# Table of Contents

## Installing the Gliffy for Confluence Plugin
- Automated Installation ................................................................. 3
- Manual Installation ......................................................................... 6
- Updating the Gliffy for Confluence Plugin ..................................... 8
- Locating Your Support Entitlement Number (SEN) ........................ 11
- Gliffy Plugin Administration ........................................................ 12
- Setting Your Language Preference ............................................... 14

## Adding Gliffy Diagrams to Confluence
- Accessing the Gliffy Start Screen .................................................. 18
- Creating a New Diagram ................................................................. 22
- Importing Diagrams ..................................................................... 23
- Creating a New Diagram Based on an Existing Diagram ............. 24
- Inserting an Existing Diagram ....................................................... 25
- Editing an Existing Diagram .......................................................... 28
- Renaming and Deleting Diagrams .................................................. 31
- Changing the Display of a Diagram .............................................. 32
- Using Version Pinning ................................................................... 34

## Using the Gliffy Editor
- The Drawing Stage ......................................................................... 43
  - Using Tabs ................................................................................ 44
- The Toolbar ................................................................................... 45
- The Menu Bar ............................................................................... 46
- Shape Libraries ............................................................................ 48
  - Customizing and Managing the Shape Library ......................... 49
  - Searching the Shape Library ...................................................... 54

## Gliffy Basics
- Adding Elements to the Drawing Stage ........................................ 57
  - Adding Library Symbols .......................................................... 58
  - Adding Images .......................................................................... 59
  - The Text Tool .......................................................................... 60
  - The Ellipse and Rectangle Tools ................................................ 61
  - The Connector and Line Tools .................................................... 62
- Moving and Manipulating Objects ................................................. 63
  - Moving Shapes and Symbols ...................................................... 64
  - Moving Lines and Connectors .................................................... 65
Installing the Gliffy for Confluence Plugin

This section outlines the installation and update processes for the Gliffy for Confluence Plugin.
Automated Installation

1. Open the Confluence administration menu and select Add-ons (must have Admin rights) as shown below:

2. Log in with your Confluence Admin credentials.
3. In the left menu, select Find new add-ons to open your Universal Plugin Manager (UPM).
4. Search the Marketplace for Gliffy.
5. Click Install.

6. The plugin will be automatically installed.
If you are not already a Gliffy customer, you will start a free 30 day trial. Before your trial expires, be sure to purchase a license.
Manual Installation

1. Download the Gliffy Confluence Plugin OBR file from our download page.
2. Open the Confluence administration menu and select Add-ons (must have Admin rights).
3. Log in with your Confluence Admin credentials.
4. In the left menu, select Manage add-ons.
5. Select Upload add-on.
6. Browse your computer for the Gliffy Confluence Plugin OBR file you downloaded in step 1 and click Upload.
7. The plugin will be uploaded to Confluence and will be automatically installed. Check the Manage add-ons screen to ensure that the plugin is available.

* If you are not already a Gliffy customer, you will start a free 30 day trial. Before your trial expires, be sure to purchase a license.
Updating the Gliffy for Confluence Plugin

This article applies only to Gliffy for Confluence Server. If you use the Cloud version of Confluence, you cannot update plugin versions yourself. Atlassian will release updates to you based on their release schedule.

As long as you have an active Gliffy license, you can update the Plugin any time from the Universal Plugin Manager (UPM):

1. Open the Confluence administration menu and select Add-ons (must have Admin rights).

2. Log in with your Confluence Admin credentials.

3. In the left menu, select Manage Add-ons to open your Universal Plugin Manager (UPM).

4. Use the drop-down menu at the top to select Action Required add-ons.

5. If there is an available update for Gliffy, click on Gliffy Diagrams for Confluence then click the Update button.
6. The update should show a “Success!” screen if installed successfully.
If your Gliffy license has expired, you will need to renew your license before you can install the update.
Locating Your Support Entitlement Number (SEN)

You can locate your Support Entitlement Number (SEN) / Customer ID by opening up the Gliffy Editor, either by creating a new diagram or editing an existing one.

Once the Gliffy Editor is open click on the Help menu in the upper-right corner of the canvas. Scroll down to Customer ID.

Users with Admin rights can also locate the SEN under their Gliffy Plugin Administration.
Gliffy Plugin Administration

1. Users with Admin access can access the Gliffy Confluence Plugin area by opening the Confluence Administration menu and select Add-ons.

2. Click into Manage Add-ons->Gliffy Diagrams for Confluence.

3. Here you can locate and update your license information.
Create Gliffy diagrams in Confluence

You can learn how to configure, use, and share this add-on by getting started below.

- Get started
- Configure
- Uninstall
- Disable

Version: 6.8.8
Vendor: Gliffy, Inc.
Add-on key: com.gliffy.integration.confluence
License details: 50-user commercial license, Standard, expires Oct 04, 2016
License status: Valid
License SEN: SEN-2844
License key: [Blank]

Watch add-on
Marketplace listing
Full pricing details
94 of 94 modules enabled

Screenshots (8)
Setting Your Language Preference

When using the Confluence Plugin version 5.4 and above, you can set your Language Preference from the Confluence login page, and your language will follow you throughout Gliffy. All of Gliffy’s labels will now be viewable in the language of your choice. You can choose from:

- German
- English
- French
- Swedish
- Dutch
- Finnish
- Norwegian
- Japanese
- Russian
- Spanish (Available in version 6.3 and above)

For Swedish, Dutch, Finnish, Norwegian, Japanese and Russian languages, you will need to install the appropriate Confluence language pack.

Simply select the language preference at the bottom of the Confluence login page.
The language preference you set in Confluence will now auto-translate for you all throughout Gliffy.
Adding Gliffy Diagrams to Confluence
Accessing the Gliffy Start Screen

The Gliffy Start Screen dialog lets you add diagrams to your pages. There are three ways to access the Gliffy Start Screen:

1. From an edited Wiki page, go to Insert -> Gliffy Diagram.
2. If you are editing a page and prefer keyboard shortcuts, type the macro: “{gliffy”.
3. You can use the Blueprint feature to start a new blank page with a Gliffy diagram. To access this click the Create button at the top of any Confluence page. A window will open and you can select “Add a blank page with a Gliffy Diagram”. 
You can also use the Blueprint feature to add or customise templates for a selected space.
Clicking on that link will bring you out to the Space Templates in Confluence. Click on “Add New Space Template” and this will start a new page for you.

You can name your Space Template, then select Insert->Gliffy Diagram. Here you can only search for an existing diagram, or use a Gliffy template in your Space Template. Gliffy diagrams cannot be created or edited in templates. If you need to edit a diagram in a template, please edit the diagram from the page where it is attached and changes will be reflected here.
To remove a Space Template, click the “Remove” button.
Creating a New Diagram

To create a new blank diagram, select Create a New Diagram from the Gliffy Start Screen, select Blank, then click Create (or just double-click).

To start a diagram using a Gliffy Template, click into the category you want on the left, then choose the template you want and click Create (or just double-click).
Importing Diagrams

If you have a file ready, you can import an existing Gliffy diagram that has been saved in .gon, .gliffy or .gxml format, or a Visio diagram that have been saved as .vdx files or .vsdx and exported from Visio (Gliffy v6.7 and above):

1. Open the Gliffy Start Screen.
2. Select Import a Diagram from the menu.
3. Click Browse to locate your file.
4. Double-click on your file to select it. You will then be launched into the Gliffy Editor.
Creating a New Diagram Based on an Existing Diagram

You can use any diagram that already exists on any page within your Confluence as a starting point for a new diagram:

1. Open the Gliffy Start Screen.
2. Select Search for a Diagram from the menu.
3. Type in the diagram name, select the space in which it was created, and hit Enter on your keyboard to Search.
4. Select the diagram from the list and click Use as a Template.
Inserting an Existing Diagram

You can also insert an existing diagram into a new page without creating a new diagram.

To insert an existing diagram into a new page, do the following:

1. From the page where you would like the diagram to appear, open the Gliffy Start Screen.
2. On the left side of the Gliffy Start Screen, click Search for a Diagram.
3. Type in the diagram name, select the space in which it was created, and hit Enter on your keyboard, or choose from the populated list below.
4. Select the diagram from the list and click Use as a Template.

Note that, in the case of an inserted diagram, if you select the option to Link to Original Diagram, any changes will affect the original diagram and will be reflected anywhere that diagram appears. If you leave this unchecked, it will create a new diagram that is not tied to the original.
To link a diagram to an existing diagram, do the following:

1. From the page where you would like the diagram to appear, open the Gliffy Start Screen.
2. On the left side of the Gliffy Start Screen, click Search for a Diagram.
3. Type in the diagram name, select the space in which it was created, and hit Enter on your keyboard.
4. Select the diagram from the list and check off the Link to Original Diagram box.
5. Click Insert Diagram.

If you link a diagram to an existing one, this will be reflected in the HTML5 viewer on the unedited Confluence page. Clicking on the “link” icon will direct you to the linked diagram connected to it.
Editing an Existing Diagram

Edit an existing diagram while viewing a Confluence page (Gliffy v6.2 and above):

1. Hover your mouse over the diagram.
2. Click the Edit (pencil) button.

Edit an existing diagram while viewing a Confluence page (Gliffy v6.1.2 and below, no longer formally supported):
1. Hover your mouse over the diagram.
2. Click the Edit button.

Edit an existing diagram while editing a Confluence page:

1. Edit the page in Confluence.
2. Select the diagram.
3. Click the Edit button at the bottom or double-click your mouse on the diagram.
4. You will then be launched into the Gliffy Editor.
Renaming and Deleting Diagrams

You can rename or delete any diagram from the Confluence page where it was created. Go to Tools -> Attachments to locate your diagram files.

**Rename a diagram:**

1. Go to the page in Confluence the Gliffy Diagram is attached to and select Tools -> Attachments.
2. Locate your diagram in the list. Under Comments, it will be described as GLIFFY DIAGRAM. Click Properties.
3. Change the File Name and click Save.
4. Return to the Confluence page. You will see a Gliffy Macro Error where the diagram should be. Edit the page.
5. Delete the broken macro.
6. Go to Insert -> Gliffy Diagram.
7. On the left side of the Gliffy Start Screen, click Search for a Diagram.
8. Select Last Modified from the menu.
9. Locate your updated diagram name on the list. Select it and click the “Link to Original Diagram” box in the bottom left-hand corner.
10. Click Insert Diagram in bottom right-hand corner

**Delete a diagram:**

1. Go to Tools -> Attachments.
2. Locate your diagram in the list. Under Comments, it will be described as GLIFFY DIAGRAM. Click Remove.
3. You will get a message asking you to confirm the delete. Click Remove again.
4. Return to the Confluence page. You will see a Gliffy Macro Error where the diagram should be. Edit the page.
5. Delete the broken macro.
Changing the Display of a Diagram

Clicking on your diagram in Confluence while in Edit mode on the Confluence page will make the Properties Buttons appear at the bottom and allow you to change the way your diagram appears on the page.

- Clicking on the Edit button will launch you into the Gliffy Editor
- Clicking on the various Size buttons will make your diagram appear small, medium, or large on the page
- Clicking on Original will set the diagram back to its original size
- Clicking Border will create a border around your diagram
- Clicking More will give you options to manually change the pixel size of your diagram, to show the “Full” Chrome or “None”, or turn off the Interactive HTML5 Viewer per diagram
- Clicking Remove will remove the diagram from your Confluence page
Additional Options

Size

### (width in px), T (140px), S (1/3), M (2/3), L (1/1)

Viewer Toolbar

**Full**

"Full" displays Edit/Zoom controls

- Interactive HTML5 Viewer
  
  Fall back to PNG image when disabled

[Update]  [Cancel]
Using Version Pinning

Version Pinning is available in Gliffy for Confluence version 6.5 and up.

You can pin previous versions of your Gliffy Diagrams to show on your Confluence page instead of just the current one.

To change the version you want to display on the Confluence page, you must first edit the page in Confluence. Version pinning can only be done after the Confluence page has been edited.

Once edited, click once on the diagram and the properties panel will appear below it. Click on Version.
Once you click on Version, the Version modal will appear.
Here you can drop-down the version menu to select what version you want to show.
As you select the versions, it will show you a thumbnail preview of the diagram you are choosing to display.
Once you have decided what version you want to show, click Update.
After clicking Update, the version you chose will show on the diagram page with the version number showing in the Gliffy Macro pane.
Click Save on the Confluence page to save your changes. Your new version will now show on the Confluence page.
Version Demo Page

Created by Katy Kelly, last modified just a moment ago

Version Pinning Diagram (v3):

1
2
3

Like

Be the first to like this

Write a comment...
Using the Gliffy Editor
The Drawing Stage

The Drawing Stage is where you build your documents. Drag shapes from the symbol libraries or create elements using the toolbar to create flowcharts, diagrams, schematics, wireframes, floor plans, or whatever else you desire.

The bottom and side scroll bars help you move around in larger documents. Holding down the spacebar while you click and drag lets you pan around the canvas. And, if you have a mouse with a scroll wheel, you can use that, too!
Using Tabs

Tab functionality was removed in Gliffy version 6.8.7, and subsequent version, as copy/paste in the same browser tab is not currently a supported feature. Copy/Paste in separate browser tabs is supported.

You can open multiple diagrams at once with the tab feature. To open a second diagram, click the + tab, and use the Open Diagram dialog to navigate to your second diagram.
The Toolbar

1. Undo/Redo
2. Group/Ungroup
3. Bring to Front/Send to Back
4. Hyperlink Tool
5. Pop-up Notes Tool (v6.2 and above)
6. Copy Style Tool (v6.6 and above)
7. Text Tool
8. Ellipse/Rectangle Tool
9. Connector/Straight Line Tool
10. Pointer
11. Pan
12. Zoom Level
13. Zoom in/Zoom out
14. Drawing Guides
15. Show Grid
16. Snap to Grid
17. Themes
18. Layers (v6.6 and above)
The Menu Bar

The Menu Bar provides access to the File and Edit menu commands needed to save, edit, and export your documents.

The File Menu lets you Open, Save, Save As, Save and Close, Close, Export your diagram in SVG, Gliffy, JPG, or PNG format, view Revision History, setup Document Properties, Page Setup and Print.

The Edit Menu contains standard copy and paste commands, all of which have keyboard shortcuts. Copy and paste are also accessible using the context menu by right-clicking or control+click. You should also take note of the Group and Ungroup commands found here. These commands allow you to combine text boxes, shapes and lines into clusters that can be manipulated as a single object.
<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Group</td>
<td>Ctrl+G</td>
</tr>
<tr>
<td>Ungroup</td>
<td>Ctrl+U</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Duplicate</td>
<td>Ctrl+D</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete</td>
</tr>
</tbody>
</table>
Shape Libraries

To expand any shape library and browse the shapes it contains, click that library tab in the left menu.

Hover your mouse over any shape to see a brief description. Drag and drop any shape from any library right onto the Drawing Canvas.
Customizing and Managing the Shape Library

If you do not see the Shape Library you want on the left side of the Drawing Canvas, you can click on More Shapes which will open up the More Shapes dialog and will allow you to customize your shape library.

Clicking on the individual shape library names expands that chosen section to allow browsing the shapes it contains. You can click and select or de-select libraries you want to add or remove.

You can also add your own shape libraries by clicking on the "+Add Custom Library" button at the top of the More Shapes area.
Once the Custom Library dialog appears you can add your own JPG, PNG, GIF, and SVG files to it. Please keep in mind there is currently a limit of 30 images per library and a limit of 1MB per image.

You'll also need to name your custom library before you click Save Library.

p(banner tip). Your Library will not save without a name!

The Hide Sidebar button is located at the bottom of the symbol library panel, to the left of the drawing canvas and to the right of the “More Shapes” button. It allows you to hide any symbol libraries that you don’t want to currently show in the drawing pane.
You can also Expand/Collapse all the libraries to make them easier to navigate.
If you click on the **Move** button in a shape library, you can move the libraries up/down on your list and re-order them as you like. Clicking on the “x” in the shape library title bar will remove it from your library pane. You can bring it back at anytime by going into More Shapes.

To manage your custom shape library, click on the title of it in the sidebar then click on the gear wheel to show the Custom Library Options. Here you can:

- Edit this Library
- Remove from Favorites
- Remove from Sidebar
- Delete Permanently
Searching the Shape Library

In Gliffy for Confluence v6.4 and up, you can search the shape library for keywords to help locate shapes.

The “Search Shapes” field is located in the upper left corner of the drawing canvas above the Shape Libraries:

You can search for any shape in any of the Gliffy shape libraries in this field. The shape library does not have to be showing on the left side for results to pull up.

To search, type in your search parameters and hit “Enter” on your keyboard.
Any results that match your entry will appear below the search box. You can then drag and drop any of these shapes on to your canvas.
Adding Elements to the Drawing Stage
Adding Library Symbols

Select a shape from any symbol library, then drag and drop that shape onto the Drawing Canvas. To add text, start typing. To change the style settings, click the shape and open the blue properties menu.
Adding Images

Before you can add an image to your Gliffy diagram, you need to upload it to Confluence:

1. On the Confluence page where you are building your diagram, go to Tools > Attachments.
2. Upload your image to Confluence.
3. Return to the Confluence page and Insert or Edit your Gliffy diagram.
4. Select the Images symbol library.
5. Drag your images onto the Drawing Canvas like any other element.

(SVG files can be dragged directly to the canvas)

Images can be moved, rotated, resized, or linked with connectors like any other element.

If you want to upload additional images while you are editing the diagram, click the Add Images button in the Images library. This will open the Confluence Attachments page in another browser tab. When you have uploaded your image, return to Gliffy and click the Refresh button. The new image will be available to use.

There is a 1MB limit for PNG, JPG, and GIF files. There is a 500MB limit for SVG files.
The Text Tool

Click the Text Tool button in the toolbar. Click anywhere on the Drawing Canvas and start typing. To define the width of your text box, select the Text Tool from the toolbar and draw the box anywhere on the Drawing Canvas with a click-drag-release, then start typing. Text box height expands automatically as you type. To change text style settings, click the text box and open the blue properties menu.

Text boxes behave like any other Gliffy element, and can be easily moved, resized, and rotated.
The Ellipse and Rectangle Tools

Click the appropriate Ellipse or Rectangle button in the toolbar. Click anywhere on the Drawing Canvas and draw your shape with a click-drag-release. To change the style settings, click the shape and open the blue properties menu.
The Connector and Line Tools

The Connector Tool is most valuable when you already have other elements on the Drawing Canvas. Click the Connector button in the toolbar and connection points will appear on any symbols on the Drawing Canvas. Connect any two of these connection points with a click-drag, release. To change the style settings, click the connector and open the blue properties menu.

Unlike the Connector tool, the Straight Line Tool will only draw a perfectly straight line, with no bends or corners. But you can still use it to link connection points on symbols, if a perfectly straight line is appropriate for your diagram. Click the Straight Line Tool button in the toolbar and draw a line with a click-drag, release. You can also connect any two connection points with a click-drag, release. To change the style settings, click the line and open the blue properties menu.
Moving and Manipulating Objects
Moving Shapes and Symbols

To move any element or group of elements, click it, then drag and drop it anywhere you like on the Drawing Canvas. While you’re moving the shape, you will see a bounding box and a display of the XY coordinates of the upper left corner of that object or group of objects. If you have snap-to-grid placement enabled, objects will automatically move in increments of 10 pixels. If you have drawing guides enabled, green lines will help you align the shape you are moving to the edges of other objects and red lines help you align the shape you are moving to the center of other objects.

You can also specify an exact location for any shape or group of shapes:

1. Select the shape or group of shapes.
2. Open the blue properties menu.
3. In the X field, set the X coordinate for the upper left corner of the shape or group.
4. In the Y field, set the Y coordinate for the upper left corner of the shape or group.
Moving Lines and Connectors

Instead of boundary boxes, lines and connectors have small circles defining each endpoint and, in the case of connectors with more than two segments, one to control each middle segment. If you click on the line or connector anywhere but on these circles, you'll move the entire line without changing its shape. Clicking and dragging the circles will move only that end of the line or connector. If you move the shape that a line or connector is linked to, the line or connector will adjust to maintain the connection.
Resizing Objects

To resize any element or group of elements, select it so that the bounding box appears. Click any corner of the bounding box and drag it until the shape or group of shapes is the correct size. While you’re resizing the shape, you will see a display of the dimensions of the object. If you have snap-to-grid placement enabled, objects will automatically resize to increments of 10 pixels. If you have drawing guides enabled, green lines will help you resize the shape in alignment to the edges of other objects and red lines help you resize the shape in alignment to the center of other objects.

You can also specify exact dimensions for any shape or group of shapes:

1. Select the shape or group of shapes.
2. Open the blue properties menu.
3. In the W field, define the width, in pixels.
4. In the H field, define the height, in pixels.

![Image of a shape with dimensions](image)

Certain shapes, particularly complex Network or Floorplan symbols, have a locked aspect ratio, which will affect how they resize. You can easily lock or unlock the aspect ratio for any shape:

1. Select the shape.
2. Open the blue properties menu.
3. Check or uncheck the Lock Aspect Ratio box.
Rotating Objects

To rotate any element or group of elements, select the shape or group of shapes. A bounding box will appear with a rotation icon at the top. Click the rotation icon, drag it into the correct orientation, then release. While you are rotating the element, you will see a display of the rotation in degrees. If you have snap-to-grid placement enabled, objects will automatically rotate in increments of 5 degrees.

You can also specify exact rotation for any shape or group of shapes:

1. Select the shape or group of shapes.
2. Open the blue properties menu.
3. In the Rotation field, define the exact rotation in degrees clockwise.
Locking and Unlocking Objects

If you have carefully positioned an element and want to be sure that you don’t accidently move it while you edit the rest of your diagram, you want to lock that element:

1. Select the shape.
2. Open the blue properties menu.
3. Check (or uncheck) the Lock Shape box.

Note that if you select a locked and unlocked shape in the same group, you will be able to move both shapes together as if they were an unlocked group. When the group is released, the locked object will be locked to its new position.
Grouping and Ungrouping Objects

If you have carefully positioned several elements in relation to each other, and you want to be able to move and manipulate them as if they were a single object, you can add them to a Group:

1. Select the shapes.
2. Click the Group button in the toolbar.

To break up the group and treat each element as an individual object again, select the group and click the Ungroup button.
Using Bring to Front/Send to Back

If you have positioned an element correctly, but it overlaps with other objects in a way you don’t like, you can move any object into the foreground or background:

1. Select the shape or shapes.
2. Click the Bring to Front or Send to Back button in the toolbar.

This feature is especially helpful if you are using shapes or images as a background for your diagram.
Evenly Distributed Shapes

You can align and evenly distribute a group of shapes on your diagram. To do so, select the shapes you’re working with, click the blue properties menu that appears next to your shapes, and then use the various Align and Distribute buttons to make them distributed the way you want.

Align Options

- Align left
- Align center
- Align right
- Align top
- Align middle
- Align bottom

Aligning takes all the selected shapes and aligns them with the shape that is furthest to the left, center, right, etc. depending on what you select.

Distribute Options

- Distribute vertical center
- Distribute horizontal center
Distributing takes all the selected shapes and distributes them evenly either vertically or horizontally depending on what you select.
Using Themes

You can choose to apply color themes to your diagram for quick and easy styling. Clicking the Diagram Themes button from the Toolbar will open up the Themes box on the right side of your diagram.

This moveable box can be moved anywhere on your canvas.

Hovering over each theme creates a preview of it applied to the diagram on your drawing canvas. Clicking on the theme applies it to your diagram.
To undo an applied theme, select Edit-&gt;Undo, or Ctrl+Z.

Completed diagram with no theme:

![Diagram Theme applied](image)

Diagram Theme applied:

![Diagram Theme applied](image)

Please note that themes only work on flowchart and basic shape types.
Changing Object Styles
Shapes and Symbols

To change the style of any shape or symbol, select it then click the blue button to open the properties menu. You can make the following adjustments (some options are not available on all elements):

- Change the Shape Color. (On some of the more complex shapes, such a Network symbols, only part of the object had a customizable color.)
- Change the Border Color.
- Change the Border Thickness.
- Change the Border Pattern.
- Toggle the Gradient on and off.
- Toggle the Drop Shadow on and off.
- Adjust the Shape Opacity.
- Set the X/Y coordinates of the upper left corner of the element.
- Set the Width and Height of the element.
- Specify a Rotation for the element.
- Lock or unlock the element Aspect Ratio.
- Lock or Unlock the element position.
Lines and Connectors

To change to style of any line or connector, select it then click the blue button to open the line properties menu. You can make the following adjustments:

- Set the Beginning Arrow style.
- Set the End Arrow style.
- Change the Line Color.
- Change the Line Thickness.
- Change the Line Style to dotted, dashed, or solid.
- Change the Line Type to straight line, sharp corners, rounded corners, or smooth curves.
Text

You can add text to almost any element: shapes, symbols, lines, and connectors. To add text, just select the element and start typing. Once an element has text associated with it, you will be able to modify the text style.

To change the text style for an entire element, select that element (or group of elements) then click the blue button to open the text properties menu. If you only want to change a single letter, word, or phrase within an element, double-click the element to enter Text Edit mode, then highlight the words you want to modify. You can make the following adjustments:

- Set the text to Bold, Italic, or Underline.
- Change the text Alignment to left, center, or right.
- Change the Font Family.
- Change the Font Size.
- Insert or remove a Hyperlink.
- Change the Font Color.
Copying Styles

You can copy a style from one shape or connector to other shapes and connectors.

Start by setting a style for a shape or connector, then click on the shape to activate the Copy Style paintbrush icon in the Toolbar.

Clicking on the paintbrush will copy the style of the shape or connector you selected and your pointer will show as a paintbrush.
Click on the shape or connector you want to paste the style to and this will then make them have the same styles.
If you want to paste styles to multiple shapes, click the shape you want to copy and click the Copy Style icon.

Circle the shapes/connectors you want to apply the style to with your mouse.
Once you release your mouse it will change all the shapes in the selected area.
Viewing and Managing the Diagram Stage
Document Properties

Selecting File->Document Properties will open up the Document Properties panel for the diagram you are in. By default, the Width and Height of the staging area are set to $5000 \times 5000$ pixels and is the maximum size for a diagram. You can set the limits for your diagram size here.

You can also choose to export the border of your diagram and set your background color here.
Transparent Background

You can change the background on your diagram to be transparent. You can set this under File->Document Properties and set the Background to be No Fill.
Drawing Guides

If you have drawing guides enabled, green lines will help you move or resize shapes in alignment to the edges of other objects and red lines help you move or resize shapes in alignment to the center of other objects.

You can easily toggle drawing guides on and off again with the Drawing Guides button in the toolbar.
Show Grid

The Show Grid button turns the grid on the canvas on/off.
Snap to Grid

By default, Snap To Grid placement is enabled on your diagrams so that you move or place objects in increments of 10 pixels. You can easily toggle snap-to-grid off and on again in the Toolbar.
Zoom

If you want to get a closer (or wider) look at your diagram, you can use the Zoom dropdown in the toolbar to set the zoom.

The + Zoom and – Zoom buttons give you a tool that allows you to zoom in (or out) on a specific area of the diagram by clicking the Drawing Canvas.

You can also zoom in a very specific area by selecting the + Zoom tool and drawing a rectangle around that area with a click-drag-release.
Pan

If you want to move around a large diagram without using the browser’s scroll bars, the Pan tool lets you pan through the visible area of your Drawing Canvas: just click, drag, and release.

If you want a quick shortcut, holding down the space bar on your keyboard automatically switches your cursor to the pan tool.
Saving and Returning to Confluence

The Save button in the upper right corner will let you save the diagram. If this is the first time you’re saving the diagram, you will be prompted to enter a name.

The Exit link in the upper right corner will return you to your Confluence page. If you have not already saved the diagram, you will receive a warning asking to confirm the navigation. If you leave without saving, your most recent edits may be lost.

You can also go to File->Save and Close to leave the Gliffy Editor.

⚠️ You will need to name the diagram before you can exit
File  Edit

Save            Ctrl+S
Save As

Save and Close

Close

Export…

Revision History
Document Properties
Page Setup

Print
Using Save As

You can use the Save As function to save and name your diagram as a new one to the existing page in Confluence or to a new page.

Start by clicking Edit on an existing named diagram from a Confluence page.

Once the diagram is open, go to File->Save As.
This will open the Save As modal. You can change the name of your new diagram at the top. If you want to save this to the existing page you are on, select This Page.
If you select New Page, you can create and name a new page in Confluence and also save your diagram there right from the modal. Type in the name of your new page name and select the space you want it in.
If you do not see the space you need on the dropdown menu, use your keyboard to delete the text and as you type it will search through your spaces.
Lastly, you can search for an existing page to save your diagram to.
If you do not see the page you want, you can use the search bar to type and search for a space.
Once you choose the page and space you want to save to, select it and it will highlight blue. Click Save.
After you save, it will refresh the screen and place you into the new copy of your diagram. It will then confirm in green a temporary message that lists the name of your diagram and the page and space it was saved to.
Main Headline Goes Here

Subtitle goes here
Autosave

Autosave is controlled in the Gliffy Plugin Configuration and can be enabled/disabled by users with Admin rights: https://www.gliffy.com/user-manual/?productId=1#article_186

Gliffy for Confluence does autosave, but it works conditionally based on a few things:

1. You must be connected to the internet (and logged into your Confluence instance).
2. You must have already saved a first version of the diagram. Thus, autosave does not work on a diagram that has never been saved and has no name (we recommend saving and naming the page in Confluence first: http://support.gliffy.com/entries/53986104-Gliffy-Diagram-Saved-But-Not-Attached-to-Page)
3. The underlying Confluence page must have been saved as well.
4. Autosave must not have been disabled by your system administrator in the global Gliffy Confluence settings.

Please see this forum post for additional information: http://support.gliffy.com/entries/96131957-Diagram-autosave-and-drafts-in-Gliffy-for-Confluence-how-to-recover-lost-diagrams-
Exporting Diagrams

Gliffy allows you to export your diagram in several formats. To export your diagram, go to File->Export.

If you select PNG or JPG you will have the option to set the resolution up to 400%

The SVG and Gliffy file options have one standard.
## Export...

<table>
<thead>
<tr>
<th>File Format</th>
<th>Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>PNG</td>
<td>Screen Size (100%)</td>
</tr>
<tr>
<td>JPG</td>
<td>Medium (200%)</td>
</tr>
<tr>
<td>SVG</td>
<td>Large (300%)</td>
</tr>
<tr>
<td></td>
<td>Extra-Large (400%)</td>
</tr>
</tbody>
</table>

[Export] [Cancel]
Using Revision History

Every time you save a diagram, Gliffy keeps a record of that version. At any time, you can revert to an earlier saved version of your diagram:

1. Go to File -> Revision History.
2. Select the version you would like to recover and click Okay.
3. If you have not saved the currently active version of the diagram, you will be asked to confirm. You can choose to Continue Working on the current unsaved diagram, or you can Open Revision to discard the active diagram and restore the earlier version.
**The HTML5 Viewer**

Gliffy diagrams are displayed on Confluence pages using our HTML5 viewer as live web content, not just static images. This makes it much easier to interact with your diagrams without switching into edit mode. Placing your mouse cursor over the diagram within Confluence will make the Chrome appear.
Preview and Zoom

If you roll your mouse over an in-page diagram and you’ll see a button that says Fullscreen.

Clicking on the Fullscreen arrows will open the thumbnail in a full-size preview where you can do various actions
Demo Page

Created by Katy Kelly 7 minutes ago

Entity Relationship (ERD)

Room
- Room Number
  - Staffed By
  - Occupied By

Doctor
- Employee Id
- First Name
- Last Name
  - Primary Care
  - Provides

Patient
- Patient Id
- First Name
- Last Name
  - Receives

Nurse
- Employees Id
- First Name
- Last Name
  - Supervises

Prescription
- Prescription Id
  - Contains

Drug
- Drug Id
- Drug Name
1. Edit diagram (will launch you into Gliffy Editor)
2. Fit to Page
3. Show/Hide Pop-up Notes
4. Zoom bar
5. Close thumbnail (will take you back to Confluence)
Links and Text

Because Gliffy diagrams are rendered in HTML5, any text in the diagram behaves just like page text. You can copy text from a diagram to paste into other applications. You can search a page for any term in the diagram. And of course all the links in your diagrams are live and clickable.
Printing Diagrams

Printing directly from the Gliffy Editor is available in Gliffy for Confluence v6.6 and above.

To print your diagram, go to File->Print.

Some browsers have different behaviors when printing.

**Chrome Browser:** In Chrome, you will need to set your margins to “None” in the print system dialog that comes up after you click “Next”.

![File menu with Print option highlighted](image)
For all browsers you will need to also make sure you have your Paper Size and Page Orientation set correctly in the print dialog screen that comes up after you click “Next”.
Page Setup

Under File->Page Setup, you can select the Paper Size for your diagram, set the paper orientation to Portrait or Landscape, and Display Page Breaks to show within the drawing canvas to show how your diagram will print.

Paper Size options:
Display Page Breaks:

Page Setup

Paper Size
Letter (8.5in x 11in)

- Portrait
- Landscape
- Display Page Breaks

Close

Phone Tree, v1

Welcome to the ABC Credit Union
(Please expect a call back)

For information about opening an account, please
contact your branch manager or call 555-1234.

ACCOUNT OPENING

For your convenience, our staff is available to
assist you.

Press 1

For your account

Press 2

For new account

Press 3

For loan

Press 4

For mortgage

Press 5

For investment

Press 6

For insurance

Press 7

For credit

Press 8

For more information, visit our website

www.abccreditunion.com

Thank you for choosing ABC Credit Union.

Save
Once you have this setup the way you want, click “Close” to exit the Page Setup screen.
Working with Shapes and Lines

You can add shapes to the Drawing Stage in two ways:

- Draw them with the Ellipse or Rectangle Tool
- Drag them in from the Shape Library

You can draw connectors and lines using the Connector Tool and the Line Tool.
Using the Ellipse and Rectangle Tools

The most basic way to draw shapes is using the Ellipse and Rectangle Tool in the Toolbar. These tools work identically – one draws a shape with rounded corners and the other draws a shape with right angle corners.

There’s no trick to using either tool. Just select the tool you want from the Toolbar and draw by clicking, dragging and releasing. The first place on the Drawing Stage that you click defines the first corner of the shape’s boundary box. As you drag your mouse with the button depressed, the box grows. When you release the mouse button, the ellipse or rectangle is created to fill the boundary box you’ve drawn.
Using the Shape Library

If you’re using shapes from the Shape Library, it’s even easier. First find the shape you want. Next click it then drag it onto the Drawing Stage and drop it at the destination.
### Moving and Manipulating Shapes

Any shape can be resized, rotated or moved once it’s been placed upon the Drawing Stage. You can use the little squares that appear in any selected shape’s boundary box’s corners or midpoints to extend the dimensions of the shape. Just click and drag them. To rotate a shape, click and drag the curled arrow that you’ll see above the selected shape.

Also worth noting is the ability to lock a shape to its current dimensions. To do this mark the “Lock Shape” box in the shape’s Properties Panel that appears to the right of the shape. (Using Gliffy Online, you can also right click on a shape and select “Lock Shape” from the context menu).

When you lock a shape, the little squares around the boundary box turn red to indicate the shape is fixed. You will not be able to change the dimensions, or other properties, of the shape until you unlock the shape.
Setting Shape Properties

When you select a shape, you can edit its properties using the Properties Panel. At the top of the shape properties section, you will see several icons that control the shape’s appearance.

- **Shape Color**
- **Border Color**
- **Border Thickness**
- **Line Pattern**
- **Gradient**
- **Drop Shadow**
- **Shape Opacity**

The **Shape Color** icon lets you choose what color fill you want the selected shape to have.

The **Border Color** icon controls the color of the shape’s border.

The **Border Thickness** icon determines how thick the shape’s border is, or whether it has a border at all.

The **Line Pattern** icon determines what type of pattern the border of the shape will have.

The **Gradient** icon allows you to turn the gradient on or off and the fill color will transition from lighter to darker from top to bottom.

The **Drop Shadow** icon allows you to add shadows to your shapes that suggest depth.

The **Shape Opacity** icon allows you to add opacity to Basic and Flowchart shapes.
If you find your mouse isn't giving you the level of control you want, you can also use the Size, Position and Rotation properties to specify the exact dimensions, location and angle of rotation of the selected shape. The position coordinates correspond to the position of the upper left corner of the shape’s boundary box.

On the right side of the Properties Panel, you'll also see check boxes for “Aspect Ratio” and “Lock Shape”. Marking the “Aspect Ratio” box forces the selected shape to retain its current shape, but not its size. You can still make an ellipse or rectangle larger or smaller, but it will hold its aspect ratio. “Lock Shape” not only secures the aspect ratio, but also secures the size, color and other properties of the selected shape.
Shape Opacity

You can control the opacity of Basic and Flowchart shapes. Click into the blue shape properties box that appears next to the shape and you will see a Shape Opacity icon.

You can manually type in a value or use the scroll bar to adjust the opacity on your shape.
Linking Shapes

You can hyperlink entire shapes instead of just text.

Please note, this feature is not available on multi-part shapes, such as swimlanes, certain UML shapes, tables, etc.

To link a shape, click once on it so it is highlighted, then click the “Create Link” button in the Toolbar.

After clicking the “Create Link” button, a modal will open to allow you to enter a link to another diagram or a URL. This works the same as the Hyperlink Navigator.
After entering the link to the diagram or URL you want, click “Insert” to add it.
After inserting the link, your shape will show an icon in the lower right corner. This indicates that the shape is linked.
If you want to remove the shape link icon, check the “Hide Link Icon” box when setting up your link.
Clicking on the shape will show the URL it is linked to. You can Go to the link, Edit the link, or Unlink from this menu.
Gliffy provides guides to help you line up your shapes with other shapes. To turn on the Drawing Guides, click on the **Drawing Guides** button in the Toolbar. Now, when you drag a shape from somewhere on the stage or from the shape library, it will detect if another shape in its vicinity has a matching edge or center point. If there is a matching edge, the shape you are dragging will "snap" to the other shapes edge, and a green line will appear to show the alignment. The same goes with a center point, except the line will be red. See the image below as an example of a left edge and center point alignment on the X axis.
Using the Connector and Line Tools

The Connector and Line Tools work identically to each other.

The Connector Tool lets you draw a line forced to turn at right angles where necessary and the Line Tool draws a straight line between whichever endpoints you select, with no turns. To draw either a connector or a line, select the appropriate tool from the Toolbar, place your cursor where you want your connector or line to start and click and drag to your desired endpoint.
Moving and Locking Lines and Connectors

Once you’ve drawn a line or connector you’ll notice a characteristic about each endpoint: if it’s a connector with more than two segments, each middle segment has a little circle. These circles work like the squares around the boundary boxes of shapes. If you click and drag on one of the circles, you’ll only adjust that segment of the line/connector. If you click anywhere else, you’ll move the whole line.

Frequently, you’ll want to connect the end of a line to a shape so that if the shape moves, the line will stick to the shape. When you select a line, you’ll see that all the shapes in your diagram become flanked with little ‘+’ symbols. There should be one in the middle of each shape as well. These ‘+’ symbols are standard connection points. If you drag the endpoint of a line or connector to one, you’ll see the little circle turn green. That indicates the line is locked to the connection point. From then on, if you move the shape, the line will remain connected.

When initially drawing a line or connector, you can start off on a connection point—if the connection point shows a green circle, your line will be locked to it.
Infinite Connection Points

You can attach your connectors to any outside border of certain shapes within Gliffy. When you use the Connector Tool and scroll around the outside of certain square shapes, you’ll see a green circle appear. The green circle indicated where you can attach it. If you scroll all the way around you will see you can place your connector anywhere and lock it to the shape.
Setting Line and Connector Properties

When you select a line or connector, you can change its properties using the Properties Panel (just click the blue button next to the line end, see image below). You can change:

- **Line Color** icon allows you to select a color for your connector or line.
- **Line Weight** icon allows you to change how thick your lines are in pixels.
- **Line Style** icon lets you choose from a selection of different patterns for the selected line, from finely dotted to solid.
- **Line Type** icon allows you to select a type of line or connector. The first choice is a straight line. The next three are connectors: right angle, rounded corner, and Bézier Curve.

If you select any number of lines or connectors at one time, you can set properties for all of them at once.
Use the arrow icon to add a direction to your line (for most lines) as shown here. For specific shapes, like UML, ERD, BPMN, etc., you will get a selection of line end types specific to that shape type. The direction the arrows in this menu point translates as 'left = line start point' and 'right = line end point'. So if you drew your line from right to left, and select the arrow that points to the right, you'll see your line will get an arrow pointing to the left! If you consistently draw your lines/connectors from start to end, this will make adding arrows much easier.
UML Cardinality

In Gliffy for Confluence v6.0 and above, you can add cardinality to your UML lines. If you drag a UML connector line onto the canvas, you will notice some cardinality boxes appear on each side. You can then use these to add cardinality to your UML diagram.
UML Arrows

UML connectors have additional arrow ends you can use by clicking into the connector property box.
Entity-Relationship Arrows

In Gliffy for Confluence v6.0 and above, you can adjust your Entity-Relationship arrow ends to make the appropriate shape for your needs.

If you don't see a pre-made ER arrow you would like to use, pull any of them onto the canvas then click into the blue, shape properties box.

Click into the line properties and you will see a drop-down for both arrow ends. You can choose from here what type of shape you want to create.
As your document becomes more complex, you may find you need to control which elements are in the foreground and which are in the background. You can do this by selecting the desired element be it a shape, a line, or a text box) and using the *Bring to Front* icon to bring the selected element to the front or the *Send to Back* icon to send it to the back. In Gliffy Online, you can also send elements to the front or back by selecting them and right clicking to select these options in the context menu.
Using Swimlanes

The Swimlane shapes can have up to 12 lanes added to them. You can add additional swimlanes by dragging a swimlane shape out to the editor, then click the blue custom properties box:

Once you click into the shape properties, you can select the "Number of swimlanes" drop-down menu and select how many lanes you want it to have up to 12.
Using Layers

Layers can be added by clicking the Layers button in the Toolbar. This will pop-up the “Layers” panel on the right side of the drawing canvas.

Adding Layers:
Hiding Layers:
Changing Layer Order:
Locking Layer:
Duplicate Layer:
Moving and Deleting Layer:
Renaming Layers:

*Layers can be renamed by double-clicking on the existing name with your mouse. This works the same as*
editing text anywhere else in the application.
Using Pop-up Notes

The Pop-Up Note command button can be found in the Toolbar. The pop-up note can only be selected if an applicable shape is selected(clicked first (Please note this feature is currently limited to Basic and Flowchart shapes only. More shapes will be added in the future). The pop-up button will show as inactive if you do not have a shape selected first.

Once you have selected the shape you want to add a note to and click on the pop-up button, the Add Note prompt will appear.
You can type your note/comment in and when finished, click Done to add your note. Click Cancel to back out and cancel the note (there is a 250 character limit).

Once you have clicked Done, you will see a note icon in the corner of the shape. If you hover over the shape in edit mode, the note will pop-up.

If you publish your diagram as a public diagram, your notes will also show on the public view of it. Clicking on the shape will reveal the note if you have the “Show All Pop-up Notes” button selected. You can hide the notes by clicking it again. The notes will still be viewable if you click on the shape with the pop-up note icon.
To Delete a note, click on the shape with the pop-up note, click the pop-up note icon in the Toolbar, then delete the text and click “Done”.

Happy Toy Org Chart

Happy Toy Corporation

To Delete a note, click on the shape with the pop-up note, click the pop-up note icon in the Toolbar, then delete the text and click “Done”.

CEO
Julian Miller

Director of Engineering
Sally Smith

Director of Marketing
Michael Olier

Director of Sales
Eileen Frank

Director of UI
Sandra O’Cosnor

External Team 4

COO
Adam Kiniskiz

North America
Janine Metzler

Usability
Ruth Smith

Middle East
Mr. Mops

Visual Design
Claudia Elst

Design Engineer
Christian List

Front End
Naya Miller

Marketing Assistant

Asia

Development
Francis French
Working with Tables

In Gliffy for Confluence 6.4 and up, you can add tables to your diagram by going into More Shapes->Website and UI->Tables. This will open the tables section in your shape library.

Once you have pulled a table on to the diagram, you can click on a cell to select it. Shift + Click to select multiple cells. A cell is highlighted orange if currently selected.
If you want to Add/Remove columns or rows, click into the edit custom properties widget.
If you have the entire table selected, you will see these options:

- Add Column
- Remove Column
- Add Row
- Delete Row

This will insert or delete the column or row at the end.

If you have an individual cell selected, you will see these options:

- Add Column
- Remove Column
- Add Row
- Delete Row
- Insert Column
- Remove Selected Column
- Insert Row
• **Remove Selected Row**

This will add/remove/insert/remove columns or rows from the cell selected.

Max rows and columns are currently 13.

If you have a single cell or multiple cells selected, you can change the properties of these by clicking into the blue properties bar.

If you have the entire table selected and click into the shape properties, you can select the border color and thickness of your lines.

**Border Color:**
Border Thickness:

If you click into the shape properties area, you can adjust the color of your selected cells.
You can adjust the width and height of individual columns or rows by scrolling your mouse on the border lines between them. The cursor will change and you can then move the columns or rows to make them smaller or larger.

Using these features you should be able to create extensive, colorful tables in your diagrams.
### Pricing Table, v3

<table>
<thead>
<tr>
<th>Standard</th>
<th>PRO</th>
<th>BASIC</th>
</tr>
</thead>
<tbody>
<tr>
<td>$3.99 / mo paid annually</td>
<td>$7.99 / mo paid annually</td>
<td>$0 / mo</td>
</tr>
<tr>
<td>$4.95 / mo paid monthly</td>
<td>$9.95 / mo paid monthly</td>
<td>$0 / mo</td>
</tr>
<tr>
<td>200 diagrams</td>
<td>UNLIMITED diagrams</td>
<td>5 diagrams</td>
</tr>
<tr>
<td>260 MB storage space</td>
<td>UNLIMITED storage space</td>
<td>2 MB storage space</td>
</tr>
<tr>
<td>Visio Import</td>
<td>Visio Import</td>
<td>Visio Import</td>
</tr>
<tr>
<td>Google Drive Integration</td>
<td>Google Drive Integration</td>
<td>–</td>
</tr>
<tr>
<td>–</td>
<td>UML 2.0 Shapes and Templates</td>
<td>–</td>
</tr>
<tr>
<td>290 Private Diagrams</td>
<td>UNLIMITED Private Diagrams</td>
<td>NO PRIVATE DIAGRAMS</td>
</tr>
</tbody>
</table>
Mind Maps

Mind Maps are available in **Gliffy for Confluence Plugin v6.7** and above.

Mind Maps are drawn differently than flowcharts. A flowchart shows the flow of information and has a beginning and an end; a Mind Map shows information in clusters. Because Mind Maps are a brainstorming tool, they have their own set of shortcuts, making it possible for you to map as fast as your ideas flow.

Because Mind Maps are drawn differently and have a specific set of functionalities, certain browser features such as copy/paste may not be available.
How to Start a Mind Map

You can start and create a Mindmap template by doing one of the following:

1. From the Gliffy Start Screen, select "Create From a Template" and then click the Mind Map folder. Click once on the Mind Map template and click “Open” or double-click to load the template and start working.

2. From any other page, go to File -> New and then click the Mind Maps folder and template.
This will open up a Mindmaps template with a main topic and tips for creating your mindmap.

The Main Topic shape is the template anchor, so any nodes must come off of this. If this shape is removed or deleted, the Mind Map functionality and commands will not work. Mind Map commands only work on shapes in the Mind Map template.
To add a subtopic – Click an arrow or enter the CMD/CTRL + Arrow keys

To add a topic at the same level as the current topic – enter the TAB + Arrow keys

To navigate around your mindmap, use the arrow keys on your keyboard
How to Hide and Show Subtopics

To hide a node’s subtopics, click the “Collapse” button. To show the subtopics, click the “Expand” button.
How to Tidy Up Your Mind Map

Creating mindmaps can be messy! To make sure your nodes aren’t overlapping when you’re done, click the “Layout” button in the Properties panel and then “Fit to Screen.” Voila! Your mindmap is all tidy now.
Working with Text

There are two ways to add text to your document. Using the Text Tool lets you create text boxes, which can be moved and resized independently from other document elements. You can also enter text directly into elements which is easier, but offers less control.
Using The Text Tool

Selecting the Text Tool icon from the Toolbar allows you to draw a text box so you can immediately start typing in text. Text will automatically wrap at the end of a line to remain within the box you’ve drawn. If you enter more lines than will fit in the box, the text will extend above and below the borders of the text box.

When you’re done entering text, you can move, resize or rotate a text box just as you would any other shape. If you want to edit the text inside the text box, just double-click on it, you’ll notice a flashing cursor indicating you can edit the text.
Entering and Editing Text in Objects

Sometimes you’ll want to enter or edit text directly into a shape or over a line.

To enter text this way, just select the element you want, by double-clicking (or click once and hit F2 on your keyboard), and start typing.

You can edit this text at any time by double clicking on the element (or click once and hit F2). To completely remove text from an element, double click the element, highlight the text and click delete.
Setting Text Properties

Regardless of how you've entered text, you can edit the properties of selected text by clicking the Properties Panel icon. If you select a text box, an element with text typed over it, or any combination of the two, the text properties section will show up in the Properties Panel.

Here, you can choose from a list of available fonts. You also can change the font size and color, make text bold, italic and/or underlined, and change the alignment of the text. You can also add hyperlinks to text (not available in the Gliffy Plugin for JIRA).

You can set different sections of text to have different properties within the same text box or element. For example, one word in a sentence can be bold and in a larger font size. All that’s needed is to select the words you want to change the properties for and make your changes.
Changing Text Position in a Shape

You can move text in a shape to various areas in/around the shape. Clicking into the text properties area will show a Text Position button.

Clicking on Text Position will give you 5 options:

- Text Inside
- Text Above
- Text Below
- Text Left
- Text Right
Text Inside:

Text Above:
Text Below:

Text Left:
Text Right:
Vertical Alignment

When setting the text position in a shape, you can also use the Vertical Align tool to align the text. You can access this also from the text properties menu.

Vertical Align Top:

Vertical Align Middle:

Vertical Align Bottom:
Vertical alignment is currently only available on Basic and Flowchart Shapes

This alignment functionality will not work on grouped shapes
Managing Text On a Line

In Gliffy for Confluence v6.0, you can move text on a line.

If you add text to the middle of a connector and then click on it, you should see it highlighted green. This means it can be moved all around the line.

You can also enter multiple text entities on a single line. You can click anywhere on a connector line to add text and enter as many different boxes as you like.
If you add text to a connector and then click on it, you should see it highlighted green. This means it can be moved all around the line.
Linking Text

To add a hyperlink, double click on the text and highlight the words you want to turn into an active link. Click the Hyperlink icon in the text properties box and enter the desired URL, then click “Insert Link”.

You can also highlight the text you want to hyperlink and click the “Create Link” button in the Toolbar:

Clicking on the hyperlinked text will show a hyperlink editing box while in Edit mode. You can Go to the link, Edit the link, or Unlink from this menu.
Hyperlinks will remain active if viewed as a full-size image on a Gliffy Plugin for Confluence wiki page, exported as SVG or a published URL Gliffy Diagram.
Using the Context Menu

Another way to work faster with Gliffy is to use the Context Menu. The Context Menu provides access to the most commonly used commands with the click of your mouse. To access the Context Menu, right-click your mouse (for Mac users, control+click will perform the same function). The Context Menu varies based on what shapes/lines you have selected:

No shapes selected or not mousing over a shape: Option to Paste Here, Select All Objects, and Zoom

One Shape selected and mouse is over a shape: Option to Cut, Copy, Paste, Delete, Lock Selection, Bring to Front, and Send to Back

If more than one shape is selected and mouse is over a shape: You will have the options above and the option to Group or Ungroup
Keyboard Shortcuts

As you get more proficient using Gliffy, you’ll find that the built in keyboard shortcuts speed up your work. You can see a full list of keyboard shortcuts at any time by going to Help > Shape Shortcuts or Help >Document Shortcuts in the top right of the Document Editor.
Gliffy Diagrams on the Attachments Page

Confluence stores your Gliffy diagrams as attachments on the page where they were created. For every Gliffy diagram, there will be two files: the Gliffy diagram file (labeled GLIFFY DIAGRAM), and a thumbnail of your diagram saved as a PNG (labeled GLIFFY IMAGE). You can find both files by navigating to the parent page and going to Tools > Attachments.

From the attachments page, you can manage these files:

- View lets you preview how the diagram will appear in a Confluence page.
- Edit launches the diagram in the Gliffy editor.
- Properties lets you rename a file and review other details.
- Remove deletes the file permanently.

If you rename or delete a Gliffy Image, a new PNG will be automatically generated the next time you edit and save the diagram.

⚠️ If you rename or remove a Gliffy Diagram that is displayed on the page, the page will show a broken macro. Edit the page and delete the Gliffy macro or update it to point to the correct diagram name.
Version Control

You can also find previous versions of your diagrams on the attachments page. Just click the arrow at the front of the listing to expand a list of all previously saved versions of the file.

**Gliffy Images:** Click on the version number to view the PNG file.

**Gliffy Diagrams:** Click on the version number to download the diagram as a Gliffy GON file (or a Gliffy GXML file, if you are using an older version of the Gliffy Confluence Plugin).

* To revert to a previous version of a diagram, open it in the Gliffy editor and go to File > Revision History.
Hyperlink Navigator

In Gliffy, you can add a link to any text on any shape in your diagram. Because of the HTML5 viewer, these links will be active when the diagram is embedded in your page:

1. Click on the shape or highlight the text you want to link
2. Click the Create Link icon in the Toolbar
3. After clicking the “Create Link” button, a modal will open to allow you to enter a link to another diagram or a URL.

The Link Navigator lets you search for any page on any wiki in your Confluence instance, browse the Confluence pages that you have recently viewed, link to attachments on the current Confluence page, link to page content (sections formatted as h1, h2, etc.) on the current page, or set up a Web link to any URL.
Search for Confluence Pages

Select **Search** from the link navigator menu to link to another page in your Confluence instance.
Link to Recently Viewed Confluence Pages

Select **Recently Viewed** from the link navigator menu to browse the pages in Confluence you have most recently visited.
Link to Attachments

Select **Attachments** from the link navigator menu to link to any of the other attachments on this Confluence page.
Link to Page Content (Anchors)

Select Page Content from the link navigator menu to link to any content of the current page that has been formatted as a heading (h1, h2, etc.)

<table>
<thead>
<tr>
<th>Title</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>h1. Internal Resources</td>
<td>Heading 1</td>
</tr>
<tr>
<td>h1. External Resources</td>
<td>Heading 1</td>
</tr>
<tr>
<td>h1. Further Reading</td>
<td>Heading 1</td>
</tr>
</tbody>
</table>

**Tip:** Page Content (Anchors and Headers) will only be available after a save or autosave.
Link to Web Pages

Select **Web Link** from the link navigator menu to link to another page anywhere on the Web.
Protocol Filters

In Gliffy for Confluence version 5.3.1 and above, users with Admin rights can set Protocol Filters for their hyperlinks.

Users with Admin rights can access and set these by going to Confluence Admin->Gliffy Plugin Administration.

Here, you can set protocols for your hyperlinks under Allowed URL Protocols. Examples of protocols you can use are http, https, mailto, file, ftp, notes, etc.
Gliffy Plugin Administration & Configuration

Information

Plugin Version 5.3.1

Plugin Date May 13, 2013

Number of Gliffy Diagrams 7

Configuration

Autosave interval in seconds 30
(disabled = 0, minimum = 30)

Allowed URL Protocols http, https, mailto, file, ftp, notes

Comma separated protocols

Gliffy Viewer

☐ Disable HTML5 Viewer

☐ Hide Viewer Chrome

Gliffy Editor

☐ Auto Detect Browser - Fallback Flash

☐ Auto Detect Browser - Fallback HTML5

☐ HTML5 Only

☐ Flash Only

Usage Statistics

☐ Disable Usage Tracking

We will collect anonymous usage statistics to help improve Gliffy. You may globally disable all tracking by checking this box.

Submit Changes