# Table of Contents

**Welcome to Gliffy Online** ........................................................................................................................... 3

**Getting Started** ........................................................................................................................................... 4
- Using the Gliffy Start Screen .......................................................................................................................... 5
- Creating Diagrams ........................................................................................................................................ 6
  - Using Templates ........................................................................................................................................ 8
    - Creating from a Previous Diagram .......................................................................................................... 10
- Opening Diagrams ...................................................................................................................................... 11
- Importing Diagrams .................................................................................................................................. 16
- Using the Document Manager ...................................................................................................................... 19
- Renaming Diagrams .................................................................................................................................. 23
- Managing Folders ...................................................................................................................................... 26
  - Managing Folder Permissions .................................................................................................................... 30
- Deleting Diagrams .................................................................................................................................... 31

**Using the Gliffy Editor** .............................................................................................................................. 32
- The Menu Bar ............................................................................................................................................ 33
- The Toolbar ............................................................................................................................................... 36
- Using the Shape Library ............................................................................................................................... 37
  - Shape Library Customization .................................................................................................................... 41
  - Shape Library Searching ........................................................................................................................... 45
  - Most Used Shapes .................................................................................................................................. 47
- The Drawing Stage .................................................................................................................................... 49
- Document Properties ................................................................................................................................ 50
  - Transparent Background .......................................................................................................................... 51
  - Autosave ............................................................................................................................................... 52
- Revision History ........................................................................................................................................ 54
- Managing Drafts ....................................................................................................................................... 55
- Using Layers ............................................................................................................................................. 56
- Using Pop-up Notes ................................................................................................................................ 64
- Using Commenting ................................................................................................................................... 67

**Gliffy Basics** .............................................................................................................................................. 71
- Working on the Drawing Stage ...................................................................................................................... 72
- Working with Objects .................................................................................................................................. 74
- Setting Properties ...................................................................................................................................... 75
- Saving Documents ..................................................................................................................................... 76
- Shapes and Alignment ................................................................................................................................. 77
Language Preferences................................................................................................................. 79

**Working with Shapes and Lines** .......................................................................................... 80
Using the Ellipse and Rectangle Tools ..................................................................................... 81
Using the Shape Library ............................................................................................................ 82
Moving and Manipulating Shapes .............................................................................................. 83
Setting Shape Properties .......................................................................................................... 84
  Shape Opacity ......................................................................................................................... 86
  Linking Shapes ........................................................................................................................ 87
  Working with Line Patterns .................................................................................................... 91
Drawing Guides ......................................................................................................................... 92
Grouping and Ungrouping ......................................................................................................... 93
Using Connector and Line Tools ............................................................................................... 94
  Moving and Locking Lines and Connectors ........................................................................ 95
    Infinite Connection Points .................................................................................................. 96
Setting Line and Connector Properties ..................................................................................... 97
  UML Cardinality ................................................................................................................... 99
  UML Arrows ........................................................................................................................ 100
  Entity-Relationship Arrows................................................................................................... 101
Using Bring-To-Front and Send-To-Back................................................................................ 103
Using Copy Style ....................................................................................................................... 104
Working with Themes ............................................................................................................... 109
Working with Swimlanes ........................................................................................................... 111
Working with Tables ................................................................................................................ 114
Creating Mindmaps .................................................................................................................. 121
  Starting a Mind Map ........................................................................................................... 122
  Hiding and Showing Subtopics ............................................................................................ 126
  Tidying Up Your Mind Map ................................................................................................ 127

**Working with Text** ............................................................................................................ 128
The Text Tool ............................................................................................................................ 129
Entering and Editing Text in Objects ......................................................................................... 130
Setting Text Properties ............................................................................................................ 131
Changing Text Position in a Shape ............................................................................................ 132
  Using Vertical Alignment ..................................................................................................... 136
Managing Text On a Line ........................................................................................................... 138
Linking Text ............................................................................................................................... 140

**Working with Images** ....................................................................................................... 142
Uploading Images ...................................................................................................................... 143
Welcome to Gliffy Online

Gliffy Online User Manual

Gliffy is designed to make it easy and intuitive for you to create professional quality flowcharts, diagrams, floor plans, technical drawings and more. While it’s easy to figure out Gliffy on your own, this guide addresses the basics of using Gliffy and will also help you use some of our more advanced features.
Getting Started

This section will help you get started, and learn the basics of navigating Gliffy’s interface.
Using the Gliffy Start Screen

You can access the Start Screen by logging into http://www.gliffy.com. This screen will appear when you initially login. From here you can:

- Open a Recent Diagram
- Create a new Diagram
- Import a Diagram
- Create From a Template

You can dismiss the start screen by clicking the white “x” in the upper right corner, or by clicking off the screen.
Creating Diagrams

From the Start Screen, you can create a new diagram and choose which type of diagram you’d like to start. Depending on what type of diagram you are going to create, it will load those appropriate shape libraries for you on the left side.

For instance, if you were going to start a blank Flow Chart diagram, you would click on “Flow Chart” and it will load a blank canvas with Flow Chart shapes already loaded for you on the left side.

If you are in your Document Manager, you can create a new diagram from here by clicking Create->New Diagram.
Using Templates

You can also select “Create From a Template” from the Start screen and choose from a variety of templates pre-loaded for you by Gliffy.

Click on a template folder on the left to load example templates. Click once and click “Open” or double-click to load the template and start working.
Creating from a Previous Diagram

You can create a new diagram based off a diagram you previously created. To do so, click into your diagrams at the top and select the diagram you would like to use as your starting point.
Opening Diagrams

Once a diagram has been created, it will appear in the Document Manager. You can access your Document Manager by clicking on “My Documents” in the upper right of the Toolbar.

If you want to access your Gliffy Online diagrams, click on Gliffy.

If you want to access diagrams in your Google Drive folder, click on Google Drive. If you have not already linked your Google account, you will be prompted to do so along with instructions on how to properly set Drive up with your account.
A new tab will open in your browser which will contain your diagrams. Double-click to open a diagram.
An alternative method of opening a diagram is to go to File->Open to access your diagram listings. Select a diagram and click Open or just double-click.
If you are integrated with Google Drive, you can also choose the location you want to open a diagram from under File->Open From.
If you want to open a diagram from your Gliffy Online folders, select File->Open From->Gliffy.

If you want to open a diagram from your Google Drive folders, select File->Open From Google Drive.
Importing Diagrams

Diagrams can be imported from multiple places within Gliffy. The available file formats you can import are:

- .vdx and .vsdx (Visio)
- .gliffy
- .gon
- .gxml

From the **Start Screen**, click on the “Import a Diagram” box to locate the file on your computer and upload.

*Import is not available from Google Drive. File->Open would open any diagrams stored in Drive.*
If you are within your Document Manager, you can also import a diagram by clicking Import.

If you are within the Gliffy Editor, you can import from the File menu.
Using the Document Manager

You can access your Document Manager by clicking the “My Documents” drop-down menu in the upper right of the Toolbar.

If you want to access your Gliffy Online diagrams, click on Gliffy.

If you want to access diagrams in your Drive folder, click on Google Drive. If you are not already integrated, it will prompt you with instructions on how to set Drive up with your account.

A new tab will open in your browser where all of your diagrams will be listed.
On the left side you will see:

- Recent Diagrams
- Starred Diagrams
- Shared Diagrams
- Your Account Diagrams

Recent Diagrams are the last 10 diagrams opened by the user in Gliffy.

Starred Diagrams are diagrams you have marked with the “star” symbol. When the star is marked it will turn yellow and be listed in this folder.

Shared Diagrams are diagrams that have been shared with you via the Collaborate feature. This will list the creator of the diagram and who last edited it. You can open and edit these documents, but you cannot move, delete, or change the status of them. If you want to remove yourself as a collaborator on a shared document, you can do so by clicking on the diagram, then clicking the “x” to delete it.
Your Account Diagrams will be listed last. This is the full list of all diagrams you have access to in the account. If you see a small arrow to the left of a folder, that means there are sub-folders contained within it. Click the arrow to expand the folders out.

You can also sort your diagrams using the drop-down menu in the upper right corner of the Document Manager. You can sort your diagrams by:

- Last Edited
- Alphabetical A-Z
- Alphabetical Z-A
- Date Created
Renaming Diagrams

You can Rename a diagram from the Document Manager by hovering over the diagram name, then clicking to edit.

Once you click it will allow you to start typing a new name. If you do not want to change the name, click off the name and it will revert back to the original. Click off the name once done changing and it will save the new name.
You can also Rename a diagram by opening the diagram up in the Editor (double-click), then go to File->Rename.
A new dialog box will open where you can enter the new diagram name, then click “Rename” to save your changes.
Managing Folders

Creating new folders for organizing your Gliffy diagrams can be done via the My Documents button and accessing your Document Manager. Once in the Document Manager, you can create a new folder by clicking Create->New Folder. A new dialog box will appear. Name your folder, then click Create.

You can Delete a folder by clicking on the folder name and you’ll see a small folder settings gear wheel appear.
Click into folder settings, then click on Delete Folder. A dialog box will appear asking you to confirm the deletion. Click Delete again and the folder will be permanently deleted.

* Folders with nested diagrams cannot be deleted. To delete these folders, you would first need to delete the diagrams contained therein, which will allow you to delete the folder.

You can Rename a folder by clicking into Rename Folder in the folder settings.
A modal will appear and you can enter in the new name of the folder. Click “Update” to save your changes.

You can create sub-folders by clicking into an existing folder then Create->New Folder. If you see a folder has a small black arrow next to it, that means it has sub-folders within it. You would need to click the black arrow to expand all of the folders.
You can move a diagram into another folder by dragging it from the Document Manager into the folder you want it in on the left side.
Managing Folder Permissions

Users with Admin rights can set folder Permissions from within the folder settings. By default, users have access to all folders upon creation.

Click on Permissions and a dialog box will appear. On the left side it will list all users that have access to that folder. If you want to remove access from a user for that folder, click on their email in the Users WITH Access column and then click the button to move their email to the Users WITHOUT Access column. Click Done to save your changes.

Folder permissions will only appear for sub-folders. You cannot delete, rename, or set permissions on the main (root) folder of the account.
Deleting Diagrams

You can Delete a diagram by opening up your Document Manager by navigating to “My Documents->Gliffy”.

Once your Document Manager is open, click once on the diagram you want to delete. The lane with your diagram will highlight and a small “x” will appear in the upper right corner.

To delete the diagram, you can simply click the X, which will provide a prompt confirming that you wish to delete the diagram.

Diagram deletion is permanent, and Gliffy is unable to recover diagrams once they have been deleted. Please be sure you want to completely delete the diagram prior to confirming!
Using the Gliffy Editor

The Gliffy Document Editor is the heart of the application and, with minor exceptions, works the same across all versions of Gliffy. The main areas of the Document Editor are: Menu Bar, Toolbar, Shape Library, and Drawing Stage as shown here:
The Menu Bar

The Menu Bar provides access to the basic commands needed to share, save and print your documents.

The File Menu lets you Open, Save, Save As, Rename, Import, Export your diagram in SVG, Gliffy, JPG, or PNG format, view Revision History, setup Document Properties, Page Setup and Print.

The Edit Menu contains standard copy and paste commands, all of which have keyboard shortcuts. Copy and paste are also accessible using the context menu by right-clicking or control+click. You should also take note of the Group and UnGroup commands found here. These commands allow you to combine text boxes, shapes and lines into clusters that can be manipulated as a single object.
The Share Menu allows you to Collaborate your diagram, or to change the Publish settings on it.

The Help Menu gives you access to various help features for Gliffy, including the User Manual, Tips, Signup for Newsletter, About the Gliffy Team, Shape/Document Shortcuts, and our EULA.

The My Documents button takes you to your Document Manager.
The Profile/silhouette figure tells you information about your account. If you click on this from the main Drawing Editor, it will indicate the Account Name and Username/Email you are logged in under. This is also how you Logout.

If you click on the Profile/silhouette figure from within your Document Manager, this will allow you to access your Account Settings, Switch Accounts (if you have multiple accounts), and Logout.
The Toolbar

The Toolbar lets you select tools to create lines, shapes, text and more.

1. Undo/Redo
2. Group/Ungroup
3. Bring to Front/Send to Back
4. Hyperlink Tool
5. Pop-up Notes Tool
6. Copy Style Tool
7. Free Text Tool
8. Ellipse/Rectangle Tool
9. Connector/Straight Line Tool
10. Pointer
11. Pan
12. Zoom Level
13. Zoom in/Zoom out
14. Drawing Guides
15. Show Grid
16. Snap to Grid
17. Diagram Themes
18. Layers

To change the tool you are using, click into the Toolbar on to the new tool and it will switch to that.

For more tips, you can review our Toolbar video here: https://gliffyvideo.wistia.com/medias/5n4b7dsu5y
Using the Shape Library

The shape library shown upon starting your diagram will be dependent on the type of diagram you chose to start. For example, if you choose to create a flow chart, a library will load containing commonly used flow chart shapes alongside other relevant libraries. You can access additional libraries at any time by clicking on the More Shapes button at the bottom of the shape libraries.

You can Expand/Collapse Libraries in the sidebar by clicking the Expand button.
You can hide the shapes sidebar by clicking the Hide Sidebar button.
If you hide the shape libraries, you can bring them back by clicking the “Show Sidebar” button.
Shape Library Customization

Clicking on More Shapes will open up the More Shapes dialog which will allow you to customize your shape library.

Clicking on the individual shape library names expands that chosen section to allow browsing the shapes it contains. You can click and select or de-select libraries you want to add or remove.

You can also add your own shape libraries by clicking on the +Add Custom Library button at the top of the More Shapes area.

* Only users on Trial, Standard, or Business accounts can create Custom Shape Libraries
Once the Custom Library dialog appears you can add your own JPG, PNG, GIF, and SVG files to it. Please keep in mind there is currently a limit of 30 images per library and a limit of 1MB per image.

You'll also need to name your custom library before you click Save Library.

⭐ Your library will not save unless you select a name for it!
You can also choose to make your custom library available to edit by everyone in your account or you can set it to only allow you to edit it.
To manage your custom shape library, click on the title of it in the sidebar then click on the gear wheel to show the Custom Library Options. Here you can:

1. Edit this Library
2. Remove from Favorites
3. Remove from Sidebar
4. Delete Permanently
Shape Library Searching

You can search the shape library for keywords to help locate shapes. The “Search Shapes” field is located in the upper left corner of the drawing canvas above the Shape Libraries.

You can search for any shape in any of the Gliffy shape libraries in this field. The shape library does not have to be showing on the left side for results to pull up.

To search, type in your search parameters and hit “Enter” on your keyboard.
Any results that match your entry will appear below the search box. You can then drag and drop any of these shapes on to your canvas.
**Most Used Shapes**

As you start adding shapes to your diagrams, the Most Used shape library will automatically populate with your most commonly used shapes. As you use a shape more often, it will move higher on the list. Custom images and shapes are not able to be added at this time.

The Most Used shape library will store up to 18 shapes, on 3 pages of 6. Click the down and up arrows in the library space to move through your pages.
The Most Used Shape library cannot be removed from the sidebar. You can click on the title to expand/collapse the library, and you can also move the library up/down on your library sidebar.

The library is controlled by your local system storage on your computer. If you clear the cache or use a different browser, the Most Used settings will be reset.
The Drawing Stage

The Drawing Stage allows for a blank slate where you build your diagrams. Use shapes pulled from the Library and elements you’ve drawn using the Toolbar to create flowcharts, diagrams, schematics, wireframes, floor plans or whatever else you desire.

The Toolbar lets you select tools to create lines, shapes, text and more. Take note of the Revision History in the File drop-down menu in the upper left corner. This is a quick way to revert to previous drafts. The more often you save, the more useful this feature will be! Also notice the bottom and side scroll bars, which help you move around in larger documents. If your mouse has a scroll wheel it will also work on the drawing stage.
Document Properties

For Gliffy Online, you can find the properties to change the page or document under File->Document Properties, located in the Menu Bar at the top left of Gliffy.

![Document Properties](image)

From here you can control the basic setup of your diagram. Define your page size in pixels and you’ll see thin lines that define your document boundaries (5000×5000 is the default and the max). You can also select your diagram’s background color from here.
**Transparent Background**

You can change the background on your diagram to be transparent. You can set this under File->Document Properties and select the no fill option. By selecting the “no fill” option, this will give make the background transparent upon export.

* At this time, your diagram must be exported in .PNG format to support transparent backgrounds.
Autosave

Autosave is turned on by default in all diagrams. If you want to disable the Autosave on a diagram, you can do that from the File->Document Properties menu by checking the Disable Autosave box. This setting is per diagram and is not a general setting for the whole account.

There are a few conditions when using autosave:

1. The diagram must have been named/saved once to enable autosave.
2. You must have an internet connection.
3. Autosave cannot have been disabled.
Autosave becomes active once you name and save your diagram for the first time. Due to this, we encourage you to make an initial save of your diagram as soon as possible. Autosave drafts are created roughly once every 30 seconds.
Revision History

Every time you save a diagram, Gliffy keeps a record of that version. At any time, you can revert to an earlier saved version of your diagram:

Go to File->Revision History*.
Select the version you would like to recover and click Okay.
If you have not saved the currently active version of the diagram, you will be asked to confirm. You can choose to Continue Working on the current unsaved diagram, or you can Open Revision to discard the active diagram and restore the earlier version.

* Revision History is available on paid accounts only.

PLEASE NOTE: This functionality is not available when diagrams are saved to Google Drive.
Managing Drafts

Occasionally you may see a Draft message appear in the upper-right corner of your diagram. Draft messages appear when the browser detects that it may have work that was left unsaved, or if there were any network or connectivity issues while working on a diagram. These ensure that no work is lost inadvertently.

You can Preview Draft to see if it is a version you want to keep, Load Draft (this will override current draft in the editor), or Discard the Draft.

If the Draft does not load the browser has cleared the draft from it’s history. Drafts only store the most recent browser history.
Using Layers

Layers can be added by clicking the Layers button in the Toolbar. This will pop-up the “Layers” panel on the right side of the drawing canvas.

Adding Layers:
Hiding Layers:
Changing Layer Order:
Locking Layer:
Duplicate Layer:
Moving and Deleting Layer:
Renaming Layers:

*Layers can be renamed by double-clicking on the existing name with your mouse. This works the same as*
editing text anywhere else in the application.
Using Pop-up Notes

The Pop-Up Note command button can be found in the Toolbar. The pop-up note can only be selected if an applicable shape is selected/clicked first (Please note this feature is currently limited to Basic and Flowchart shapes only. More shapes will be added in the future). The pop-up button will show as inactive if you do not have a shape selected first.

Once you have selected the shape you want to add a note to and click on the pop-up button, the Add Note prompt will appear.
You can type your note/comment in and when finished, click Done to add your note. Click Cancel to back out and cancel the note (there is a 250 character limit).

Once you have clicked Done, you will see a note icon in the corner of the shape. If you hover over the shape in edit mode, the note will pop-up.

If you publish your diagram as a public diagram, your notes will also show on the public view of it. Clicking on the shape will reveal the note if you have the “Show All Pop-up Notes” button selected. You can hide the notes by clicking it again. The notes will still be viewable if you click on the shape with the pop-up note icon.
To Delete a note, click on the shape with the pop-up note, click the pop-up note icon in the Toolbar, then delete the text and click “Done”.
Using Commenting

Leaving a Comment

To add their comments, your collaborator will click new comment. An orange dot will appear on the canvas and they’ll type in their comments. If they are new to Gliffy, they will be asked to enter their name the first time (and only the first time) they leave a comment.
They’ll be able to place their comments anywhere on the canvas and will be able to move them around later if need be. When someone submits a comment, the diagram owner will get an email notifying you that your collaborators had something to say. New comments should be visible instantly. If for whatever reason you’re not seeing them, refresh your diagram.

**Editing, Archiving and Deleting Comments**
The comment owner will be able to edit, archive or delete their comments at any time, but will only be able to reply to comments others leave. The diagram owner on the other hand, will be able to edit, archive or delete anyone’s comment.

Commenting as the Diagram Owner

As the diagram owner you too will be able to make comments either before or after you invite collaborators. You will now see a Comments button in the main toolbar. Clicking it will reveal a side panel with the comments history, which can be toggled on or off. Commenting is not currently set up to be used with Google Drive.
You have no comments on this diagram.
Gliffy Basics

Start here for the basic functionality of Gliffy.
Working on the Drawing Stage

To begin, click the “Flow Chart” tab in the Library and click a “start/end” shape and drag it onto the Drawing Stage, now drop the shape on the drawing stage (Note how if you let your mouse hover over a Library shape you’ll see the shape’s title appear).

While that shape is still selected, type “Start”—the text should appear directly inside the shape. Now, click the icon in the Toolbar. Use your mouse to draw a rectangle directly onto the drawing stage: click, drag and release. While the rectangle is still selected, type “End”. Finally, click the icon in the Toolbar. To draw a connector between your “Start” and your “End”, click on the start shape and drag the end of the line to the end shape.

While we’re having fun, go ahead and click on the icon then click on your new flowchart to zoom in. You can zoom back out using the icon or by choosing your magnification level from the drop-down menu in the Toolbar. You can also right click on the drawing stage and select one of the zoom settings from the context menu.
Working with Objects

Whether objects on the Drawing Stage come from the Shape Library or whether they’re drawn using the Toolbar, you can move and manipulate them the same way. If you click on an object, you can drag and drop it where you choose on the Drawing Stage. Each shape (like the 'start' and the 'rectangle' in this example) will display its boundary box when selected. You can use the connection points (little squares in the boundary box’s corners and midpoints) to extend the dimensions of the shape. Just click and drag them. To rotate a shape, click and drag over the curled arrow that you'll see above the shape.

Lines and connectors are slightly different. Instead of boundary boxes, lines and connectors have small circles defining each endpoint and, in the case of connectors with more than two segments, one to control each middle segment. If you click on the line or connector anywhere but on these circles, you’ll move the entire line without changing its shape. Clicking and dragging the circles will move only that portion of the line or connector.
Setting Properties

The Properties Panel for Gliffy gives you the power to change properties on a shape, line or group, quickly and with little hassle. No more hunting around the application interface to change a simple property, now it’s right there with one easy click. When you add or select an object or group of objects on the stage, a small blue button will appear nearby. Click the button on a shape to display different property options for that object or group.

From here you can change the color of your shape, border color, border thickness, line pattern, gradient, drop shadow, shape opacity, change the X,Y coordinates of your shape, change the width/height, rotate the shape a certain degree, Lock Aspect Ratio, and Lock Shape.

You can easily hit the TAB or ENTER key to quickly commit the values of X, Y, Width, Height or Rotation.

If you click on a line or connector, your Properties Panel will look like this:

You can do the following quick manipulations within the Properties Panel:

- Change the arrows at the beginning and the end of the line independently, and we give you all arrow options based on the type of line you are drawing. For instance, if you are connecting UML shapes, we offer you the UML arrows in the selection options.
- If you have a selection that contains line, shapes and text, you can now change properties of each object type independently via the Properties Panel, without having to select each object type separately.
Saving Documents

The only thing left to do now is to save your document. You can save using the button at the top right of the Drawing Stage or through the “File” menu in the Menu Bar. Each time you save a document, it gets logged as a new revision. At any time you can use the “Revision History” in the File drop-down menu in the upper left corner of the Drawing Stage to revert back to any previously saved version.

Through the File Menu, you’ll also have the option to “Save As”. Many customers use this to create template diagrams or another diagram very similar.
Shapes and Alignment

You can align and evenly distribute a group of shapes on your diagram. To do so, select the shapes you’re working with, click the blue properties menu that appears next to your shapes, and then use the various Align and Distribute buttons to make them distributed the way you want.

Align Options:

1. Align left
2. Align center
3. Align right
4. Align top
5. Align middle
6. Align bottom

Aligning takes all the selected shapes and aligns them with the shape that is furthest to the left, center, right, etc. depending on what you select.

Distribute Options:

1. Distribute vertical center
2. Distribute horizontal center
Distributing takes all the selected shapes and distributes them evenly either vertically or horizontally depending on what you select.
Language Preferences

Gliffy Online currently supports the following languages:

- English
- French
- German
- Russian
- Spanish

You can set your language preference in the Language Settings area of the browser you are using.

**Chrome** *(recommended)*: https://support.google.com/chrome/answer/95416?hl=en

**Firefox**: https://support.mozilla.org/pt-BR/questions/949545


**Safari**: http://support.apple.com/kb/HT3155
Working with Shapes and Lines

Here we explain and work through more advanced usage of shapes and lines within Gliffy.
Using the Ellipse and Rectangle Tools

The most basic way to draw shapes is using the Ellipse and Rectangle Tools in the Toolbar as shown here: 

These tools work identically; one draws a shape with rounded corners and the other draws a shape with right angle corners.

There’s no trick to using either tool. Just select the tool you want from the Toolbar and draw by clicking, dragging and releasing. The first place on the Drawing Stage that you click defines the first corner of the shape’s boundary box. As you drag your mouse with the button depressed, the box grows. When you release the mouse button, the ellipse or rectangle is created to fill the boundary box you’ve drawn.
Using the Shape Library

If you’re using shapes from the Shape Library, it’s even easier. First find the shape you want. Next click it then drag it onto the Drawing Stage and drop it at the destination.
Moving and Manipulating Shapes

As explained in Gliffy Basics, any shape can be resized, rotated or moved once it’s been placed upon the Drawing Stage. You can use the little squares that appear in any selected shape’s boundary box’s corners or midpoints to extend the dimensions of the shape. Just click and drag them. To rotate a shape, click and drag the curled arrow that you’ll see above the selected shape.

Also worth noting is the ability to lock a shape to its current dimensions. To do this mark the “Lock Shape” box in the shape’s Properties Panel that appears to the right of the shape. (Using Gliffy Online, you can also right click on a shape and select “Lock Shape” from the context menu.)

When you lock a shape, the little squares around the boundary box turn red to indicate the shape is fixed. You will not be able to change the dimensions, or other properties, of the shape until you unlock the shape.
Setting Shape Properties

When you select a shape, you can edit its properties using the Properties Panel as shown here:. At the top of the shape properties section, you will see several icons that control the shape’s appearance:

- **Shape Color** icon lets you choose what color fill you want the selected shape to have.

- **Border Color** icon controls the color of the shape’s border.

- **Border Thickness** icon determines how thick the shape’s border is, or whether it has a border at all.

- **Line Pattern** icon determines what type of pattern the border of the shape will have.

- **Gradient** icon allows you to turn the gradient on or off and the fill color will transition from lighter to darker from top to bottom.

- **Drop Shadow** icon allows you to add shadows to your shapes that suggest depth.

- **Shape Opacity** icon allows you to add opacity to Basic and Flowchart shapes.
If you find your mouse isn’t giving you the level of control you want, you can also use the Size, Position and Rotation properties to specify the exact dimensions, location and angle of rotation of the selected shape. The position coordinates correspond to the position of the upper left corner of the shape’s boundary box.

On the right side of the Properties Panel, you’ll also see check boxes for “Aspect Ratio” and “Lock Shape”. Marking the “Aspect Ratio” box forces the selected shape to retain its current shape, but not its size. You can still make an ellipse or rectangle larger or smaller, but it will hold its aspect ratio. “Lock Shape” not only secures the aspect ratio, but also secures the size, color and other properties of the selected shape.
Shape Opacity

You can control the opacity of Basic and Flowchart shapes. Click into the blue shape properties box that appears next to the shape and you will see a Shape Opacity icon.

You can manually type in a value or use the scroll bar to adjust the opacity on your shape.
**Linking Shapes**

You can hyperlink entire shapes instead of just text.

> This feature is not available on multi-part shapes, such as swimlanes, certain UML shapes, tables, etc. More linkable shapes will be coming in the future!

To link a shape, click once on it so it is highlighted, then click the “Create Link” button in the Toolbar.

After clicking the “Create Link” button, a modal will open to allow you to enter a URL.
After entering the link to the URL you want, click “Insert” to add it.

After inserting the link, your shape will show an icon in the lower right corner. This indicates that the shape is linked.
Clicking on the shape will show the URL it is linked to. You can Go to the link, Edit the link, or Unlink from this menu.
If you want to remove the shape link icon, check the "Hide Link Icon" box when setting up your link.
Working with Line Patterns

In Gliffy Online, you can set the shape properties of some shapes to be dashed or dotted. You can access this from the blue shape properties box and then click into Line Patterns.
Drawing Guides

Gliffy provides guides to help you line up your shapes with other shapes. To turn on the Drawing Guides, click on the Drawing Guides button in the Toolbar as shown here: . Now, when you drag a shape from somewhere on the stage or from the shape library, it will detect if another shape in its vicinity has a matching edge or center point. If there is a matching edge, the shape you are dragging will "snap" to the other shapes edge, and a green line will appear to show the alignment. The same goes with a center point, except the line will be red. See the image below as an example of a left edge and center point alignment on the X axis.
Grouping and Ungrouping

If you have carefully positioned several elements in relation to each other, and you want to be able to move and manipulate them as if they were a single object, you can add them to a Group:

1. Select the shapes.
2. Click the Group button in the toolbar.

To break up the group and treat each element as an individual object again, select the group and click the Ungroup button.
Using Connector and Line Tools

The Connector and Line Tools work identically to each other. This icon is shown here:

The Connector Tool lets you draw a line forced to turn at right angles where necessary and the Line Tool draws a straight line between whichever endpoints you select, with no turns. To draw either a connector or a line, select the appropriate tool from the Toolbar, place your cursor where you want your connector or line to start and click and drag to your desired endpoint.
Moving and Locking Lines and Connectors

Once you’ve drawn a line or connector you’ll notice a characteristic about each endpoint: if it’s a connector with more than two segments, each middle segment has a little circle. These circles work like the squares around the boundary boxes of shapes. If you click and drag on one of the circles, you’ll only adjust that segment of the line/connector. If you click anywhere else, you’ll move the whole line.

Frequently, you’ll want to connect the end of a line to a shape so that if the shape moves, the line will stick to the shape. When you select a line, you’ll see that all the shapes in your diagram become flanked with little ‘+’ symbols. There should be one in the middle of each shape as well. These ‘+’ symbols are standard connection points. If you drag the endpoint of a line or connector to one, you’ll see the little circle turn green. That indicates the line is locked to the connection point. From then on, if you move the shape, the line will remain connected.

When initially drawing a line or connector, you can start off on a connection point—if the connection point shows a green circle, your line will be locked to it.
Infinite Connection Points

You can attach your connectors to any outside border of certain shapes within Gliffy. When you use the Connector Tool and scroll around the outside of certain square shapes, you'll see a green circle appear. The green circle indicated where you can attach it. If you scroll all the way around you will see you can place your connector anywhere and lock it to the shape.
Setting Line and Connector Properties

When you select a line or connector, you can change its properties using the Properties Panel (just click the blue button next to the line end, see image below). You can change:

- **Line Color** icon allow you to select a color for your connector or line.
- **Line Weight** icon allow you to change how thick your lines are in pixels.
- **Line Style** icon lets you choose from a selection of different patterns for the selected line, from finely dotted to solid.
- **Line Type** icon allows you to select a type of line or connector. The first choice is a straight line. The next three are connectors: right angle, rounded corner, and Bézier Curve.

If you select any number of lines or connectors at one time, you can set properties for all of them at once.
Use the arrow icon to add a direction to your line (for most lines) as shown here:

For specific shapes, like UML, ERD, BPMN, etc., you will get a selection of line end types specific to that shape type. The direction the arrows in this menu point translates as 'left = line start point' and 'right = line end point'. So if you drew your line from right to left, and select the arrow that points to the right, you'll see your line will get an arrow pointing to the left! If you consistently draw your lines/connectors from start to end, this will make adding arrows much easier.
UML Cardinality

In Gliffy Online and Gliffy for Confluence v6.0 and above, you can add cardinality to your UML lines. If you drag a UML connector line onto the canvas, you will notice some cardinality boxes appear on each side. You can then use these to add cardinality to your UML diagram.
UML Arrows

UML connectors have additional arrow ends you can use by clicking into the connector property box.
Entity-Relationship Arrows

In Gliffy Online, you can adjust your Entity-Relationship arrow ends to make the appropriate shape for your needs.

If you don’t see a pre-made ER arrow you would like to use, pull any of them onto the canvas then click into the blue, shape properties box.

Click into the line properties and you will see a drop-down for both arrow ends. You can choose from here what type of shape you want to create.
Using Bring-To-Front and Send-To-Back

As your document becomes more complex, you may find you need to control which elements are in the foreground and which are in the background. You can do this by selecting the desired element and using the **Bring to Front** icon to bring the selected element to the front or the **Send to Back** icon to send it to the back. In Gliffy Online, you can also send elements to the front or back by selecting them and right clicking to select these options in the context menu.
Using Copy Style

You can copy a style from one shape or connector to other shapes and connectors. Start by setting a style for a shape or connector, then click on the shape to activate the Copy Style paintbrush icon in the Toolbar.

Clicking on the paintbrush will copy the style of the shape or connector you selected and your pointer will show as a paintbrush.
Click on the shape or connector you want to paste the style to and this will then make them have the same styles.
If you want to paste styles to multiple shapes:, click the shape you want to copy and click the Copy Style icon.

Circle the shapes/connectors you want to apply the style to with your mouse.
Once you release your mouse it will change all the shapes in the selected area.
Working with Themes

You can choose to apply color themes to your diagram for quick and easy styling. Clicking the Diagram Themes button from the Toolbar will open up the Themes box on the right side of your diagram.

This moveable box can be moved anywhere on your canvas.

Hovering over each theme creates a preview of it applied to the diagram on your drawing canvas. Clicking on the theme applies it to your diagram. To undo an applied theme, select Edit->Undo, or Ctrl+Z.
Completed diagram with no theme:

Diagram Theme applied:

Themes only work on flowchart and basic shape types.
Working with Swimlanes

The Swimlane shapes can have up to 12 lanes added to them. You can add additional swimlanes by dragging a swimlane shape out to the editor, then click the blue custom properties box:

Once you click into the shape properties, you can select the "Number of swimlanes" drop-down menu and select how many lanes you want it to have up to 12.
Working with Tables

In Gliffy Online, you can add tables to your diagram by going into More Shapes->Website and UI->Tables. This will open the tables section in your shape library.

Once you have pulled a table on to the diagram, you can click on a cell to select it. Shift + Click to select multiple cells. A cell is highlighted orange if currently selected.
Selected cell:

Multiple Selected cells:

If you want to Add/Remove columns or rows, click into the edit custom properties widget
If you have the entire table selected, you will see these options:

- Add Column
- Remove Column
- Add Row
- Delete Row

This will insert or delete the column or row at the end.

If you have an individual cell selected, you will see these options:

- Add Column
- Remove Column
- Add Row
- Delete Row
- Insert Column
- Remove Selected Column
- Insert Row
• **Remove Selected Row**

This will add/remove/insert/remove columns or rows from the cell selected.

Max rows and columns are currently 13.

If you have a single cell or multiple cells selected, you can change the properties of these by clicking into the blue properties bar.

If you have the entire table selected and click into the shape properties, you can select the border color and thickness of your lines.

**Border Color:**
Border Thickness:

If you click into the shape properties area, you can adjust the color of your selected cells.
You can adjust the width and height of individual columns or rows by scrolling your mouse on the border lines between them. The cursor will change and you can then move the columns or rows to make them smaller or larger.

Using these features you should be able to create extensive, colorful tables in your diagrams.
<table>
<thead>
<tr>
<th></th>
<th>Standard</th>
<th>Pro</th>
<th>Basic</th>
</tr>
</thead>
<tbody>
<tr>
<td>Price</td>
<td>$3.99 / mo paid annually</td>
<td>$7.99 / mo paid annually</td>
<td>$0 / mo</td>
</tr>
<tr>
<td></td>
<td>$4.95 / mo paid monthly</td>
<td>$9.95 / mo paid monthly</td>
<td>$0 / mo</td>
</tr>
<tr>
<td>200 diagrams</td>
<td>UNLIMITED diagrams</td>
<td>5 diagrams</td>
<td></td>
</tr>
<tr>
<td>250 MB storage space</td>
<td>UNLIMITED storage space</td>
<td>2 MB storage space</td>
<td></td>
</tr>
<tr>
<td>Visio Import</td>
<td>Visio Import</td>
<td>Visio Import</td>
<td></td>
</tr>
<tr>
<td>Google Drive Integration</td>
<td>Google Drive Integration</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>UML 2.0 Shapes and Templates</td>
<td></td>
<td></td>
</tr>
<tr>
<td>250 Private Diagrams</td>
<td>UNLIMITED Private Diagrams</td>
<td>NO PRIVATE DIAGRAMS</td>
<td></td>
</tr>
</tbody>
</table>
Creating Mindmaps

Mind Maps are drawn differently than flowcharts. A flowchart shows the flow of information and has a beginning and an end; a Mind Map shows information in clusters. Because Mind Maps are a brainstorming tool, they have their own set of shortcuts, making it possible for you to map as fast as your ideas flow. Some features, such as copy/paste, are not available on these shapes due to their unique characteristics.
Starting a Mind Map

You can start and create a Mindmap template by doing one of the following:

1. From the Gliffy Start Screen, select "Create From a Template" and then click the Mind Map folder. Click once on the Mind Map template and click “Open” or double-click to load the template and start working.

2. From any other page, go to File -> New and then click the Mind Maps folder and template.
This will open up a Mindmaps template with a main topic and tips for creating your mindmap.

The Main Topic shape is the template anchor, so any nodes must come off of this. If this shape is removed or deleted, the Mind Map functionality and commands will not work. Mind Map commands only work on shapes in the Mind Map template.
To add a subtopic – Click an arrow or enter the **CMD/CTRL + Arrow keys**

To add a topic at the same level as the current topic – enter the **TAB + Arrow keys**

To navigate around your mindmap, use the **arrow keys on your keyboard**
Hiding and Showing Subtopics

To hide a node’s subtopics, click the “Collapse” button. To show the subtopics, click the “Expand” button.
Tidying Up Your Mind Map

Creating mindmaps can be messy! To make sure your nodes aren't overlapping when you're done, click the “Layout” button in the Properties panel and then “Fit to Screen.” Voila! Your mindmap is all tidy now.
Working with Text

There are two ways to add text to your document. Using the Text Tool lets you create text boxes, which can be moved and resized independently from other document elements. You can also enter text directly into elements which is easier, but offers less control.
The Text Tool

Selecting the Text Tool icon from the Toolbar allows you to draw a text box so you can immediately start typing in text. Text will automatically wrap at the end of a line to remain within the box you’ve drawn. If you enter more lines than will fit in the box, the text will extend above and below the borders of the text box.

When you’re done entering text, you can move, resize or rotate a text box just as you would any other shape. If you want to edit the text inside the text box, just double-click on it, you’ll notice a flashing cursor indicating you can edit the text.
Entering and Editing Text in Objects

Sometimes you’ll want to enter or edit text directly into a shape or over a line.

To enter text this way, just select the element you want, by double-clicking (or click once and hit F2 on our keyboard), and start typing.

You can edit this text at any time by double clicking on the element (or click once and hit F2). To completely remove text from an element, double click the element, highlight the text and click delete.
Setting Text Properties

Regardless of how you've entered text, you can edit the properties of selected text by clicking the **Properties Panel** icon. If you select a text box, an element with text typed over it, or any combination of the two, the text properties section will show up in the Properties Panel.

Here, you can choose from a list of available fonts. You also can change the font size and color, make text bold, italic and/or underlined, and change the alignment of the text. You can also add hyperlinks to text (not available in the Gliffy Plugin for JIRA).

You can set different sections of text to have different properties within the same text box or element. For example, one word in a sentence can be bold and in a larger font size. All that's needed is to select the words you want to change the properties for and make your changes.
Changing Text Position in a Shape

In Gliffy Online, you can move text in a shape to various areas in/around the shape. Clicking into the text properties area will show a Text Position button.

Clicking on Text Position will give you 5 options:

- Text Inside
- Text Above
- Text Below
- Text Left
- Text Right
Text Inside:

Text Above:
Text Below:

Text Left:
Text Right:
Using Vertical Alignment

When setting the text position in a shape, you can also use the Vertical Align tool to align the text. You can access this also from the text properties menu.

Vertical Align Top:

Vertical Align Middle:

Vertical Align Bottom:
Vertical alignment is currently only available on Basic and Flowchart Shapes

This alignment functionality will not work on grouped shapes
Managing Text On a Line

In Gliffy Online, you can move text on a line.

If you add text to the middle of a connector and then click on it, you should see it highlighted green. This means it can be moved all around the line.

You can also enter multiple text entities on a single line. You can click anywhere on a connector line to add text and enter as many different boxes as you like.
If you add text to a connector and then click on it, you should see it highlighted green. This means it can be moved all around the line.
Linking Text

To add a hyperlink, double click on the text and highlight the words you want to turn into an active link. Click the Hyperlink icon in the text properties box and enter the desired URL, then click “Insert Link”.

You can also highlight the text you want to hyperlink and click the “Create Link” button in the Toolbar:

Clicking on the hyperlinked text will show a hyperlink editing box while in Edit mode. You can Go to the link, Edit the link, or Unlink from this menu.
Hyperlinks will remain active if viewed as a full-size image on a Gliffy Plugin for Confluence wiki page, exported as SVG or a published URL Gliffy Diagram.
Working with Images

Depending on which version of Gliffy you’re using, there are alternate ways to insert full color images directly into your document via the Library.
Uploading Images

In Gliffy Online, the My Images tab is where you can upload images directly into your Gliffy account, or search the internet for an image. Any image in this tab can be clicked, dragged and dropped to the Document Editor and manipulated like any other shape. Images must be in GIF, JPG or PNG format and cannot be larger than 1 MB.

SVG and all other file types can also be directly dragged on to the canvas.
Image Search

You can also search the internet for images through the Bing search engine. Enter a search term into the search field in the “My Images” tab and click the down arrow to select “Bing Images”. This will then pull up any images of your search results in Bing. Gliffy will display images returned from your search, broken into pages of twenty.

You can scroll down through pages using the “Next” arrows at the bottom of the page. Click on an image to add it to your Gliffy Image Library. They are editable just like any other shape in Gliffy.
Image Tagging

When you upload or add an image to your library, you have the option to “tag” the image with a certain keyword by right-clicking on the image and selecting “Tag”.

Tags are descriptive words that will help you find your image when performing a search. i.e. if your image is a kitten, you can tag it “kitten, cute, animals”.
If you tag a group of photos all as “kitten” for example, you can enter “kitten” into the search field in the My Images tab and click the down arrow to select “Search My Gliffy Account”. This will then pull up any images you have tagged with that word.

If you want to know the specific properties or tags related to an image, right-click on it and select “Get Image Info”.

**Image Info**

- **Filename:** cat_2.jpg
- **Size:** 117061 KB, 1280px x 1024px
- **Tags:** kitten
Deleting Images

You can remove an image from your Image Library by right-clicking* on the image, then selecting “Delete”.

* Mac users can use a two-finger tap while selecting the image
As you get more proficient using Gliffy, you’ll find that the built in Document & Shape Shortcuts speed up your work. You can see a full list of keyboard shortcuts at any time by clicking the "Help" button in the Menu Bar.
<table>
<thead>
<tr>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Zoom In</td>
<td>Ctrl++</td>
</tr>
<tr>
<td></td>
<td>Alt + Mouse Wheel Up</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>Ctrl+-</td>
</tr>
<tr>
<td></td>
<td>Alt + Mouse Wheel Down</td>
</tr>
<tr>
<td>Scroll Page</td>
<td>Arrow Keys</td>
</tr>
<tr>
<td>Jump to Page Edge</td>
<td>Ctrl + Arrow Keys</td>
</tr>
<tr>
<td>Drag or Pan Page</td>
<td>Space + Drag</td>
</tr>
<tr>
<td>Quit Tool</td>
<td>Esc</td>
</tr>
<tr>
<td>Text Tool</td>
<td>Ctrl+2</td>
</tr>
<tr>
<td>Connector Tool</td>
<td>Ctrl+3</td>
</tr>
<tr>
<td>Straight Line Tool</td>
<td>Ctrl+6</td>
</tr>
<tr>
<td>Rectangle Tool</td>
<td>Ctrl+8</td>
</tr>
<tr>
<td>Ellipse Tool</td>
<td>Ctrl+9</td>
</tr>
<tr>
<td>Action</td>
<td>Shortcut</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>------------------</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete</td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Group</td>
<td>Ctrl+G</td>
</tr>
<tr>
<td>Ungroup</td>
<td>Ctrl+U</td>
</tr>
<tr>
<td>Bring to Front</td>
<td>Ctrl+F</td>
</tr>
<tr>
<td>Send to Back</td>
<td>Ctrl+B</td>
</tr>
<tr>
<td>Move Object</td>
<td>Arrow Keys</td>
</tr>
<tr>
<td>Move Object without Snapping</td>
<td>Shift + Arrow Keys</td>
</tr>
<tr>
<td>Drag Without Snapping</td>
<td>Shift + Drag</td>
</tr>
<tr>
<td>Rotate without Snapping</td>
<td>Shift + Rotate</td>
</tr>
<tr>
<td>Stretch without Snapping</td>
<td>Shift + Stretch</td>
</tr>
</tbody>
</table>
Using the Context Menu

Another way to work faster with Gliffy is to use the Context Menu. The Context Menu provides access to the most commonly used commands with the click of your mouse. To access the Context Menu, right-click your mouse (for Mac users, control+click will perform the same function). The Context Menu varies based on what shapes/lines you have selected:

No shapes selected or not mousing over a shape: Option to Paste Here, Select All Objects, and Zoom

One Shape selected and mouse is over a shape: Option to Cut, Copy, Paste, Delete, Lock Selection, Bring to Front, and Send to Back

If more than one shape is selected and mouse is over a shape: You will have the options above and the option to Group or Ungroup
Exporting Diagrams

In Gliffy Online, you can directly export diagrams to a variety of formats, including PNG, JPG, and SVG. You can also export your diagram in Gliffy's .gliffy format for use across Gliffy products.

⚠️ Image exports require a paid Gliffy account
Exporting Diagrams as an Image

In Gliffy, you have access to export and print options through the File menu in the Menu Bar. In this menu, you can Export Gliffy documents in SVG*, JPG*, PNG*, and Gliffy (.gliffy) format and save them for off-line access.

To export your diagram, go to File->Export.

If you select PNG or JPG you will have the option to set the resolution up to 400%.

Direct Export is not available from Google Drive. To export a file stored within Google Drive, select File and Save As, and then save the diagram directly to Gliffy.
If you see larger screen size options grayed out in the Chrome browser, this is due to the diagram being too large for the browser stack to support exporting at that size. This is a limitation of Chrome’s memory capabilities. Under most circumstances, you can bypass this by performing your export in FireFox.

The SVG and Gliffy file options have one standard.
SVG, JPG, and PNG exports are only available on paid accounts. If image options are grayed out when you attempt to export as shown below, you will need to click the “Subscribe Today” button and upgrade to a paid account to export in those formats.
Printing Diagrams

For specific steps on how to print from each browser, please see this article: http://support.gliffy.com/entries/96901917-Printing-from-Different-Browsers-in-Gliffy

To Print your diagram from Gliffy, go to File->Print.

Some browsers have different behaviors when printing. For this example, we will be using the Chrome browser.

In Chrome, you will need to set your margins to “None” in the print system dialog that comes up after you click “Next”.

On the next page, you must set your margins to none in the Chrome print menu.

Make sure your browser settings for Paper Size and Page Orientation are set correctly in the next screen as well.
For all browsers you will need to also make sure you have your Paper Size and Page Orientation set correctly in the print dialog screen that comes up after you click "Next".
Page Setup

Under File->Page Setup, you can select the Paper Size for your diagram, set the paper orientation to Portrait or Landscape, and Display Page Breaks to show within the drawing canvas to show how your diagram will print.

Paper Size options:
Display Page Breaks:

[Diagram of a flowchart]
Once you have this setup the way you want, click “Close” to exit the Page Setup modal.
Printing to PDF

Printing to PDF is available through most browsers. To print to PDF, follow the standard printing flow, and select “Change” to change the destination of your print job.

Once you have selected “Save to PDF”, you can click “Print”, and will be prompted to name and select a save location for your file.
Sharing Diagrams

Under most circumstances, you can control who has the ability to edit your document using the Sharing feature.

⚠️ Sharing is only available to free trial or multi-user accounts.

⚠️ Sharing is not available through Google Drive. Google Drive has their own sharing commands.
Sharing a Diagram

You can share a diagram by clicking the Share button in the upper right corner of a saved diagram.

If your diagram is not saved/named, it will prompt you to do so first.
You also must have verified your email to share. If your email was not verified, you will receive a prompt to verify it first. After it has been verified, you can share the diagram.

Once you click the Share button, the share modal will appear with different options. By default you will be in the Link area. Clicking on Create New Share Link creates a unique, private, and anonymized url you can share with anyone. This also activates the drop-down menu where you can specify the level of access the recipient has.
Levels of Sharing

Clicking on Create New Share Link creates a unique, private, and anonymized url you can share with anyone. This also activates the drop-down menu where you can specify the level of access the recipient has.

Allow Commenting is the default. This allows the recipient of the link to view and comment on the diagram.

Allow Editing allows the recipient of the link to view, comment and edit the diagram. This is similar to our previous Collaboration feature. You can click on Manage Collaborators which acts as a management tool for your diagram.
Here you can add multiple collaborators at once by entering their email and click Send.

This will send them an email from Gliffy inviting them to collaborate on your diagram. By default, this will create a 14 day trial for them if they do not already have an account (a user must have a Gliffy account to edit a Gliffy diagram).
Hi There!

**katy+sharerelease@gliffy.com** would like to collaborate on their diagram Network Diagram with you.

To accept the invitation click the big, orange button:

![Accept Button](image)

You’ll be able to log in with the email and temporary password below:

**katy+44547678181818@gliffy.com**

**uoqelexiqb**

If the link isn’t working, please copy and paste the following URL into your browser:

If the user already has an account with Gliffy, they will be prompted to login with their existing email and password. A Gliffy account is only required for this specific level of sharing. The recipient can continue to collaborate with you after their trial has ended.
Once logged in, they will be able to see your diagram in the Gliffy viewer. If you have given them editing privileges they can click the Edit Diagram icon to edit the diagram in the Gliffy Editor.
Allow Viewing allows anyone with the link to view your diagram with no editing or commenting abilities.

Public on the Web is a read-only public document that anyone on the Internet can find and access (similar to our previous Publish feature).

By default the Diagram can be duplicated option will also be selected. If you do not want the recipient to be able to duplicate or use your diagram as a template, disable this option.

Click on the Copy button to copy the link. You can then use this link to send to anyone you wish.
You can remove access at any time by clicking on Deactivate Link. Click Deactivate Link again to confirm (you must deactivate each link individually currently). You can always regenerate a new code.

Business individual accounts and Standard accounts will have Allow Viewing and Public on the Web options only.

Copy and paste to share this private URL:

https://stage.gliffy.com/go/share/s1vtqsb9ld4t78uhpedo

Diagram can be duplicated

Are you sure?

Anyone with this link will no longer be able to view it
Using Embed and Publishing

You can Embed your diagram into various websites and apps. The diagrams are private and only accessible to you and to where you choose to publish.
Embedding Diagrams

To embed a diagram, click on Share then click into the Embed tab.

Embed links are deactivated. Click on any of the service below to create new embed links

By default no links are generated until you click on an application. If you wanted to embed your diagram in HipChat, for example, click on the HipChat icon.
This generates a code that is supported in the HipChat app. Pasting it there will show your Gliffy diagram. All changes show up when refreshed.

If you want to remove the embed links tied to your diagram, click on Deactivate All Embed Links.
Select where you want to embed a live version of your diagram:

- CUSTOM
- JIRA
- Confluence
- slack
- HipChat
- flowdock
- teamwork
- Basecamp
- WordPress
- Google Apps

Copy and paste the code into your Hipchat message:


Deactivate All Embed Links
Publishing Documents

You can quickly verify the status public/private status of a diagram by looking at the lock icon located next to the diagram name. If it shows a yellow, closed lock, the diagram is “private” and not publicly accessible on the internet. If the diagram has an open lock, it is public.

All diagrams created by Gliffy Online Free users are public, meaning anyone on the Internet can access a read-only version of them and they are indexed by search engines such as Google.

Gliffy Online Standard and Business users will by default create private documents they can choose to make public.
During your free trial, your account will operate as a “Business” account, and all diagrams will default to private. After your trial expires and you revert to a Basic account, all new diagrams you create are by default Public.

To change the public/private status of a document, use the “Share” command found in the Document Manager. This will open the Publish window (as a reminder, Free users will not have access to make a diagram private).
You can also change the status when the diagram is open from Share->Publish.

You also must have verified your email to share. If your email was not verified, you will receive a prompt to verify it first. After it has been verified, you can share the diagram.
Once you click the Share button, the share modal will appear with different options. By default you will be in the Link area. Clicking on Create New Share Link creates a unique, private, and anonymized url you can share with anyone. This also activates the drop-down menu where you can specify the level of access the recipient has.
Gliffy and Google Drive

You'll notice that when you go to My Documents in the upper right portion of your screen you'll have two options, one for Gliffy and one for Google Drive. You'll be able to create your diagrams as usual, but now you'll have the option to save them in either Gliffy or Google Drive. Once you set up Google Drive it will become your default save location. You'll be able to change this by going to your Account Settings.

If you click on Google Drive and you are not already on a Business multi-user account, it will prompt you to upgrade. Once upgraded you can continue with the integration.
If you are already logged into a Gmail account, it will ask you to allow Google and Gliffy Diagrams to access your information. Click on “Allow”.

(Note: If you are logged into more than one Gmail account, it will ask you to choose which one you want to link it to)
Once you click “Allow” Google Drive will become your default save location all new diagrams. You can switch the default location for new files back to Gliffy in Account Settings.
You can also link up Drive to your Gliffy Online account under Account Settings->Google Drive.

If you are having trouble with your Drive integration, we would recommend coming here to verify you are linked up. You can also unlink then relink to reset the integration.

* Users who upgraded to a paid account before March 2016 can keep their existing Google Drive integration regardless of what type of paid account they are on. To inquire about this, please contact Gliffy Support.
Using Google Drive

Once you have successfully linked your Gliffy Online account to Google Drive, you can select the default for where your diagrams will be created and stored.

When you create a diagram, you will see either Gliffy or Google Drive listed before your diagram title. This indicates where that diagram will be saved.

Saved in Gliffy:
The Command Pattern encapsulates a request as an object, thereby letting you parameterize other objects with different requests, queue or log requests, and support undoable operations.
If you want to switch the default location for where your diagrams are saved, go to Account Settings->Google Drive.

Here you can select to make Google Drive your default location for diagrams. Keep the box checked to make Google Drive the default, or uncheck it to make Gliffy Online the default.
You can also unlink your Drive account entirely by clicking on unlink Google Drive.
Copying Diagrams between Gliffy Online and Google Drive

You cannot drag and drop diagrams between Gliffy Online and Google Drive. You may receive an error if you attempt to do so.

If you have a diagram stored in Gliffy Online and want a copy stored in Drive (or vice versa), start by opening up your existing diagram.

Go to File->Save As and select the location you want to save a copy to. To save a copy in Drive, select Google Drive.
Your Google Drive folders should appear and will let you select what folder and what name you want to save it as. Once you have selected the folder location and named the diagram, click Save.

Your diagram should now show a copy in Google Drive. Please note, this saves a new copy and any changes to the original would not affect the new version. If you only want one copy, delete the previous diagram from either Gliffy Online or Drive.
This procedure also works in reverse. If you would like to take a diagram from Google Drive and make a copy in Gliffy Online, go to File->Save As and select the Gliffy option.
Account Management

This section outlines how to manage and administer your Gliffy Online Account. To access this menu, click into the profile silhouette in the upper right corner of any Gliffy page, then Account Settings.

At the Account Summary page, you can view your current account plan, Next Recurring Billing Date (if applicable), and your current Google Apps domain link.
If you have a paid account with Gliffy, and you are an Admin you will also have the menu options: Upgrade, Payment Info, Cancel Plan, Account History, and Users.

The Upgrade menu allows you to upgrade your plan to a higher, or lower, user count or plan.

The Payment Info menu allows you to update your credit card information for future billings from Gliffy.

The Cancel Plan menu allows you to end your Gliffy Online subscription. If you cancel your plan with Gliffy, your account will revert to basic, or close, at the end of the current subscription period.

The Account History menu allows you to view all previous transactions and print invoices directly from Gliffy.
Changing Account Information

You can edit your email address, password, and account name via the Account Summary screen by clicking on the respective link.

Edit Email:

![Edit Email Screenshot]

Edit Password (max 25 characters):
Change Account Name:
User Management

This section outlines how to administer users, as well as other Administrators, on your Gliffy account.
Account Admin Rights

Users with Admin rights can manage Admin rights for other users. From the Account Settings Menu, click on the Users area. A box labeled 'Admin' will appear to the right of their name. By selecting the box, a checkmark will appear which indicates the user now has Admin rights. This can also be un-checked to remove Admin rights from a user.
Add/Remove Users

Gliffy also offers you the ability to Add or Remove users from the Account Settings menu if you are an administrator of the account and you have a multi-person plan.

Users with Admin rights can add new users to the account by entering the email address of the person in the add box and clicking ‘Add’ button located on the right.
Once a user is added they will be sent a welcome email to the email address entered. This welcome email will contain the account name, email address, and a temporary password (if the user is not already listed under another account).

Users with Admin rights can remove a user from the “Users” menu by clicking the “Remove” link and they will no longer have access to the account.
Switching Accounts

Users who have multiple accounts under the same email can switch between accounts by clicking on the profile silhouette in the upper right corner of the Gliffy editor to access the Switch Accounts menu.

The selection you make here will become your default account upon login until you select the other account following this process.
Obtaining Invoices

Invoices for the purchase of your Gliffy Online account can be found under Account History and can be accessed by users with Admin rights.

All payments made will be listed there with a “View” link to view the invoice. Click on “View” to view, download, or print the invoice.

Invoices will only be listed for purchases. Refunds and prorations will not generate invoices.

Gliffy is an American company therefore we do not charge VAT, or list it on our invoices. We also do not charge sales tax.
How to Cancel your Plan

Administrators can cancel a paid Gliffy Online account from the Account Settings page

From Account Settings click into Cancel Plan.

Select a reason from the drop-down menu and enter any comments (comments are optional). Once that is selected, click Cancel Plan.
If you cancel the plan successfully you will receive a confirmation screen. We advise to print this for your records.
Once you cancel an account, it will revert to a free, Basic account at the end of your billing cycle (you can view the date under Account Summary). All your diagrams will remain accessible/editable, but you will not be able to add any additional (over 5) unless you upgrade back to a paid account.
How to Change Your Plan

If you are an Admin on your account, you have the ability to change the associated plan and/or user level of your account.

From the Account Settings screen, click Upgrade.

Choose either a single-user or multi-user plan by clicking “Buy now” under the corresponding plan you want.
Choose a plan

Individual

$7.99/month
Plan billed annually

Just the basics to get you started.

Buy now

Team

As low as
$4.99 per user/month
Plan billed annually

Enhanced features for teams up to 50 people.

Buy now

Enterprise

Contact us

Next level security for teams larger than 50.

Contact us

Unlimited private Diagrams
Image export
Visio import
UML & wireframe shapes
24/7 e-mail support
Live diagram embedding
Google Drive plugin
Private sharing
Commenting tool

Unlimited private Diagrams
Image export
Visio import
UML & wireframe shapes
24/7 e-mail support
Live diagram embedding
Google Drive plugin
Private sharing
Commenting tool

Everything in team +
Best in class security
Single Sign-On (SSO) integration
Dedicated support person
Automated account migration
Priority support
Once you click “Buy now” you will be taken to the payment screen. From here you can select the plan you want, number of users (if you’ve selected a Team account), and if you want monthly or annual billing.

Once you complete your billing information, confirm your details and what you are purchasing is correct. Clicking “Complete Purchase” will finalize your plan change.

Due to a change in payment processors, there are two things that may occur once you finalize your plan change:

If your last account change was prior to October 6th, 2016, you will be refunded a pro-rated amount based on the remainder of your plan.

If your account was created, or your billing or plan information changed after this date, the following will happen –

**Account Upgrade:**
• Your account will immediately change to your newly selected plan/user count. You will not be billed immediately.
• Your next billing date will include your due payment, plus the previous payment adjustment.

For example, if you upgrade from an Individual plan to a Team plan, your account will immediately become a Team plan. On your next billing date, you will be charged the difference due from the previous billing cycle, as well as the next payment due for your next billing cycle.

**Account Downgrade:**

• Your account will immediately change to your newly selected plan/user count.
• The remainder of your previous plan will be applied to your account as a credit. On your next billing date, that credit will be applied to the payment for your next billing cycle.
Gliffy Enterprise

Accounts with 50 or more users are eligible for Gliffy Enterprise, which contains some features exclusive to this plan.
Okta Single Sign On (SSO)

These steps outline the process of linking Okta to your Gliffy Account.

Please ensure the following are correct prior to beginning this process:

- The individual performing this process is an admin in both Okta as well as within the Gliffy Enterprise account
- The email address utilized in Okta as well as within Gliffy Enterprise are identical
- The individual performing this process has reached out to Gliffy Support to obtain all necessary information

Once the above steps have been validated, you are ready to begin the integration process!

1. **IN OKTA**, navigate to Okta Admin. Choose Applications, and then Add Application. Then select “Create new app"

2. Choose “SAML 2.0”, then Create

3. Set the App Name to Gliffy, and if you wish, upload the logo provided by Gliffy Support. Then click “Next”

4. Set the parameters as shown in the following image, using the URL and URI provided by Gliffy Support:
- Attribute Statements should resemble as shown within the following table:

<table>
<thead>
<tr>
<th>Name</th>
<th>Name Format</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>FirstName</td>
<td>Unspecified</td>
<td>user.firstName</td>
</tr>
<tr>
<td>LastName</td>
<td>Unspecified</td>
<td>user.lastName</td>
</tr>
</tbody>
</table>
5. Click next, select “I’m an Okta customer adding an internal app”

6. Select “This is an internal app that we have created”, and then click “Finish”

7. Click the “People” tab within Okta, and then click “Assign to People”

8. Find your Okta user profile and click “Assign” to make yourself a Gliffy user

9. Optionally, assign a Username to yourself, then click “Save and Go Back”, and finally “Done”

10. Click back to the Sign-On Tab

11. Next to the yellow bar, click “View Setup Instructions”

12. **Keep this tab open**, and navigate to Gliffy in a new browser tab. Ensure you are logged into Gliffy as an Admin of your Enterprise account

13. **Within Gliffy**, click on the silhouette in the upper right hand corner, and select “Account Settings”

14. Click Single Sign On within the Account settings menu.

15. Open your **Okta** tab, and copy the “sign in URL” from the Setup Instructions page. Paste this into the noted field within **Gliffy**
16. Open your Okta tab, and copy the X.509 certificate from the Setup Instructions page. Paste this into the noted field within Gliffy.

17. Once you have placed both of these pieces of information, click “Test” at the bottom of the window. The login process will be tested and proper configuration will be confirmed.

PLEASE NOTE: Once SSO is Enabled, it can not be disabled. Don’t click this until you are absolutely sure!

18. When ready, click “Enable” to enable SSO functionality within your Gliffy account.

19. Navigate back to “Okta” and assign the app to the appropriate users via the steps found here: https://support.okta.com/help/Documentation/Knowledge_Article/27418177-Using-the-Okta-Applications-Page#Assigning

From this point forward, all non-administrative users will need to use Okta SSO to sign in.