User Guide to
MegAlign Pro

DNASTAR, Inc. 2019
# Table of Contents

Welcome to MegAlign Pro.......................................................................................................................... 5

Create or Open a Project.............................................................................................................................. 6

MegAlign Pro Interface............................................................................................................................... 8

  Project tabs ........................................................................................................................................ 10

  Views .................................................................................................................................................. 11

    Overview .......................................................................................................................................... 12
      Overview prior to performing an alignment .................................................................................... 14
      Overview after aligning multiple genomes with Mauve ................................................................. 15
      Overview after other alignments ...................................................................................................... 17
      Overview after aligning and entering additional sequences ............................................................ 18
      Using the Overview as a sequence navigation tool ........................................................................... 19

    Sequences view ................................................................................................................................. 20

    Pairwise view ................................................................................................................................... 23

    Distance view .................................................................................................................................... 26

    Tree view .......................................................................................................................................... 29

    Change the appearance of a view ........................................................................................................ 32

    Split and resize panes in a view ......................................................................................................... 33

    Zoom in or out on a view .................................................................................................................... 35

Panels....................................................................................................................................................... 37

  Style panel ......................................................................................................................................... 38

    Overview section ............................................................................................................................... 40

    Sequence section ............................................................................................................................. 42

      Available color schemes ................................................................................................................ 43

    Multiple Alignment section ............................................................................................................. 47

    Pairwise Alignment section ............................................................................................................. 49

    Distance section ............................................................................................................................... 52

      Distance metric options .................................................................................................................. 53

      Gap treatment options .................................................................................................................... 54

    Tree section ..................................................................................................................................... 55

Tracks panel .......................................................................................................................................... 57

  Layout section .................................................................................................................................... 59

  Options section .................................................................................................................................. 60

Features panel ....................................................................................................................................... 61

Places panel .......................................................................................................................................... 63

Favorites section .................................................................................................................................. 65
Recent section ................................................................. 66
Details panel ........................................................................ 67
  When no document, or a blank document, is open .......... 69
  When a non-empty document is open ......................... 70
  When one sequence is selected ................................. 71
  When a portion of a sequence is selected ................. 73
  When multiple sequences are selected ................... 74
  When a portion of multiple sequences is selected ....... 75
  When one track is selected ..................................... 76
  When multiple tracks are selected ......................... 77
  When one feature is selected ................................. 78
  When multiple features are selected .................... 80
  When a portion of a pairwise alignment is selected .... 81
Console panel ................................................................. 82
Hide, show, move, or resize items in the MegAlign Pro window ............................................. 84

Sequences ........................................................................ 85
  Add ungapped sequences to a project ...................... 86
    Advantages of using SeqNinja files ......................... 89
  Add gapped sequences to a project ....................... 91
  Add multi-segment sequences to a project ............ 93
    Try it! – Add and align multi-segment sequences .... 95
  Add sequences from a saved project to an active project .......... 96
  Manually specify sequence type .......................... 97
  Change the order of sequences .......................... 98
  Rename sequences manually ................................ 99
  Rename sequences automatically using specified data fields .... 100
  Remove sequences from a project .................... 103

Tracks ........................................................................ 105
  Ruler tracks .............................................................. 108
  Features tracks ........................................................ 110
  Consensus track ....................................................... 113
  Consensus Match track ......................................... 114
  Sequence Logo track ............................................ 116
  GC Content track .................................................. 118
  Gap Fraction track ................................................ 120
  Numeric tracks ....................................................... 122
  Match Bar track ...................................................... 125
  Translation track .................................................... 127
Features

Map features (copy features to another sequence)

Options screen

Output screen

Output files

Mapping features in MegAlign Pro vs. SeqNinja

Remove features

Try it! – Map features

Part A: Add, rename and align sequences

Part B: Map a single feature

Part C: Map all features

Part D: Map a filtered set of features

Part E: Compare output files

Part F: Export the annotated target sequence

Search Within an Open Project

Make a Selection

Choose the Alignment Type

Perform a Multiple Alignment

Perform an initial multiple alignment

Notes regarding multiple alignments

Troubleshoot multiple alignments

Multiple alignment methods and options

Clustal Omega alignment options

Clustal W alignment options

MAFFT alignment options

MUSCLE alignment options

Mauve alignment options

Modify a multiple alignment

Subalign sequences

Merge two existing alignments ("Profile alignment")

Merge unaligned sequences into an existing alignment

Align selected unaligned sequences with an existing alignment

Unalign aligned sequences

Try it! – Perform a Clustal Omega alignment

Part A: Add and align sequences

Part B: Navigate using the Overview
Change the default application for opening files ................................................................. 272
Clean cached files on startup ............................................................................................ 273
Troubleshoot the error “A different version is running” .................................................. 274
Supported file types ......................................................................................................... 275
IUPAC codes ..................................................................................................................... 276
Installed Lasergene file locations .................................................................................... 278
Research references ......................................................................................................... 280
Welcome to MegAlign Pro

MegAlign Pro is Lasergene’s application for generating multiple and pairwise alignments of protein and/or nucleic acid sequences using your choice of alignment methods. Easily navigate between synchronized views with a click of a button, and rearrange views and toolbars by simply dragging and dropping them where you want them to be.

The following video is a brief walk-through of the MegAlign Pro application. Note that this video does not show all available alignment methods.

These support pages contain written help and tutorials, as well as video tutorials.

- For help INSTALLING Lasergene, see our separate Installation Guide.
- Click here for a list of all TUTORIAL topics.
- Click here for a list of all topics that include VIDEOS.
- To PRINT the current page of the User Guide, click the printer icon in the top right corner ( ).
- To download a PDF of the entire User Guide, scroll to the bottom of the table of contents on the left, and press Download as PDF.
Create or Open a Project

To open an existing MegAlign Pro project (.msa):

Use the File > Open command, select the Open a file tool ( ), or press Ctrl/Cmd+O. Once a project is open in MegAlign Pro, you can open additional files using the same command.

If you moved or renamed any of the sequences prior to reopening a project, you may be prompted to supply the new name(s) or navigate to the location(s) of those sequences.

To create a new, untitled MegAlign Pro project:

Choose File > New Alignment Project, select the Create a new alignment project tool ( ), or press Ctrl/Cmd+N.

Three options are available:

- **Blank Document** – Creates an empty document, regardless of whether any sequences or subsequences are currently selected. See Add ungapped sequences to a project for an alternative method.

- **With Selected Sequences** – Creates a new document containing the currently selected sequences. If no sequences are selected, this option is disabled.

- **With Selected Subsequences** – Creates a new document containing the currently selected subsequences. If no subsequences are selected, this option is disabled.

To create a new project while simultaneously adding sequences to it:

Drag and drop sequence files into an empty project or onto the tab row above one or more projects.

To create a new project based on a classic MegAlign project file or a gapped FASTA file:

1. Choose File > Import Alignment.
2. Navigate to the file you wish to open. The file must be in MegAlign (.meg) or gapped FASTA format (.fasta, .fas, .fap, etc.).

3. Click Open.

The project will open as a MegAlign Pro project in a new tab.
MegAlign Pro Interface

The following table describes components of the MegAlign Pro user interface, along with links to more in-depth information about each item:

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menus</td>
<td>The MegAlign Pro menus are: <strong>MegAlign Pro</strong> (available only on Macintosh), <strong>File, Edit, View, Align, Features, Sequences, Overview, Distance, Tree, Window</strong> and <strong>Help</strong>. Some menu commands can also be initiated by keyboard shortcuts, tools, and/or context menu (right-click) options.</td>
</tr>
<tr>
<td>Tools</td>
<td>The MegAlign Pro toolbar is situated just below the menus. To toggle between showing/hiding the toolbar, choose <strong>View &gt; Show (Hide) Toolbar</strong>.</td>
</tr>
<tr>
<td>Projects</td>
<td>In MegAlign Pro, each <strong>project</strong> is displayed in a separate tab with an .msa extension.</td>
</tr>
<tr>
<td>Overview</td>
<td>The <strong>Overview</strong> provides a way to navigate within the sequences, no matter what type of sequences or alignment is used. In the case of Mauve-generated alignments consisting of multiple alignment blocks, the Overview also allows you to explore the relationships between aligned blocks.</td>
</tr>
<tr>
<td><strong>Sequences view</strong></td>
<td>The <strong>Sequences view</strong> shows the sequences and any enabled tracks (see Work with Tracks).</td>
</tr>
<tr>
<td>-------------------</td>
<td>------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Distance view</strong></td>
<td>The <strong>Distance view</strong>, available only after an alignment has been performed, shows a matrix (i.e., table) of numbers representing distances between each pair of sequences for the alignment block selected in the Overview. Sequence distances are used as input in creating the Tree View. In the case of multi-block alignments, each alignment block will have a separate matrix.</td>
</tr>
<tr>
<td><strong>Tree view</strong></td>
<td>The <strong>Tree view</strong>, available only after an alignment has been performed, shows evolutionary relationships predicted from the multiple sequence alignment, and is calculated using the current <strong>Distance metric</strong>. In the case of multi-block alignments, each alignment block will have a separate tree.</td>
</tr>
<tr>
<td><strong>Panels</strong></td>
<td>The <strong>Style</strong>, <strong>Tracks</strong>, <strong>Features</strong>, <strong>Places</strong> and <strong>Details</strong> panels allow you to specify how to display items in the views, or show details about items in the views.</td>
</tr>
<tr>
<td><strong>View splitter</strong></td>
<td>The <strong>view splitter</strong> is used to divide the Sequences view or Overview vertically into multiple panes.</td>
</tr>
<tr>
<td><strong>Header/footer</strong></td>
<td>A header and footer are collapsible sections above and below the selected reference sequence. They contain tracks that apply to all those sequences and their alignment, if any. The Overview provides a header, and the Sequences view provides a header and footer.</td>
</tr>
<tr>
<td><strong>Sequence ruler</strong></td>
<td>Sequence rulers pertain only to the sequences just above them, and use pre-alignment (ungapped) numbering. Gaps are not counted in this ruler.</td>
</tr>
<tr>
<td><strong>Show/hide icons</strong></td>
<td>The gray circles to the left of each sequence name in the Sequences view and Overview contain a plus or minus sign. These toggle between displaying and hiding the detail tracks.</td>
</tr>
<tr>
<td><strong>Console</strong></td>
<td>The <strong>Console</strong> panel displays information about an alignment in progress, or a log for a completed alignment.</td>
</tr>
<tr>
<td><strong>Console toolbar</strong></td>
<td>This toolbar is located in the upper right of the Console and pertains only to the Console.</td>
</tr>
</tbody>
</table>
Project tabs

You can open multiple projects within a single instance of MegAlign Pro. Each project is displayed in a separate tab and is initially assigned a unique name (*Untitled[#].msa*).

**To make a project the active project:**

Click on its project tab.

**To open an additional MegAlign Pro window:**

Select the **Window > New Window** command.

**To open a project chooser:**

Press **Ctrl+;** (Win) or **Cmd+;** (Mac). Alternatively, press the **>>** icon that appears to the right of the project tabs. This icon is displayed when multiple projects are open and the MegAlign Pro window is too small to display each one in an individual tab.

The project chooser appears as a yellow popup with a line for typing in text at the top, and a list of open projects below.

Use your mouse to click on the project you want to make active. If you do not have a mouse, make a selection using the keyboard arrow keys, then press **Enter**. To instead search for a project using a filter, type text into the text field and press **Enter**. The text field supports the “?” and “*” wildcards.
Views

The majority of the MegAlign Pro window is comprised of one or two “views.” To learn more about the types of views and how to change their appearances, click the links below.

View types:

• Overview

• Sequences view

• Distance view

• Tree view

To change the look of a view:

• Change the appearance of a view

• Split and resize panes in a view

• Zoom in or out on a view
Overview

The Overview provides a way to navigate within the sequences, no matter what type of sequences or alignment is used. In the case of genomic alignments generated by Mauve, the Overview also allows you to explore the relationships between multiple aligned blocks. Selections and vertical ordering within this view are synchronized with other views in MegAlign Pro. Similarly, selections and ordering done elsewhere are reflected in the Overview.

To access the view, click on the Overview tab.

By default, the Overview displays a header, followed by one or more sequences with labels to their left. Each sequence is depicted as a “sequence/alignment block,” and the length is proportional to other sequences in the group. Each sequence row can display a variety of optional data tracks.

The Overview displays information in different ways, depending on the alignment stage and the workflow. In all cases, sequences are represented as either gray or colored blocks. Any sequence that is not part of an alignment is shown in solid gray. Sequences included in an alignment are usually drawn in dark green, although multi-block alignments, such as those generated by Mauve, are drawn in up to seven colors.

See the following topics for images and details of the Overview in different situations:

- Prior to performing an alignment
- After aligning multiple genomes with Mauve
- After performing a non-Mauve alignment or a Mauve non-genome alignment
- After performing an alignment and entering additional sequences

The following table describes ways to control the appearance of the Overview:

<table>
<thead>
<tr>
<th>Task</th>
<th>How to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>To change settings for this view</td>
<td>To change settings, including showing/hiding connecting lines and changing spacing between rows, use the Overview section of the Style panel.</td>
</tr>
<tr>
<td>To set an unselected alignment block in the Overview as the active block</td>
<td>Double-click on an inactive alignment block, or right-click on an inactive alignment block and choose Set As Active Block. The corresponding sequence blocks will line up vertically. The alignment block containing the sequence block will become active.</td>
</tr>
<tr>
<td>To change settings related to the Overview</td>
<td>use the Overview section of the Style panel.</td>
</tr>
<tr>
<td>To make an alignment block the active block and move it to the left of the Overview</td>
<td>Make a block active by double-clicking a sequence block. Then choose Overview &gt; Set Start of Sequences to Active Block or the context (right-click) option of the same name. The blocks in each sequence are rotated so that the active sequence block is leftmost.</td>
</tr>
<tr>
<td>To center the Overview display over the active block</td>
<td>Choose Overview &gt; Show Active Block.</td>
</tr>
<tr>
<td>To return alignment blocks to their default order</td>
<td>Choose Overview &gt; Reset Start of Sequences or the context (right-click) option of the same name. In the Overview, the individual sequence ruler coordinates are updated to reflect the change. Note that resetting the start of sequences presumes that alignment consists of circular genomic sequences.</td>
</tr>
</tbody>
</table>
Overview prior to performing an alignment

The Overview has different appearances, depending on the stage and workflow.

Prior to alignment, each sequence in the Overview appears as a green rectangle ("sequence block") with no gaps. The length of each block is proportional to the ungapped length of its corresponding sequence.
Overview after aligning multiple genomes with Mauve

The Overview has different appearances, depending on the stage and workflow.

A Mauve genome alignment results in a set of locally colinear blocks (LCBs), each of which is a conserved region across multiple sequences. In MegAlign Pro, these may be referred to as “blocks” or “alignment blocks”. The Overview displays the part of a sequence in an alignment block as a “sequence block.” The sequence blocks in the same alignment block have the same color, and by default are shown connected by lines.

To orient the alignment around an active block, double-click on the sequence block. If necessary, individual sequences flip (i.e., are reverse complemented) to orient properly for the new alignment. Sequence rulers reorient along with the strands, and display the new coordinates. Gaps in the active block are shown by the presence of gray bars.

- Only one block is active at a time, and the current block for all the sequences blocks for are always shown in the forward orientation (i.e., on the top strand).

- Sequence blocks are usually displayed only if they include at least two sequences, though an exception is made when there is only one sequence in the project.
• Some sequences may not be included in the active block.

• In order to keep the current blocks in the same orientation, it may be necessary to reverse complement one or more entire genomes.

• The interior of the active block (only) displays a histogram of residue count, with gray areas representing gaps. These histograms reflect the proportion of non-gapped positions in a window corresponding to the number of positions spanned by a single pixel at a given zoom level.

• Blocks appearing out of order compared to other rows can signify an inversion. Blocks in reverse order compared to other rows can signify that the sequence is from the opposite strand compared to the other rows.

• If an alignment block is “hanging down” compared to other blocks in the same track, this signifies that the feature is encoded on the opposite strand. Having blocks represented on the lower strands are the result of rearrangements, such as inversions, and are not meant to imply that the alignment is double-stranded.

• The contents of the Distance and Tree views are specific to the active block only.

After aligning sequences end-to-end, vertical blue bars are used to show the beginnings and ends of the component sequences. These bars are displayed regardless of the type of alignment performed.
Overview after other alignments

The **Overview** has different appearances, depending on the stage and workflow.

After aligning with a method other than Mauve, or after performing a Mauve alignment that results in a single aligned block, any blocks in the Overview will be green and will have the same lengths.

The interior of a sequence block displays a histogram of residue count, with gray areas representing gaps. These histograms reflect the proportion of non-gapped positions in a window corresponding to the number of positions spanned by a single pixel at a given zoom level.

After aligning sequences end-to-end (see Add Multi-Segment Sequences), vertical blue bars are used to show the beginnings and ends of the component sequences (i.e., the segments). These bars are displayed regardless of the type of alignment performed.
Overview after aligning and entering additional sequences

The Overview has different appearances, depending on the stage and workflow. In all cases, sequences are represented as either gray or colored blocks. Any sequence that is not part of an alignment is shown in solid gray.

After performing an alignment, any new sequences added to the project are shown as gray blocks under a bar with the words “Unaligned Sequences.” The bar displays the number of unaligned sequences in parentheses, and a moveable pane divider separates the unaligned sequences from the alignment. The unaligned sequences can be shown/hidden by clicking the Unaligned Sequences bar. The Unaligned Sequences bar is not displayed if there is only one sequence in the project.

- To learn how to add the unaligned sequences to an existing alignment, see Merge unaligned sequences into an existing alignment.

- For information on performing a completely new alignment consisting of a combination of one or more unaligned sequences and one or more previously aligned sequences, see Align selected unaligned sequences with an existing alignment.
Using the Overview as a sequence navigation tool

The light blue vertical column in the Overview is a “viewport” showing the region currently being displayed in the Sequences view. There are a number of methods—all performed within the Overview—for using the slider to navigate to a particular region in the Sequences view:

- **In any project**, move the slider to a desired region by dragging it with the mouse.
- **In a single-block project**, double-click anywhere on a block to center the slider over that position.
- **In a multi-block project**, double-click on an un-highlighted block to make it the active block and to move the slider to its left end.
- **In a multi-block project**, double-click anywhere on the active block to center the slider over that location.

Once you have centered the viewport in the desired location, use the horizontal zoom slider in the Sequences view to increase or decrease the width of the view.
Sequences view

The Sequences View displays added sequences and aligned sequences. Sequence names selected in this view are simultaneously selected all other views in MegAlign Pro. Similarly, sequence names selected elsewhere will be highlighted in the Sequences View.

To access the view, click on the Sequences tab.

By default, the Sequences view consists of three sections: the header, the footer, and sequences area, the last of which consists of nucleotide or amino acid codes for each sequence on the right, and their labels on the left. Each section can display a variety of optional data tracks. The Sequences view has a different appearance depending on the zoom level.

When viewing a multi-block alignment produced by Mauve and using a minimal horizontal zoom, the currently-selected alignment block will appear the same color as in the Overview. Flanking sequences in adjacent blocks will appear gray. At higher zoom levels, the residues for the active block will be shown in bright colors, while flanking sequence residues are represented by “dimmed” (dull) colors.
The dimmed residues are displayed as unaligned sequences, and therefore appear ungapped and without a consensus. To view the dimmed residues as aligned sequences, select the corresponding block in the Overview.

The following table describes ways to control the appearance of the Sequences view:

<table>
<thead>
<tr>
<th>Task</th>
<th>How to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>To change settings related to the Sequences view</td>
<td>Use the <a href="#">Sequences section</a> of the <a href="#">Style panel</a>. The <a href="#">Sequences &gt; Color Sequence Foreground (Background)</a> commands act as alternatives to checking/unchecking the <a href="#">Color foreground (background)</a> boxes in the that section.</td>
</tr>
<tr>
<td>To control the portion of sequence displayed in the view</td>
<td>The Overview’s “viewport indicator” highlights the portion of sequence displayed in the displayed in the Sequences View. You can drag the indicator to scroll the Sequences view along the sequence. If you split the Sequences view, there will be more than one viewport indicator in the Overview. If you split the Overview, a viewport indicator may appear in more than one of the sub-panes.</td>
</tr>
<tr>
<td>To show/hide a vertical guideline</td>
<td>The guideline is displayed, by default, and is a navigational aid to help in guiding your eye between the sequences and the rulers. To hide the guideline in all open projects, click <a href="#">Sequences &gt; Show Guideline</a> to remove the checkmark. Even after hiding the guideline, an abbreviated version of the guideline will remain visible in the header and footer.</td>
</tr>
<tr>
<td>To show/hide the header, sequences area, or footer in the Sequences view</td>
<td>The display of the header, sequences area or footer can be toggled on/off by clicking on the small dark gray arrows near the upper right corners of each section.</td>
</tr>
</tbody>
</table>
Pairwise view

The Pairwise view displays sequences that have been aligned pairwise. Sequence names selected in this view are simultaneously selected all other views in MegAlign Pro. Similarly, sequence names selected elsewhere will be highlighted in the Pairwise view.

The Pairwise view opens automatically after you perform a pairwise alignment. To return to the view at a later time, click on the Pairwise tab. If there are multiple Pairwise tabs, hover over each tab to see a tooltip showing which sequences were involved in that alignment.

![Pairwise 1](image)

By default, the Pairwise view consists of three areas: toolbar, summary, and sequences.

**Toolbar area:**

This area consists of two drop-down menus and five tools.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Align and with drop-down menus</strong></td>
<td>The left drop-down menu is used to specify the target sequence, which should be the longest sequence of the two. The right drop-down menu is used to specify the query sequence. Specifying a different sequence in either menu will initiate a new pairwise alignment.</td>
</tr>
<tr>
<td><strong>Change alignment options in this view</strong></td>
<td>To replace the current pairwise alignment, use this tool to open the pairwise options dialog. Set options as desired and press Align.</td>
</tr>
<tr>
<td><strong>Create new pairwise alignment from selection</strong></td>
<td>Select a portion of the alignment and use this tool to perform a subalignment. The subalignment will open in a new Pairwise view.</td>
</tr>
</tbody>
</table>
Export data
Shortcut to File > Export Data > Pairwise. The summary and sequences areas are both exported.

Export image
Shortcut to File > Export Image > Pairwise. The summary and sequences areas are both exported.

Clone this view
Makes an exact copy of the current Pairwise view, including sequences, alignment type, settings and current selection. This is useful if you want to change one factor for comparison to the original alignment.

Summary area:

<table>
<thead>
<tr>
<th>Local: Smith-Waterman DNA alignment</th>
<th>[Matrix: &quot;NUC44&quot;  Gap penalty: 10  Gap extension penalty: 1]</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>TETHIS21MA</td>
</tr>
<tr>
<td>Alignment</td>
<td>13&gt;862</td>
</tr>
<tr>
<td>Selection</td>
<td>24&gt;264</td>
</tr>
</tbody>
</table>

The summary area describes the alignment engine and settings that were used to create the pairwise alignment.

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>% Identity</td>
<td>Number of matching residues divided by the sum of all residues and gap characters. The quotient is multiplied by 100 to give the similarity as a percent.</td>
</tr>
<tr>
<td>% Gaps</td>
<td>The gap length divided by the consensus length. The quotient is multiplied by 100 to give the similarity as a percent.</td>
</tr>
<tr>
<td>Identical</td>
<td>Number of residues that are identical in both sequences.</td>
</tr>
<tr>
<td>Gap Count</td>
<td>Number of gaps (of any length) in either sequence of an alignment.</td>
</tr>
<tr>
<td>Gap Length</td>
<td>Number of gap characters in an alignment.</td>
</tr>
<tr>
<td>Score</td>
<td>The cumulative score for an alignment derived by adding the matrix-derived match scores and subtracting gap penalties.</td>
</tr>
</tbody>
</table>
Length  Number of residues in the consensus, including gaps that match in both sequences.

**Sequences area:**

The sequences area consists of nucleotide or amino acid codes for each sequence on the right, and their labels on the left. The order is always “target sequence” first, and “query sequence” second.

A variety of optional [data tracks](#) can be displayed in this section. The Pairwise view has a different appearance depending on the [zoom level](#).
Distance view

The Distance view shows a matrix (i.e., table) of numbers representing distances computed for each pair of sequences for the selected aligned block. Sequence distances are used as input in creating the phylogenetic tree shown in the Tree view. Selections within the Distance view are synchronized with other views in MegAlign Pro. Similarly, selections made elsewhere will be highlighted simultaneously in the Distance view.

The Distance view is only accessible after you have performed a multiple alignment, and becomes inaccessible again if you unalign the sequences. After performing an alignment, you can access the view by clicking on the Distance tab.

Above the matrix is a row containing the following information:

- **Block** – (multi-block Mauve alignments only) The color of the alignment block currently selected in the Overview.

- **Metric** – The Metric (calculation method) specified in the Distance section of the Style panel.

- **Sequences** – The number of sequences in the alignment or in the active block.

- **Global/Pairwise gap removal** – The gap treatment specified in the Distance section.

- **Residues considered** – Total length of alignment minus all columns containing even a single gap. This field shows both the minimum and maximum number of residues considered, if they differ.

Here are some tips for understanding the information shown in the matrix:
• Larger numbers correspond to greater differences between sequences. Uncorrected distances are always ≤1.0. However, the Kimura and Tamura-Nei values can exceed 1.0 because they reflect the inferred actual number of nucleotide substitutions or amino acid replacements per site, not the observed distance.

• The upper and lower triangles of the matrix are reflections of one other and contain the same information.

• No numbers appear on the diagonal, since a sequence cannot differ from itself.

• In certain situations, it may not be possible to calculate distances for every pair of aligned sequences, in which case “NA” is displayed. In other cases, “NA” may be an artifact of the computational algorithm; for example, an attempt to calculate the log of a negative number.

• When the divergence between a pair of sequences is greater than about 0.75, it may not be possible to calculate a value for corrected distance using the Kimura and Tamura-Nei metrics.

The following table describes ways to control the appearance of the Distance view:

<table>
<thead>
<tr>
<th>Task</th>
<th>How to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>To change settings related to the Distance view</td>
<td>Use the Distance section of the Style panel.</td>
</tr>
<tr>
<td>To display a tool tip with the name of the sequence corresponding to a cell</td>
<td>Hover over any row/column header or any cell on the diagonal of the matrix.</td>
</tr>
<tr>
<td>To display a tool tip with the two sequence names and the distance between them</td>
<td>Hover over a distance cell in the table that is not on the diagonal. For projects using Pairwise gap removal (see Distance section), the tool tip also contains the number of residues considered for that pair.</td>
</tr>
<tr>
<td>To select all cells in the table</td>
<td>Choose Distance &gt; Table &gt; Select All.</td>
</tr>
<tr>
<td>To use editing commands with the Distance table</td>
<td>Choose Distance &gt; Table &gt; Copy (Select All, Rename, Rename with Fields).</td>
</tr>
<tr>
<td>To freeze scrolling</td>
<td>Choose Distance &gt; Table &gt; Freeze Scrolling Region. In a large table, this command allows you to compare rows near the top with those further down.</td>
</tr>
<tr>
<td>Distance</td>
<td>Accession</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>0.10</td>
<td></td>
</tr>
<tr>
<td>0.10</td>
<td></td>
</tr>
<tr>
<td>0.12</td>
<td>CP002076</td>
</tr>
<tr>
<td>0.09</td>
<td>NC_012973</td>
</tr>
<tr>
<td>0.05</td>
<td></td>
</tr>
</tbody>
</table>

Residues considered: 12340
Tree view

The Tree View shows evolutionary relationships estimated from the multiple sequence alignment, and is calculated using the currently selected Distance metric. The tree is built using the BioNJ algorithm (Gascuel, 1997), a variant of the Neighbor-Joining algorithm (Saito and Nei, 1987) used in MegAlign. The following video is a brief overview of the Tree view:

Selections within the Tree view are synchronized with other views in MegAlign Pro. Similarly, selections made elsewhere will be highlighted simultaneously in the Tree View.

The Tree view is only accessible after you have performed a multiple alignment, and becomes inaccessible again if you unalign the sequences. After performing an alignment, you can access the view by clicking on the Tree tab (the dark blue part of the image, below).
Branch lengths are displayed, by default, and a distance scale appears at the bottom left of the image. Phylogenetic trees are considered to be reflections of the evolutionary relationships between the aligned sequences. Due to the nature of the tree-building algorithm, note that the sum of branch lengths between any pair of sequences is not expected to equal the pair-wise distance reported in the Distance view. This is because the computed branch lengths are conditioned by the relationships to other sequences represented on the tree.

**Note:** Due to the difference in clustering algorithms, trees built in MegAlign and MegAlign Pro may appear different. In addition, trees built in MegAlign are rooted, whereas trees built in MegAlign Pro are always unrooted, regardless of the method used for the alignment. The presence or absence of “roots” can cause a discrepancy in the vertical ordering of sequences between the two applications.

Above the tree is a row containing the following information:

- **Block** – (multi-block Mauve alignments only) The color of the alignment block currently selected in the [Overview](#).

- **Clustering** – The clustering method used is BioNJ ([Gascuel, 1997](#)).

- **Metric** – The distance metric (calculation method) specified in the [Distance section](#) of the [Style panel](#).

- **Sequences** – Number of sequences in the alignment or in the active block.
• **Global/Pairwise gap removal** – The gap treatment specified in the the *Distance section* of the *Style panel*.

• **Residues considered** – Total length of alignment minus all columns containing even a single gap. This field shows both the minimum and maximum number of residues considered, if they differ.

Changes made to the alignment (e.g., realigning with a different method, or with additional sequences) or to the distance metric cause the tree to be recalculated.

In certain situations, it may not be possible to calculate distances for every pair of aligned sequences. In these cases, sub-clusters of related sequences may be shown together on separate trees, or listed together as a single node. See *Distance view* for more information.

The following table describes ways to control the appearance of the Tree view:

<table>
<thead>
<tr>
<th>Task</th>
<th>How to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>To change settings related to the Tree view</td>
<td>Use the <em>Tree section</em> of the <em>Style panel</em>.</td>
</tr>
<tr>
<td>To redraw the tree according to the default settings</td>
<td>Use <em>Tree &gt; Reset Phylogenetic Tree View</em> or Ctrl/ Cmd+Shift+R.</td>
</tr>
</tbody>
</table>
# Change the appearance of a view

The following table shows methods for changing the appearance of one or more views:

<table>
<thead>
<tr>
<th>Task</th>
<th>How to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>To show a view</td>
<td>Use <strong>View &gt; Show Document View &gt; (View Name)</strong>.</td>
</tr>
<tr>
<td>To split the project into two sections that are arranged as a “vertical stack”</td>
<td>Use <strong>Sequences &gt; Split</strong>, <strong>Overview &gt; Split</strong>, or click on the <strong>Split</strong> tool (                        under the view.</td>
</tr>
<tr>
<td>To minimize all but the active view</td>
<td>Use <strong>Sequences &gt; Remove Split</strong>, <strong>Overview &gt; Remove Split</strong>, or click on the <strong>Remove Split</strong> tool ( under the view.</td>
</tr>
<tr>
<td>To show the active view in full-screen mode</td>
<td>Use <strong>View &gt; Full Screen</strong> or press <strong>Ctrl/Cmd+Shift+F</strong>.</td>
</tr>
<tr>
<td>To exit full-screen mode and return to normal mode</td>
<td>Press the <strong>Esc</strong> key or <strong>Ctrl/Cmd+Shift+F</strong>, or click on the <strong>Exit Full Screen</strong> tool (                        at the bottom of the full-screen view.</td>
</tr>
<tr>
<td>To detach the view</td>
<td>Use <strong>View &gt; Detach Document View &gt; (View Name)</strong> or use the context (right-click) option of the same name. Detaching a view turns it into a free-floating window.</td>
</tr>
<tr>
<td>To reattach all detached views to their original locations</td>
<td>Use <strong>View &gt; Reattach All Views</strong>.</td>
</tr>
</tbody>
</table>
Split and resize panes in a view

To change the relative sizes of panes:

To change the sizes of panes (e.g., the sequence names and the alignment blocks areas in the Overview), drag the light gray divider bar between them to the left or right. The images below show examples in the Overview (left) and Sequences view (right).

To split the sequence portion of the view into multiple panes:

To view different sections of the sequences simultaneously, you can split the view into any number of panes.

• To split the Overview in half, use Overview > Split View. To split the Sequences view in half, use Sequences > Split View.

• To split the view manually, drag the view-splitter tool ( ), found at the right edge of the view, in a leftward direction. The images below show examples in the Overview (left) and Sequences view (right).
When the Sequences view is split, the Overview provides a separate “viewport indicator” for each section. Splits are ignored when printing or exporting an image, although the layout is preserved.

To split the sequence portion of the Sequences view horizontally:

To view different sections of the sequence simultaneously, you can split the view into horizontal panes. From the Style panel, use the Sequences section Layout drop-down menu to select Automatic wrapping. The Sequences view will immediately wrap horizontally. You can then add one or more splits by dragging the split tool at the bottom of the view ( ) in an upward direction.

If you were using a Linear layout and had already split the sequence portion of the view vertically, then choosing Automatic wrapping will change vertical splits to horizontal ones. Also, the scroll bars will move from the bottom of the view to the right.

When the Sequences view is split, the Overview provides a separate “viewport indicator” for each section. Splits are ignored when printing or exporting an image, although the layout is preserved.

To remove vertical or horizontal splits:

To remove an existing split, drag the divider as far as you can to either side (vertical splits) or downward (horizontal splits) and drop it there. Or, to automatically remove the right-most split, use Overview > Remove Split. To split the Sequences view in half, use Sequences > Remove Split.
Zoom in or out on a view

Three of MegAlign Pro’s views (Sequences, Tree and Overview) all have independent vertical and horizontal zoom in/out sliders. Grab any green slider with your mouse and drag left/right or up/down to zoom in or out in the view.

The following table uses the Sequences view as an example to show the look of the sequences and some of the detail tracks at different zoom levels.

<table>
<thead>
<tr>
<th>Track</th>
<th>Maximum Zoom</th>
<th>Medium Zoom</th>
<th>Minimum Zoom</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sequences</td>
<td>![Sequences Max]</td>
<td>![Sequences Med]</td>
<td>![Sequences Min]</td>
</tr>
<tr>
<td></td>
<td>Once the letters disappear, only the background color, if any, is shown.</td>
<td>![Sequences Med]</td>
<td>At minimal zoom levels, sequences are shown as colored bars with white gaps.</td>
</tr>
<tr>
<td>Sequence Logo</td>
<td>![Sequence Logo Max]</td>
<td>![Sequence Logo Med]</td>
<td>![Sequence Logo Min]</td>
</tr>
<tr>
<td></td>
<td>Once the logo letters disappear, only the background color, if any, is shown.</td>
<td>![Sequence Logo Med]</td>
<td>Some tracks cannot be displayed at low zoom levels, and prompt you to zoom in.</td>
</tr>
<tr>
<td>Consensus Match</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>----------------</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>![Consensus Match]</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>GC Content</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>![GC Content]</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Gap Fraction</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>![Gap Fraction]</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Translation</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>![Translation]</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Some tracks cannot be displayed at low zoom levels, and prompt you to zoom in.
Panels

Settings panels allow you to optimize the look, contents and layout of the MegAlign Pro view. To learn what can be done within each panel and their “areas” (expandable sections within each panel), click the links below.

- Style
- Tracks
- Features
- Places
- Details
- Console
Style panel

The Style panel has expandable sections with options affecting the Overview, Sequences, Distance and Tree views, as well as multiple and pairwise alignments.

To open the Style panel:

Click on the Style tab ( ). If the panel is not already visible, reveal it using any of the following methods:

• Choose View > Style > Style or View > Reset Panel Layout.

• Press Ctrl/Cmd+Alt+Y.

• Right-click on a track and choose Show Style Panel.

• Use Distance > Table > Show Style Panel.

To change settings in the Style panel:

Click the links below to learn about each of the sections in the Style panel:

• Overview section

• Sequences section

• Multiple Alignment section
• Pairwise Alignment section

• Distance section

• Tree section
Overview section

To access options affecting the Overview display, click on the Style panel expand bar entitled Overview, or choose View > Style > Overview.

![Overview panel](image_url)

<table>
<thead>
<tr>
<th>Task</th>
<th>How to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>To increase/decrease the amount of vertical space between sequence blocks</td>
<td>Use the <strong>Spacing</strong> slider. This command does not affect the sizes of the alignment blocks, but only the amount of white space between them. To make the alignment blocks increase/decrease in size, instead use the Overview’s zoom in/out sliders.</td>
</tr>
<tr>
<td>To change font options for the ruler numbers in the Overview</td>
<td>Use the <strong>Font</strong> drop-down menu to choose a font for the ruler numbers in the Overview. Recently selected fonts (if any) appear at the top of the menu, and other available fonts appear below the row of dashes. Enter the preferred font size by typing a number between 4-72 in the box at right, or by using the corresponding up and down arrows ( ). See note below for additional clarification.</td>
</tr>
</tbody>
</table>
| To select font options for other items in the Overview | To set a different font for sequence and track labels, first check the box next to **Track names font**. If desired, use the corresponding drop-down menu to change the font from the current value. Enter the preferred font size by typing a number between 4-72 in the box at right, or by using the corresponding up and down arrows ( ).

*Note:* When **Track names font** is unchecked and tracks are open, **Font** and **Font size** (described above) affect everything in the view. When **Track names font** is checked and tracks are open, **Font** and **Font size** affect only the rulers, while **Track names font** and **Track names font size** affect sequence labels and track labels.
<table>
<thead>
<tr>
<th>To toggle between displaying or hiding the lines connecting blocks from one track to another</th>
</tr>
</thead>
<tbody>
<tr>
<td>Check or uncheck the <strong>Show connecting lines</strong> checkbox. This option is only enabled for multi-block (<em>Mauve</em>) alignments.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>To specify the reference sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>To use one of the aligned sequences as the reference, make a selection from the <strong>Reference</strong> drop-down menu. This option is only enabled for multi-block (<em>Mauve</em>) alignments, and changes the lines that connect the blocks. All blocks for the selected reference will be placed on the forward strand. Blocks for non-reference sequences can appear on either strand.</td>
</tr>
</tbody>
</table>
Sequence section

To access options affecting the **Sequences view** and **Pairwise view**, click on the **Style panel** expand bar entitled **Sequences**, or choose **View > Style > Sequences**.

![Sequence section](image)

<table>
<thead>
<tr>
<th>Task</th>
<th>How to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>To change font options for the ruler numbers in the <strong>Sequences</strong> view</td>
<td>Use the <strong>Font</strong> drop-down menu to choose from available fonts. Recently selected fonts (if any) appear at the top of the menu, and other available fonts appear below the row of dashes. Enter the preferred font size by typing a number between 4-72 in the box at right, or by using the corresponding up and down arrows ( ).</td>
</tr>
<tr>
<td>To select font options for other items in the <strong>Sequences</strong> view</td>
<td>First check the box next to <strong>Track names font</strong>, then use the corresponding drop-down menu to change the font from the current value. Enter the preferred font size by typing a number between 4-72 in the box at right, or by using the corresponding up and down arrows ( ).</td>
</tr>
<tr>
<td>To change the sequence color scheme in the <strong>Sequences</strong> view</td>
<td>To change the letter color in the <strong>Sequences</strong> view, check the <strong>Color foreground</strong> box. To change the background color (boxes around each letter), check the <strong>Color background</strong> box. Then make selections from the corresponding drop-down menus. Color schemes are described in <strong>Available color schemes</strong>. As alternatives to checking/unchecking these boxes, check or uncheck the menu items <strong>Sequences &gt; Color Sequence Foreground (Background)</strong>.</td>
</tr>
</tbody>
</table>
Available color schemes

The Sequence section allows you to select color schemes for sequences in the Sequences view. Each available color scheme is described below:

Color by Chemistry - This is the default color scheme, and matches the colors used in DNASTAR’s Protean 3D application. Amino acids are colored according to their side chain chemistry:

<table>
<thead>
<tr>
<th>Nucleotide</th>
<th>A</th>
<th>C</th>
<th>G</th>
<th>T/U</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Side Chain Chemistry - Amino Acids</th>
</tr>
</thead>
<tbody>
<tr>
<td>Aromatic - Phenylalanine (F), Tryptophan (W), Tyrosine (Y)</td>
</tr>
<tr>
<td>Acidic (negatively charged) - Aspartate (D), Glutamate (E)</td>
</tr>
<tr>
<td>Basic (positively charged) - Arginine (R), Histidine (H), Lysine (K)</td>
</tr>
<tr>
<td>Nonpolar (aliphatic) - Alanine (A), Glycine (G), Isoleucine (I), Leucine (L), Methionine (M), Proline (P), Valine (V)</td>
</tr>
<tr>
<td>Polar (neutral) - Cysteine (C), Asparagine (N), Glutamine (Q), Serine (S), Threonine (T)</td>
</tr>
</tbody>
</table>

Shapely - This color scheme matches the RasMol amino acid and RasMol nucleotide color schemes, which are, in turn, based on Robert Fletterick’s “Shapely models.”

<table>
<thead>
<tr>
<th>Nucleotide</th>
<th>A</th>
<th>C</th>
<th>G</th>
<th>T</th>
<th>U</th>
</tr>
</thead>
</table>
### Amino Acids

<table>
<thead>
<tr>
<th>Alanine (A)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arginine (R), Lysine (K)</td>
</tr>
<tr>
<td>Asparagine (N), Glutamine (Q)</td>
</tr>
<tr>
<td>Aspartate (D), Glutamate (E)</td>
</tr>
<tr>
<td>Cysteine (C), Methionine (M)</td>
</tr>
<tr>
<td>Glycine (G)</td>
</tr>
<tr>
<td>Histidine (H)</td>
</tr>
<tr>
<td>Isoleucine (I), Leucine (L), Valine (V)</td>
</tr>
<tr>
<td>Phenylalanine (F), Tyrosine (Y)</td>
</tr>
<tr>
<td>Proline (P)</td>
</tr>
<tr>
<td>Serine (S), Threonine (T)</td>
</tr>
<tr>
<td>Tryptophan (W)</td>
</tr>
</tbody>
</table>

**Taylor** - This color scheme is taken from [Taylor](#) and is also used in JalView ([Waterhouse et al., 2009](#)).

### Nucleotides

<table>
<thead>
<tr>
<th>A</th>
<th>C</th>
<th>G</th>
<th>T/U</th>
</tr>
</thead>
</table>

Copyright DNASTAR, Inc. 2019
### Amino Acids

<table>
<thead>
<tr>
<th>Amino Acid</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alanine (A)</td>
<td></td>
</tr>
<tr>
<td>Arginine (R)</td>
<td></td>
</tr>
<tr>
<td>Asparagine (N)</td>
<td></td>
</tr>
<tr>
<td>Aspartate (D)</td>
<td></td>
</tr>
<tr>
<td>Cysteine (C)</td>
<td></td>
</tr>
<tr>
<td>Glutamate (E)</td>
<td></td>
</tr>
<tr>
<td>Glutamine (Q)</td>
<td></td>
</tr>
<tr>
<td>Glycine (G)</td>
<td></td>
</tr>
<tr>
<td>Histidine (H)</td>
<td></td>
</tr>
<tr>
<td>Isoleucine (I), Leucine (L)</td>
<td></td>
</tr>
<tr>
<td>Lysine (K)</td>
<td></td>
</tr>
<tr>
<td>Methionine (M)</td>
<td></td>
</tr>
<tr>
<td>Phenylalanine (F)</td>
<td></td>
</tr>
<tr>
<td>Proline (P)</td>
<td></td>
</tr>
<tr>
<td>Serine (S)</td>
<td></td>
</tr>
<tr>
<td>Threonine (T)</td>
<td></td>
</tr>
<tr>
<td>Tryptophan (W)</td>
<td></td>
</tr>
<tr>
<td>Tyrosine (Y)</td>
<td></td>
</tr>
<tr>
<td>Valine (V)</td>
<td></td>
</tr>
</tbody>
</table>

**Zapped** - This scheme colors residues according to their physico-chemical properties, and is also used in JalView ([Waterhouse et al., 2009](#)):
**Physico-Chemical Property - Amino Acids**

- **Aliphatic/hydrophobic** - Alanine (A), Isoleucine (I), Leucine (L), Methionine (M), Valine (V)
- **Aromatic** - Phenylalanine (F), Tryptophan (W), Tyrosine (Y)
- **Conformationally special** - Glycine (G), Proline (P)
- **Cysteine** (C)
- **Hydrophilic** - Asparagine (N), Glutamine (Q), Serine (S), Threonine (T)
- **Negatively Charged** - Aspartate (D), Glutamate (E)
- **Positively Charged** - Arginine (R), Histidine (H), Lysine (K)

**Solid** – These scheme colors residues with the color shown. After selecting **Solid**, you can specify the color by clicking on the colored box to the right of the menu.

![Color foreground](image)

**Note:** In Mauve alignments, “dimmed” (dull) colored residues represent flanking sequences immediately adjacent to the alignment block currently selected in the Overview.
Multiple Alignment section

To access options affecting the display of multiple alignments in the Sequences view, click on the Style panel expand bar entitled Multiple Alignment, or choose View > Style > Multiple Alignment.

- Use the Layout drop-down menu to specify the wrapping style for rows in the Sequences view. Choose between:
  - Linear – All information for a sequence appears on a single row with no line breaks. A horizontal scrollbar is provided.
  - Automatic wrapping – The alignment is wrapped to fit within the view. Wrapping adjusts automatically if the view’s width changes.
  - Fixed wrapping – The alignment is wrapped at the specified number of residues. Enter a number in the Size box to wrap after a different number of residues.

Vertical splits are not available in either type of wrapped view. However, any existing splits are restored if wrapping is turned off.

- Use the Comparison drop-down menu to specify how to color the sequences and the consensus to facilitate visual comparisons. Sequence comparisons can only be performed with aligned sequences. Choose between:
  - None – All residues appear in the color schemes chosen in Color foreground and Color
background (see row above).

- **Color only differences from reference** – Only residues that differ from the consensus are colored. If you chose this option, you should select the reference sequence from the **Reference** drop-down menu. The reference can be the consensus or any of the aligned sequences.

- **Color only matches to reference** – Only residues that are identical to the consensus are colored. If you chose this option, you should select the reference sequence from the **Reference** drop-down menu. The reference can be the consensus or any of the aligned sequences.

- **Show only differences from reference** – Only residues that differ from the consensus are displayed and colored. All other residues are shown as uncolored dashes. If you chose this option, you should select the reference sequence from the **Reference** drop-down menu. The reference can be the consensus or any of the aligned sequences.

- Choose either **Color only conserved residues** or **Color only non-conserved residues** to color according to whether or not residues are conserved. A residue is “conserved” if all sequences have the same residue in that column. Otherwise, it is “non-conserved.”

- If you prefer to ignore gaps when determining whether or not a residue is “conserved,” check the box next to **Ignore gaps**. The **Ignore gaps** checkbox is only enabled if you selected **Color only conserved/non-conserved residues** above.
Pairwise Alignment section

To access options affecting the display of pairwise alignments in the Pairwise view, click on the Style panel expand bar entitled Pairwise Alignment, or choose View > Style > Pairwise Alignment.

- Use the Layout drop-down menu to specify the wrapping style for rows in the Sequences view. Choose between:
  - **Linear** – All information for a sequence appears on a single row with no line breaks. A horizontal scrollbar is provided.
  - **Automatic wrapping** – The alignment is wrapped to fit within the view. Wrapping adjusts automatically if the view's width changes.
  - **Fixed wrapping** – The alignment is wrapped at the specified number of residues. Enter a number in the Size box to wrap after a different number of residues.

Vertical splits are not available in either type of wrapped view. However, any existing splits are restored if wrapping is turned off.

- A local alignment reports the highest scoring contiguous segment of alignment between two
sequences, even if the full extent of one or both of the sequences is not included in the final alignment. Local alignments are ideal for finding a short sequences within a larger sequence. Flanking segments of sequences that are not within the aligned segment can be visualized by checking the Show context box. The flanking segments appear in a dimmer color scheme than the alignment.

Consider a local alignment of a long sequence to a short one. Any positions that aren’t part of the alignment are considered to be context and are not displayed in the Pairwise view unless Show context is selected. In the case below, the segment “GGGC” in on the left of Seq1 is context, as is the trailing “TTAAAA”. The internal part of Seq2 that spans a gap in Seq1 might be considered unaligned, but is actual context, because it’s not internal to the alignment.

Seq1 GGGC CCC -- TTA TTAAAA
Seq2 ----- CCC C C TTA --------

- Use the Comparison drop-down menu to specify how to color the sequences and the consensus to facilitate visual comparisons. Sequence comparisons can only be performed with aligned sequences. Choose between:
  - None – All residues appear in the color schemes chosen in Color foreground and Color background (see row above).
  - Color only differences from reference – Only residues that differ from the consensus are colored. If you chose this option, you should select the reference sequence from the Reference drop-down menu. The reference can be the consensus or any of the aligned sequences.
  - Color only matches to reference – Only residues that are identical to the consensus are colored. If you chose this option, you should select the reference sequence from the Reference drop-down menu. The reference can be the consensus or any of the aligned sequences.
  - Show only differences from reference – Only residues that differ from the consensus are displayed and colored. All other residues are shown as uncolored dashes. If you chose this option, you should select the reference sequence from the Reference drop-down menu. The reference can be the consensus or any of the aligned sequences.

- Choose either Color only conserved residues or Color only non-conserved residues to color according to whether or not residues are conserved. A residue is “conserved” if all sequences have the same residue in that column. Otherwise, it is “non-conserved.” If you prefer to ignore gaps when determining whether or not a residue is “conserved,” check the box next to Ignore gaps. The Ignore gaps checkbox is only enabled if you selected one of the two
comparison options described in this bullet point.

- The Match bar section affects display of the optional Match bar track. This track is used to show similarities and differences between the query and target sequences:
  - Use the Show identity as drop-down menu to choose how to show the connection between the query and the target. Choosing Residues in target case or Residues in query case cause the connection to appear as a copy of the residue from the target or query sequence. Choosing Vertical bars causes the connection to appear as a symbol, depending on the match status.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Interpretation</th>
<th>Weight table value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical line</td>
<td>Match</td>
<td>1</td>
</tr>
<tr>
<td>Colon</td>
<td>Favorable mismatch</td>
<td>(0,1)</td>
</tr>
<tr>
<td>Period</td>
<td>Neutral mismatch</td>
<td>0</td>
</tr>
<tr>
<td>Space</td>
<td>Unfavorable mismatch</td>
<td>&lt; 0</td>
</tr>
</tbody>
</table>

- To add a background color behind each residue, check the Color background check box and use the adjacent drop-down menu to choose between Same as query and Same as target.

**Note:** These options are mirrored in the Match Bar track options section. Choices made in either location are instantly reflected in the other location.
## Distance section

To access options affecting the Distance view, click on the Style panel expand bar entitled **Distance**, or choose **View > Style > Distance**.

![Distance panel](image)

<table>
<thead>
<tr>
<th>Task</th>
<th>How to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>To change the metric used to calculated distance</td>
<td>Use the <strong>Metric</strong> drop-down menu. For detailed information, see Distance metric options.</td>
</tr>
<tr>
<td>To specify when gaps should be ignored</td>
<td>Use the <strong>Gap Treatment</strong> drop-down menu. For detailed information, see Gap treatment options.</td>
</tr>
<tr>
<td>To change the Distance view font style</td>
<td>Use the <strong>Font</strong> menu to choose between seven available fonts. Recently selected fonts (if any) appear at the top of the menu, and other available fonts appear below the row of dashes.</td>
</tr>
<tr>
<td>To change the Distance view font size</td>
<td>Type a number to the right of <strong>Font</strong> or use the corresponding up and down arrows ( ▲ ▼ ) to select a font size. Allowed values = 4 to 72.</td>
</tr>
<tr>
<td>To change the number of decimal places displayed in the Distance view</td>
<td>Type a number to the right of <strong>Decimal places</strong>, or use the corresponding up and down arrows ( ▲ ▼ ) to specify the number of decimal places. Allowed values = 1 to 7.</td>
</tr>
</tbody>
</table>
Distance metric options

The metric used to calculate distances (which affect the Distance and Tree views) is specified in the Distance section of the Style panel. To open the section, click on the expand bar entitled Distance, or choose View > Style > Distance.

To change the distance metric, use the *Metric* drop-down menu. Note that metric selection is disabled for projects without sequences.

Choices include:

- **Uncorrected Pairwise Distance** – (the default metric) – The number of identical bases (or residues) divided by the number of bases being compared, ignoring any positions with gaps). Uncorrected pairwise distance can be converted to %Identity using the formula: %ID = 100 * (1 – distance).

- **Kimura** – (protein sequences only) – The Kimura model (1983), which should not be used for very divergent sequences, uses the formula: $D = -\ln (1 - p - 0.2 p^2)$, where $p$ is the uncorrected pairwise distance. The Kimura distance approximates the “PAM distance” used in MegAlign.

- **Scoredist** – (protein sequences only) – This model, developed by Sonnhammer and Hollich (2005) computes the alignment score between two sequences using the BLOSUM62 scoring matrix. The units for the ScoreDist function are “percent accepted point mutations” (PAM). Scores are converted to distances and normalized by the average scores of the two sequences matched to them. This approach works even for very divergent sequences, providing that there are overlapping residues.

- **Tamura-Nei** (1993) – (nucleotide sequences and low degrees of divergence only) – An estimate of divergence using the TN93 model of the evolutionary process. This model attempts to separately account for different rates of transversion mutations (e.g., purine ↔ pyrimidine) and the two categories of transition mutations (i.e., purine only A ↔ G; pyrimidine only C ↔ T). The frequencies of each type of nucleotide do not need to be the same.
Gap treatment options

Gap treatment options affect the calculation of distances, which, in turn, affect the Distance and Tree views. One of two options may be specified in the Distance section of the Style panel. To open the section, click on the expand bar entitled Distance, or choose View > Style > Distance.

Use the Gap Treatment drop-down menu to choose between these options:

- **Global gap removal** – (default) This option ignores any column that contains a gap in any of the aligned sequences in the project. This is the only enabled option for MegAlign Pro projects created prior to the 12.0 release (spring 2014).

- **Pairwise gap removal** – This option ignores any column that has a gap in either of the two sequences being compared.

The banners at the tops of the Distance and Tree views will show a range in the field Residues considered if different numbers of residues are considered for different pairs of sequences. This happens frequently when Pairwise gap removal is checked. However, if the minimum and maximum values differ greatly, we recommend selecting Global gap removal instead.
Tree section

To access options affecting the Tree view, click on the Style panel expand bar entitled Tree, or choose View > Style > Tree.

<table>
<thead>
<tr>
<th>Task</th>
<th>How to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>To change the layout of the Tree view</td>
<td>Click on any of the four orientations to show the phylogenetic tree with that layout (left, up, down, right).</td>
</tr>
<tr>
<td>To change the font style used in the “leaves” of the Tree view</td>
<td>Use the Font drop-down menu to choose from available fonts. Recently selected fonts (if any) appear at the top of the menu, and other available fonts appear below a row of dashes.</td>
</tr>
<tr>
<td>To change the font size used in the “leaves” of the Tree view</td>
<td>Type a number to the right of Font or use the corresponding up and down arrows (↑) to select a font size. Allowed values = 4 to 72.</td>
</tr>
<tr>
<td>To change the background color in the Tree view</td>
<td>Check the box to the left of Background, and then click the box to the right to open the color picker.</td>
</tr>
<tr>
<td>To change the branch color in the Tree view</td>
<td>Click the Color box in the Branches section to open the color picker.</td>
</tr>
<tr>
<td>Action</td>
<td>Instruction</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>To change the branch width in the Tree view</td>
<td>Type a number to the right of <strong>Width</strong> or use the corresponding up and down arrows (↑↓) to select a font size. Allowed values = 1 to 20.</td>
</tr>
<tr>
<td>To toggle between showing/hiding the branch lengths</td>
<td>Check or uncheck the box to the left of <strong>Show branch length</strong>.</td>
</tr>
<tr>
<td>To change the number of decimal places for the branch length</td>
<td>Type a number to the right of <strong>Decimal places</strong>, or use the corresponding up and down arrows (↑↓) to specify the number of decimal places for the branch length. Allowed values are 1-7. This field is only enabled when <strong>Show branch length</strong> is checked.</td>
</tr>
</tbody>
</table>
Tracks panel

The Tracks panel lets you manage the tracks displayed in the Overview and the Sequences view.

To open the Tracks panel:

Click on the Tracks tab (Tracks). If the panel is not already visible, reveal it using any of the following methods:

- Choose View > Tracks > Tracks or View > Reset Panel Layout.
- Press Ctrl/Cmd+Alt+T.
- Right-click on a track in the Overview or Sequences View and choose Show Tracks Panel.

To change settings in the Tracks panel:

The uppermost part of the Tracks panel lets you specify which tracks are visible, and configure their options and appearance. Depending whether the project contains DNA/RNA or protein sequences, different subsets of track types will be listed. For instance, in the absence of an alignment, Consensus, Consensus
**Match, Sequence Logo and Gap Fraction** are hidden from the list. For those tracks that are available, some will be displayed and other will be hidden, by default. Put check marks next to available tracks that you wish to display, and remove check marks next to tracks that you wish to hide. Tracks are added to the views in the same order in which their boxes are checked in the Tracks panel. This means that the position of a track may change when its box is unchecked and then checked again.

Click the links below to learn about each of the expandable sections in the Tracks panel:

- [Layout](#)

- [Options](#)

To see the detail tracks that have been check-marked for display:

Expand one or more sequences in the Overview and/or Sequences view by clicking the relevant plus sign icon. (liğ�)
Layout section

To access options affecting the height of a track and the space above and/or below the track, click on the Tracks panel expand bar entitled “Layout,” or choose View > Tracks > Layout. Changes made in this section are applied to all currently selected tracks.

<table>
<thead>
<tr>
<th>Task</th>
<th>How to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>To control the amount of blank space above and/or below each of the selected track(s)</td>
<td>Use the Space before/after sliders.</td>
</tr>
<tr>
<td>To control the heights of the selected tracks</td>
<td>Use the Height slider. This option is enabled only when all selected tracks support user-scalable height.</td>
</tr>
<tr>
<td>To return the sliders in this dialog to their default settings</td>
<td>Click the Restore default settings tool ( ).</td>
</tr>
</tbody>
</table>
Options section

To access settings for the track type currently selected in the Tracks panel, click on the Tracks panel expand bar entitled “Options,” or choose View > Tracks > Options.

The Options section varies in appearance depending upon the selection. For discussions of each track type and its corresponding Options section, see Tracks.
Features panel

The Features panel lets you specify which feature types should be visible in the Overview and the Sequences view once a sequence has been expanded.

To open the Features panel:

Click on the Features tab (Features). If the panel is not already visible, reveal it using any of the following methods:

- Choose View > Features or View > Reset Panel Layout.
- Right-click on a track in the Overview or Sequences view and choose Show Features Panel.

To change settings in the Features panel:

The Type column shows the feature type. By default, all feature types except Source are checked.

The Count column shows the number of each feature type in the project. It includes all sequences, whether aligned or unaligned, selected or unselected. The count includes copies of features mapped to the consensus (e.g., with Features > Map Features to Active Consensus) and other sequences.

<table>
<thead>
<tr>
<th>Task</th>
<th>How to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>To display/hide a particular feature</td>
<td>Check/unchecked its box in the Type column.</td>
</tr>
<tr>
<td>type</td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>To display/hide all features</td>
<td>Right-click anywhere in the Features panel and select <strong>Show All</strong> or <strong>Hide all</strong>.</td>
</tr>
</tbody>
</table>
The Places panel lets you quickly navigate to a sequence location or range that you have visited before. The following video shows how to bookmark favorite locations using the Places panel:

To open the Places panel:

Click on the Places tab (Places). If the panel is not already visible, reveal it using any of the following methods:

- Choose View > Places > Places or View > Reset Panel Layout.
- Press Ctrl/Cmd+Alt+P.

To change settings in the Places panel:
Click the links below to learn about each of the expandable sections in the Places panel:

- **Recent section**

- **Favorites section**
Favorites section

The Favorites section is similar to the bookmarks folder for a web browser. It contains a list of previously-visited locations that you have decided you may wish to visit again.

To access the Favorites section:

Click on the Places panel expand bar entitled “Favorites,” or choose View > Places > Favorites.

Entries are nominated for this list from within the Recent section of the Places panel or by choosing Sequences > Add Place to Favorites. Favorites are listed in the same order in which they were added, by default, though you can change the order manually (see table below). The Favorites list is saved whenever you save a project.

<table>
<thead>
<tr>
<th>Task</th>
<th>How to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>To return to a location in this section</td>
<td>Double-click on the item or make a selection from the list and press the Go to this gene or location button (.seek).</td>
</tr>
<tr>
<td>To move a bookmarked location further up the Favorites list</td>
<td>Make a selection from the list and press the Move this place up arrow (.seek).</td>
</tr>
<tr>
<td>To move a bookmarked location further down the Favorites list</td>
<td>Make a selection from the list and press the Move this place down arrow (.seek).</td>
</tr>
<tr>
<td>To rename a selected item</td>
<td>Click on an item in the Favorites section to select it. Then right-click on the same item and choose Rename Favorite. Type a name into the box and click OK.</td>
</tr>
<tr>
<td>To remove a selected item from the Favorites list</td>
<td>Click on an item in the Favorites section to select it. Then right-click on the same item and choose Remove Favorite from This List.</td>
</tr>
<tr>
<td>To remove all items from the list</td>
<td>Right-click in the Favorites section and select Clear Favorites.</td>
</tr>
</tbody>
</table>
Recent section

When you perform a search for a gene or numerical sequence location using Edit > Go To Position, each found location is automatically stored in the Recent section. Access this section by clicking on the Places panel expand bar entitled “Recent,” or by choosing View > Places > Recent.

Recent locations are listed in the same order in which they were added, and the list is saved whenever you save a project.

<table>
<thead>
<tr>
<th>Task</th>
<th>How to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>To return to a location on the list</td>
<td>Double-click on the location name, or make a selection from the list and press the Go to this gene or location button ( ).</td>
</tr>
<tr>
<td>To save a location on the list to the Favorites section (similar to bookmarking a page on the Internet)</td>
<td>Make a selection from the list and press the Add this place to Favorites button ( ). Alternatively, make a selection from the list, then right-click on the item and choose Add This Place to Favorites.</td>
</tr>
<tr>
<td>To remove all items from the Recent list</td>
<td>Right-click in the Recent section and select Clear Recent.</td>
</tr>
</tbody>
</table>
Details panel

The Details panel shows details of the application, selection or project.

To open the Details panel:

This panel is represented by a blue “information” icon (ℹ️). If the panel is not already visible, reveal it using any of the following methods:

- Choose View > Details or View > Reset Panel Layout.
- Right-click on a track in the Overview or Sequences view and choose Show Details Panel.

Interpreting the Details panel display:
Details are available for all tracks in the Overview and Sequences View, as well as the Tracks panel. The panel shows actions to get started when there is no project open, or when the active project is empty. If there is a selection, the panel shows details about the selected item(s). Otherwise, the panel shows details about the project. For detailed information, see the following sub-topics:

- **When no document, or a blank document, is open**
- **When a non-empty document is open**
- **When one sequence is selected**
- **When a portion of a sequence is selected**
- **When multiple sequences are selected**
- **When a portion of multiple sequences is selected**
- **When one track is selected**
- **When multiple tracks are selected**
- **When one feature is selected**
- **When multiple features are selected**
- **When a portion of a pairwise alignment is selected**
When no document, or a blank document, is open

When no document or only a blank document (one containing no sequences) is open, the Details panel displays links to help you get started in MegAlign Pro.

<table>
<thead>
<tr>
<th>Getting Started in MegAlign Pro</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a new alignment project</td>
</tr>
<tr>
<td>Open a file</td>
</tr>
<tr>
<td>Import an alignment</td>
</tr>
<tr>
<td>Add sequences</td>
</tr>
<tr>
<td>Add sequences end-to-end</td>
</tr>
<tr>
<td>Watch a training video</td>
</tr>
</tbody>
</table>

One or more links are available. The first three options are available for blank documents, but unavailable when no document is open:

- Create or open a project
- Import an alignment
- Add sequences to the project (or add them end-to-end).
- Watch a training video

<table>
<thead>
<tr>
<th>Recent Documents</th>
</tr>
</thead>
<tbody>
<tr>
<td>RPL project.msa</td>
</tr>
<tr>
<td>ADH Project.msa</td>
</tr>
<tr>
<td>Drosophila project.msa</td>
</tr>
<tr>
<td>ADH project.msa</td>
</tr>
</tbody>
</table>

Open a recent document.
When a non-empty document is open

If a document is open and contains sequences (whether they have been aligned or not) and nothing is selected, the [Details panel](#) contains the following information:

<table>
<thead>
<tr>
<th>Heading</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>ADH Project.msa</td>
<td></td>
</tr>
<tr>
<td><strong>Sequence type</strong>: Protein</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Alignment</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Alignment</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Alignment</strong>: Clustal Omega</td>
<td></td>
</tr>
<tr>
<td><strong>Sequences</strong>: 5</td>
<td></td>
</tr>
<tr>
<td><strong>Sequence type</strong>: Protein</td>
<td></td>
</tr>
<tr>
<td><strong>Min. sequence length</strong>: 348</td>
<td></td>
</tr>
<tr>
<td><strong>Max. sequence length</strong>: 377</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Unaligned Sequences</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Sequences</strong>: 5</td>
<td></td>
</tr>
<tr>
<td><strong>Sequence type</strong>: Protein</td>
<td></td>
</tr>
<tr>
<td><strong>Min. and Max. sequence lengths</strong>:</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Actions</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Add sequences</strong> – Shortcut to File &gt; Add Sequences (see Add ungapped / gapped sequences to a project).</td>
<td></td>
</tr>
<tr>
<td><strong>Add sequences end-to-end</strong> – Shortcut to File &gt; Add Sequences End-to-end (See Add multi-segment sequences to a project).</td>
<td></td>
</tr>
<tr>
<td><strong>Align with options</strong> – Shortcut to Align &gt; Align with Options.</td>
<td></td>
</tr>
</tbody>
</table>
**When one sequence is selected**

If a single sequence has been selected in any view, the Details panel may contain a subset of the following information:

<table>
<thead>
<tr>
<th>Heading</th>
<th>The default name, if present, appears in blue above 'Organism.'</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>AAC41757</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Organism</strong></td>
<td>Homo sapiens (human)</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>alcohol dehydrogenase 1 [Homo sapiens].</td>
</tr>
<tr>
<td><strong>Sequence type</strong></td>
<td>Protein</td>
</tr>
<tr>
<td><strong>Residues</strong></td>
<td>375</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Properties</th>
<th>• <strong>Organism</strong> – The organism from which the sequence originated, if available.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Accession number</strong></td>
<td>AAC41757</td>
</tr>
<tr>
<td><strong>Sequence shape</strong></td>
<td>Linear</td>
</tr>
<tr>
<td><strong>Sequence version</strong></td>
<td>1</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Data</th>
<th>• <strong>Accession number</strong> – The NCBI accession number of the selected sequence.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• <strong>Sequence shape</strong> – Linear, Circular, or Unknown.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Sequence version</strong> – The NCBI version number (the part following the decimal after the accession number).</td>
</tr>
<tr>
<td></td>
<td>• <strong>Data specification</strong> – The name of the sequence file and the &quot;sequence name within the file,&quot; followed by the file extension.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Data file time</strong> – The time the sequence file was created or modified.</td>
</tr>
<tr>
<td>Actions</td>
<td></td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------</td>
</tr>
<tr>
<td>• <strong>Data file path</strong> – The path to the original sequence file on your computer.</td>
<td></td>
</tr>
<tr>
<td>• <strong>Rename</strong> – Shortcut to Edit &gt; Rename (See Rename sequences manually).</td>
<td></td>
</tr>
<tr>
<td>• <strong>Rename with Fields</strong> – Shortcut to Edit &gt; Rename with Fields (See Rename sequences automatically using specified data fields).</td>
<td></td>
</tr>
</tbody>
</table>
When a portion of a sequence is selected

When a portion of a sequence has been selected in any view (e.g., by double-clicking on a feature, or by dragging across the sequence with the mouse) except the Pairwise view, the Details panel contains the following information:

<table>
<thead>
<tr>
<th>Heading</th>
<th>Actions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Selected Region</strong></td>
<td><strong>Sequence</strong> – The name of the sequence from which the region was selected. This is not shown for pairwise alignment selections.</td>
</tr>
<tr>
<td><strong>Sequence:</strong> XM_541769</td>
<td><strong>Alignment/Sequence selection</strong> – (Pairwise) Alignment selection displays the inclusive coordinates of the beginning and end of the selection.</td>
</tr>
<tr>
<td><strong>Alignment selection:</strong> (1,538&gt;1,555)</td>
<td>When the sequence is not part of an alignment, (i.e., is listed with ‘unaligned sequences’), then then Alignment selection is replaced with Sequence selection. In this case, the coordinates are the ungapped sequence coordinates rather than the alignment coordinates.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Actions</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Copy</strong></td>
<td>Shortcut to Edit &gt; Copy (See Copy, Paste and Delete).</td>
</tr>
<tr>
<td><strong>Copy As FASTA</strong></td>
<td>Shortcut to Edit &gt; Copy As FASTA (See Copy, Paste and Delete).</td>
</tr>
</tbody>
</table>
### When multiple sequences are selected

If two or more sequences have been selected in any view, the [Details panel](#) contains the following information:

<table>
<thead>
<tr>
<th>Heading</th>
<th>Actions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>2 sequences</strong></td>
<td>Rename with Fields – Shortcut to Edit &gt; Rename with Fields (see <a href="#">Rename sequences automatically using specified data fields</a>).</td>
</tr>
<tr>
<td>Sequence type: Protein</td>
<td></td>
</tr>
<tr>
<td>Min. sequence length: 348</td>
<td></td>
</tr>
<tr>
<td>Max. sequence length: 375</td>
<td></td>
</tr>
</tbody>
</table>

- **The number of sequences selected** (in blue).
- **Sequence type** – DNA, RNA or Protein.
- **Min. and Max. sequence lengths** – Lengths of the shortest and longest sequences selected, in nucleotides or residues.
When a portion of multiple sequences is selected

When a portion of multiple aligned sequences has been selected (e.g., by triple-clicking on a feature, or by dragging across the consensus sequence with the mouse), the Details panel contains the following information:

<table>
<thead>
<tr>
<th>Heading</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Selected Region</strong></td>
<td></td>
</tr>
<tr>
<td>Sequences: 4</td>
<td></td>
</tr>
<tr>
<td>Alignment selection: 2,148-&gt;2,173</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Actions</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Copy</strong> – Shortcut to Edit &gt; Copy (see Copy, Paste and Delete).</td>
<td></td>
</tr>
<tr>
<td><strong>Copy As FASTA</strong> – Shortcut to Edit &gt; Copy As FASTA (see Copy, Paste and Delete)</td>
<td></td>
</tr>
</tbody>
</table>
When one track is selected

If a single track has been selected in the Overview or Sequences view, the Details panel contains the following information.

<table>
<thead>
<tr>
<th>Heading</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Features</strong></td>
<td>• Type of track (in blue).</td>
</tr>
<tr>
<td><strong>Summary</strong></td>
<td>• <strong>Summary</strong> – Basic information about what is displayed in the selected track.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Actions</th>
<th>Actions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Actions</strong></td>
<td>Only a subset of links may be available, depending on the selected track.</td>
</tr>
<tr>
<td>Rename...</td>
<td>• <strong>Rename</strong> – Shortcut to Edit &gt; Rename (See Rename sequences manually).</td>
</tr>
<tr>
<td>Rename with Fields...</td>
<td>• <strong>Rename with Fields</strong> – Shortcut to Edit &gt; Rename with Fields (See Rename sequences automatically using specified data fields).</td>
</tr>
<tr>
<td>Show track layout</td>
<td>• <strong>Show track layout</strong> – Shortcut to View &gt; Tracks &gt; Layout.</td>
</tr>
<tr>
<td>Show track options</td>
<td>• <strong>Show track options</strong> – Shortcut to View &gt; Tracks &gt; Options.</td>
</tr>
</tbody>
</table>

For additional information about using tracks, see Tracks panel and Tracks.
When multiple tracks are selected

If two or more tracks have been selected in the Overview or Sequences view, the Details panel contains the following information.

<table>
<thead>
<tr>
<th>Heading</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>2 tracks</strong></td>
<td>- Number of tracks currently selected (in blue).</td>
</tr>
<tr>
<td>Summary: Multiple tracks are selected. They can be moved or hidden together.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Actions</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Show tracks panel</strong></td>
<td>- Shortcut to View &gt; Tracks &gt; Tracks.</td>
</tr>
</tbody>
</table>

For additional information about using tracks, see the topics Tracks panel and Tracks.
When one feature is selected

If a single feature has been selected in a track in the Overview or Sequences view (e.g., by clicking one time on the feature), the Details panel contains the following information:

<table>
<thead>
<tr>
<th>Heading</th>
<th>Feature name (in blue).</th>
</tr>
</thead>
<tbody>
<tr>
<td>alcohol_DH_class_I_II_IV</td>
<td>Type – Feature type.</td>
</tr>
<tr>
<td>Type: Region</td>
<td>Left and Right – The inclusive coordinates of the beginning and end of the feature range.</td>
</tr>
<tr>
<td>Left: 3</td>
<td>Length – Length of the selected feature in nucleotides or residues.</td>
</tr>
<tr>
<td>Right: 375</td>
<td></td>
</tr>
<tr>
<td>Length: 373</td>
<td></td>
</tr>
</tbody>
</table>

Location

Range of the feature in nucleotides or residues.

Properties

Properties shown vary by feature and may include the organism, gene name NCBI feature qualifiers, etc.

Notes

• note – The NCBI feature qualifier of the same name.

Actions

• Select Subsequence – Shortcut to Edit > Select Subsequence (see Make Selections). Double-clicking on the feature fulfills the same function.

• Select Subsequences Across Alignment – Shortcut to Edit > Select Subsequences Across Alignment.
(see Make Selections). Triple-clicking on the feature fulfills the same function. This item is not available for features in unaligned sequences.

For additional information about working with features, see Features panel and Features.
When multiple features are selected

If two or more features have been selected in a track in the Overview or Sequences view, the Details panel contains the following information:

### Heading

<table>
<thead>
<tr>
<th>3 features</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type: Region, source, Protein</td>
</tr>
<tr>
<td>Left: 1</td>
</tr>
<tr>
<td>Right: 374</td>
</tr>
<tr>
<td>Min. Length: 368</td>
</tr>
<tr>
<td>Max. Length: 374</td>
</tr>
</tbody>
</table>

- Number of features currently selected (in blue).
- **Type** – List of all feature types represented in the selection.
- **Left** and **Right** – The inclusive coordinates of the beginning and end of the feature range.
- **Min.** and **Max. Length** – Lengths of the shortest and longest features in the selection.

### Properties

- Properties, if shown in this case, will vary by feature and may include the organism, gene name NCBI feature qualifiers, etc.
- `db xref: taxon:10090, GeneID:15465, MGI:107619`

For additional information about working with features, see Features panel and Features.
When a portion of a pairwise alignment is selected

When a portion of a sequence has been selected in the Pairwise view (e.g., by double-clicking on a feature, or by dragging across the sequence with the mouse), the Details panel contains the following information:

<table>
<thead>
<tr>
<th>Heading</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Selected Region</td>
<td>• <strong>Selected Region</strong> – (in blue) Unchangeable default value.</td>
</tr>
<tr>
<td>Pairwise alignment selection</td>
<td>• <strong>Pairwise alignment selection</strong> – The inclusive coordinates of the beginning and end of the selection.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Actions</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>• <strong>Copy</strong> – Shortcut to Edit &gt; Copy (See Copy, Paste and Delete).</td>
</tr>
<tr>
<td>Copy as FASTA...</td>
<td>• <strong>Copy As FASTA</strong> – Shortcut to Edit &gt; Copy As FASTA (See Copy, Paste and Delete).</td>
</tr>
</tbody>
</table>
Console panel

The Console panel displays information, messages and warnings about the operation in progress, or an operation that was recently performed.

To display the console for a particular project:

Click the tab with the project name, then open its console using the View > Console command. Each view will have a different console.

To use the Console panel:

Each console has a maximum number of characters. If this maximum is exceeded, the oldest characters disappear in order to make room for new characters.
Right-click on the Console tab to access commands allowing you to move, hide, rearrange, or restore panels and views. (See Hide, show, move, or resize items in the MegAlign Pro window).

The following tools are available in the upper right of the Console panel:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Clear Console]</td>
<td>Clear Console</td>
<td>Clears all text from the active Console.</td>
</tr>
<tr>
<td>![Scroll Lock]</td>
<td>Scroll Lock</td>
<td>Stops auto-scrolling caused by alignment output. When alignment output is long, this may fail due to a limit on the amount of text in the console.</td>
</tr>
<tr>
<td>![Word Wrap]</td>
<td>Word Wrap</td>
<td>Controls whether or not lines wider than the console panel should be wrapped.</td>
</tr>
<tr>
<td>![Pin Console]</td>
<td>Pin Console</td>
<td>Keeps the current Console active even if another project is selected.</td>
</tr>
<tr>
<td>![Display Selected Console]</td>
<td>Display Selected Console</td>
<td>Consoles can be displayed for one or more open projects. If more than one alignment is in progress, clicking the arrow to the right of this icon opens a drop-down menu from which the desired Console can be brought to the front.</td>
</tr>
<tr>
<td>![Open Console]</td>
<td>Open Console</td>
<td>Opens a new Console. If more than one alignment is in progress at the same time, you can open a new Console and pin it to a particular run using Pin Console (above).</td>
</tr>
<tr>
<td>![Minimize]</td>
<td>Minimize</td>
<td>Minimizes the Console.</td>
</tr>
<tr>
<td>![Maximize]</td>
<td>Maximize</td>
<td>Maximizes the Console.</td>
</tr>
</tbody>
</table>
# Hide, show, move, or resize items in the MegAlign Pro window

Controls for MegAlign Pro’s docking area, panels and expand bars are described in the following table. Not all options in the table are applicable to every item.

<table>
<thead>
<tr>
<th>Task</th>
<th>“How To”</th>
</tr>
</thead>
<tbody>
<tr>
<td>To show or open a hidden item</td>
<td>Use the associated <strong>View</strong> menu command, click on a closed expand bar, or click on a plus sign.</td>
</tr>
<tr>
<td>To hide or close a visible item</td>
<td>Use the <strong>Close</strong> icon (🗹) or <strong>Minimize</strong> icon (🗹), click on an open expand bar, or click on a minus sign. To close one or more tabs, right-click on a project, view or panel tab and choose <strong>Close, Close Others, Close Tabs to Right</strong>, or <strong>Close All</strong>. Some of these options are only available for certain tabs.</td>
</tr>
<tr>
<td>To increase or decrease the size of an item</td>
<td>Drag the bottom or left sides of the item or use the <strong>Maximize</strong> icon (🗹) or <strong>Restore</strong> icon (🗹). To view more of an open expand bar, close neighboring bars and/or increase the size of the whole panel.</td>
</tr>
<tr>
<td>To move an item</td>
<td>Using the mouse, grab a project, view or panel tab, then drag and drop it in the desired location.</td>
</tr>
<tr>
<td>To move a view or panel up/down</td>
<td>Right-click on the view or panel tab and choose <strong>Move Up (Down)</strong>.</td>
</tr>
<tr>
<td>To return to the default MegAlign Pro display</td>
<td>Choose <strong>View &gt; Reset Panel Layout</strong>.</td>
</tr>
<tr>
<td>To return to a view or bring a floating view to the top</td>
<td>Choose <strong>View &gt; Show Document View &gt; (View Name)</strong>. This command can also be used to regenerate a <strong>Pairwise view</strong> that was closed.</td>
</tr>
<tr>
<td>To scroll vertically</td>
<td>Use the vertical scrollbar or the mouse wheel.</td>
</tr>
<tr>
<td>To scroll horizontally</td>
<td>Use the horizontal scrollbar, or hold down the <strong>Alt</strong> key (Win) or <strong>Option</strong> key (Mac) and drag the mouse.</td>
</tr>
</tbody>
</table>
Sequences

You can add the following types of sequences to a MegAlign Pro project:

- Ungapped sequences, including SeqNinja files
- Gapped sequences
- Multi-segment sequences
- Sequences from a saved MegAlign Pro project

Once sequences have been added, you can:

- Manually specify sequence type (DNA, RNA, protein)
- Reorder sequences
- Rename sequences manually or automatically, using specified data fields
- Remove sequences from a project
Add ungapped sequences to a project

To add standard (ungapped) sequences, or additional sequences, to an existing project:

You can add standard DNA, RNA or protein sequences from a wide variety of file types, including SeqNinja .star files. (See Advantages of using SeqNinja files).

- Choose File > Add Sequences, select the Add Sequences button ( ), or press Ctrl/Cmd+E. Then choose one or more sequences from the file browser.

- Drag & drop one or more sequence files (but not folders or MegAlign Pro .msa projects) on an open project.

A project can consist of any combination of file types, including single and multi-segment sequences, but all sequences must be either DNA, RNA or protein.

\* Note: Addition of gapped or multi-segment sequences is discussed separately.

The following table shows error messages that you might encounter when adding sequences to a project.

<table>
<thead>
<tr>
<th>Situation</th>
<th>Message and response</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding a MegAlign Project (.msa file)</td>
<td>Click <strong>OK</strong> to add unaligned sequences from the saved project to the current project. This is one way to remove gaps from sequences so that they can be used in MegAlign Pro.</td>
</tr>
</tbody>
</table>
### Adding a sequence that contains gap characters (e.g., dashes or question marks)

Click **OK** to add only those sequences without gaps to the project. (There is a separate method for **adding gapped sequences**).

### Attempting to enter mixed sequence types (both protein and nucleotide) to the Sequences View

Click **OK** to add all the sequences to the project. Afterwards, manually remove any sequences that are not of the desired category.

### Attempting to load more than 1000 sequences

After clicking **OK**, a progress bar is displayed.
Press **OK** to continue loading all of the sequences. MegAlign Pro will display a progress bar (see lower image, left) with a running count of the number of sequences loaded so far. At any point, you may cancel the entire sample upload by pressing **Cancel**. This terminates the entering step without adding the new file(s). Otherwise, simply wait for the samples to finish loading.

**Entering SeqNinja projects (.star) or FASTA files with ambiguous extensions (e.g., .fasta)**

MegAlign Pro can usually determine whether the sequence consists of DNA, RNA or protein. If it cannot, MegAlign Pro will prompt you to specify file type by selecting a button from the dialog.

**Attempting to add a SeqNinja project (.star) that contains errors**

Click **OK**. Launch SeqNinja, fix any errors in the project and save it before adding the file to MegAlign Pro.
Advantages of using SeqNinja files

SeqNinja is DNASTAR’s tool for advanced and batch editing of genome sequences and features. SeqNinja allows you to convert file formats, batch edit and export features, merge and split sequence data, and transfer features between genome versions, automating the process of adjusting sequence coordinates between SeqMan NGen assemblies. The SeqNinja project – which can be created easily using the provided templates – has the extension “.star,” and uses one or more data files as inputs for its calculations. When you run the .star program, the output format can be saved in a variety of popular file types, such as FASTA, GenBank, Lasergene, etc.

While you can certainly add the SeqNinja output files to MegAlign Pro, it is also possible to add the .star project as input. To add either of these, see Add ungapped sequences to a project.

Adding one or more SeqNinja projects (.star) to a MegAlign Pro project is an indirect way of adding sequences. Sequences specified by a SeqNinja project file are all those that would be written if the project were run using SeqNinja. Using SeqNinja project files as MegAlign Pro input can save a lot of time and effort. The advantage of adding a .star project to MegAlign Pro is that it will always call up the most up-to-date version of the input data for use in making its output. So if you change, add, or delete the input data that the .star file points to, the .star file will update this information in MegAlign Pro.

The following example demonstrates the advantages of adding a .star file to MegAlign Pro:

Assume you have a directory of genomes for a phylogenetic study. You want to extract a specific gene, or set of genes, from each genome to build an alignment, and then a phylogenetic tree. Over the course of your work, new genomes and new versions of existing genomes become available. You want to generate a current alignment and tree that reflects those additions or changes. Here are three scenarios of the steps needed to do this:

**Good: Without using SeqNinja:**

1. Manually extract the genes of interest.
2. Generate output files (e.g., FASTA, GenBank, etc.).
3. Add the files to MegAlign Pro.
4. Run the alignment.
5. **Repeat Steps 1-4 every time the input data changes.**

**Better:** Using SeqNinja output (e.g., FASTA, GenBank) or a SeqNinja project file as MegAlign Pro input:

1. Create a SeqNinja program to automatically extract the genes of interest.
2. Run the program and generate output files (e.g., FASTA, GenBank, etc.).
3. Add the output files or the SeqNinja project (.star) to MegAlign Pro.
4. Run the alignment.
5. **Repeat Steps 2-4 every time the input data changes**

**Best:** Creating a SeqNinja project to use with MegAlign Pro:

For detailed information about creating SeqNinja projects, launch the SeqNinja application and select **Help > Help Contents**.

When you use a SeqNinja Project (.star) file as input for MegAlign Pro, note that the project is read as a “set of sequences,” and is not actually executed, meaning no sequence files are written. This type of project has the following limitation:

Any input files referenced in the program must already exist. In other words, the program should not reference an input file that doesn’t exist until it is created earlier in the same program. Instead:

- Replace all the references to the input file with a variable (e.g., $A), or...
- Create a SeqNinja program to create the necessary files and run the program. Then, in the SeqNinja program you wish to add to MegAlign Pro, reference those already-created files.
Add gapped sequences to a project

To import gapped sequences from an existing MegAlign Pro file (.msa):

The following procedures both remove gaps from the sequences and place the updated sequences in the “Unaligned Sequences” area of the project.

- Click on the Add Sequences button ( ) or select File > Add Sequences and choose the .msa file.
- Use File > Open and choose the .msa file. Once the project is open, select all the sequences, then use Align > Unalign Selected.

**Note**: MegAlign Pro uses a dash (-) to represent gaps. MegAlign Pro does accept sequences where gaps are represented by letters such as “n” or “x.” Sequences with non-IUPAC symbols other than dashes may be accepted by MegAlign Pro as input, but may not be recognized by certain alignment algorithms. Of MegAlign Pro’s methods, MAFFT is the most tolerant of non-IUPAC symbols.

To import gapped nucleotide sequences from another type of file (not .msa):

When the gapped sequences are not part of a MegAlign Pro file, you can use SeqMan Pro to remove the gaps. This procedure is safe to use for nucleotide (DNA or RNA) sequences only.

1. Launch DNASTAR SeqMan Pro, then drag and drop the gapped sequence file(s) onto the SeqMan Pro window.

2. Select all sequences in the Unassembled Sequences using Ctrl+A (Win) or Cmd+A (Mac).


4. Select either FastA or GenBank Flat File format and choose a file name and location. Make sure that Include gaps is left unchecked, and then click Save.

The sequence(s) in the newly saved file can now be added in the usual way.
**WARNING:** Do not use this method for protein sequences, as all letters that are not also in the IUPAC nucleic acid code will be lost.
Add multi-segment sequences to a project

Sequences that consist of more than one chromosome, contig, or fragment are called multi-segment sequences. By entering a group of sequences into MegAlign Pro using a special command, the entire data set will be concatenated end-to-end and treated as a single multi-segment sequence.

Suppose you want to string together the consensus sequences from all the contigs in an assembly, or chromosomes in a genome, or exons in a gene, etc. If you enter these sequences using **File > Add Sequences** or the corresponding button ( ), you will end up aligning the parts to one another. To avoid this, use the following procedure:

**To add sequences end-to-end:**

Choose **File > Add Sequences End-to-end**, select the **Add sequences end-to-end in project** tool ( ), or press **Ctrl/Cmd+Shift+E**. The following dialog appears:

![Add Sequences End-to-end dialog](image)

- To name the group, type a name in the **Group name** box. This serves as a substitute for a regular sequence name in all the MegAlign Pro views. If you do not explicitly type a name into the **Group name** box, a default name will be computed from the items in the list.

**Note:** Like other sequence names, a Group name can be changed later from within the
To add a sequence file to the left-hand pane, click Add. Alternatively, you may simply drag files from any file explorer & drop them into the main part of the dialog. Any supported MegAlign Pro file type may be added.

Each group of multi-segment sequence should have its segments arranged in the same order relative to other groups. To reorganize sequences, select a sequence in the left pane and then use the Up or Down buttons to move it to the desired position.

To remove a sequence from the left-hand pane, select it and click Remove.

To add another group of sequences after you save the current group, leave the Add another box checked. Otherwise, remove the check mark.

Click OK to keep your changes and add the sequence group(s) to the project, or Cancel to leave the dialog without adding the sequence group(s) to the project.

Unless you unchecked the Add another box, a new Add Sequences End-to-end dialog will appear after you check OK. If you don’t have any additional groups to add, you can exit by pressing Cancel.

To edit an existing end-to-end group:

Select an aligned or unaligned sequence group in any view and choose Edit > Edit Sequences End-to-end.

If you select an aligned sequence and then apply changes in this dialog, the sequence will be removed from the alignment and placed in the “Unaligned Sequences” area. Because of this possibility, you must respond OK to the following prompt before the dialog will open:
Try it! – Add and align multi-segment sequences

The following video tutorial describes how to add multi-segment sequences and then align them using the MUSCLE multiple alignment algorithm.

If you have not yet download and extracted the tutorial data, click here to download it. Then decompress (unzip) the file archive using the method of your choice.
Add sequences from a saved project to an active project

To add sequences from a saved project to an active project:

Choose File > Add Sequences and select a MegAlign Pro project file (.msa). All sequences in the .msa file will be added to the “Unaligned Sequences” area of the active project.
Manually specify sequence type

To manually specify a sequence type for the active project:

In most cases, MegAlign Pro can read whether a sequence is DNA, RNA or protein using clues in the sequence itself. In rare cases, you may need to over-ride or manually specify the sequence type.

Choose Edit > Change Sequence Type. After you select the desired sequence type by pressing its button, MegAlign Pro will treat all sequences in the project as being of the specified type.
Change the order of sequences

To change the order of sequences in views:

Sequences may be rearranged one at a time or as contiguous groups using drag and drop. To move several sequences as a group, select them with Ctrl/Cmd+click or Shift+click, then drag them to the desired location and release the mouse button. Any ordering changes made to the Sequences view are simultaneously made to the Distance view and to the Overview.

To reorder sequences in the other views in the same order as the Tree view:

The Tree view sequences are ordered top-to-bottom in the vertical formats and left-to-right in the horizontal ones. This means that the order of sequence names shown in the phylogenetic tree may vary from ordering seen in the Sequences and Distance view and the Overview. To force the other views to reorder their sequences to agree with the Tree view, use Tree > Order Sequences Like Tree.
Rename sequences manually

To manually rename a selected sequence:

1. Select a single sequence name from any MegAlign Pro view, then right-click on it and choose Rename. Alternatively, select the sequence name and choose Edit > Rename.

   The Choose Label dialog opens with the Display drop-down menu set to Custom label.

2. Type the desired name into the Label text box.

3. Click OK to save changes and exit from the dialog, or Cancel to leave the dialog without saving any changes.

   Note: When you export data for a renamed sequence, the new name may be exported or not, depending on the situation. See Retain custom names during export for details.
Rename sequences automatically using specified data fields

The following procedure lets you create labels for one or more selected sequences automatically, using specified fields such as sequence length, organism, or description.

To rename sequences using specified data fields:

1. Select one or more sequence names from any MegAlign Pro view.

2. Right-click on the selection and choose Rename with Fields, or instead choose Edit > Rename with Fields from the main menu. Making no selection prior to using the main menu command is equivalent to selecting all sequences.

   The Choose Label dialog opens with the Display drop-down menu set to One or more fields.
The left pane shows available fields, and the right pane shows fields that will be displayed as part of the sequence name. Initially, **Default name** is the only field listed in the right pane. An example showing the appearance of the name using the specified field(s) appears in the **Example** box at the bottom of the dialog.

3. Select and organize the fields you wish to display as part of the sequence name:

   • To add or remove items, move them between panes using the left and right arrows (← →). Use the up and down arrows on the right (↑ ↓) to specify the order in which displayed fields should appear.

   • By default, a hyphen (-) is included between each of the displayed fields. If desired, type in a different **Separator**. Or remove all text in the **Separator** box to include nothing between the fields.
• The **Example** text box shows what the label will look like with the current selections. This text can be manually edited, if desired.

4. When you are satisfied with the choices made in this dialog, click **OK** to save changes and exit from the dialog. Or click **Cancel** to leave the dialog without saving any changes.

**Note:** When you export data for a renamed sequence, the new name may be exported or not, depending on the situation. See [Retain custom names during export](#) for details.
Remove sequences from a project

The following procedure causes the selected sequences to be completely removed from the project, not simply moved to the “Unaligned Sequences” area.

To remove sequences from the project:

1. Select one or more of the aligned or unaligned sequences in the Overview or Sequences View by clicking, Ctrl/Cmd+clicking or Shift+clicking on the sequence name(s).

2. To remove sequences, either:
   - Right-click on the list of sequence names, and select Remove Sequence(s) from the menu.
   - Press the Delete key or use Edit > Delete.

3. Respond to the confirmation message that appears, if any. Different versions of the message appear, depending whether you have selected aligned and/or unaligned sequences. One example is shown below.

![Confirm Remove dialog box](image)

Notes:

- During multiple alignment, “guide trees” are created that govern the order in which sequences are aligned to each other, starting with the most similar pair. Guide trees, in turn, are based upon all possible pairwise relationships among the member sequences.

- When one or more sequences are removed from an alignment, any column containing 100% gaps is removed from all of the remaining aligned sequences. No new guide tree (representing the remaining
sequences) is calculated. Therefore, the resulting alignment may not be as good as one produced by performing a completely new alignment with the remaining sequences.

- When features have been mapped to the consensus, removing sequences from the alignment or unaligning (using Align > Unalign All) will cause all features to be removed from the consensus sequence. This is because feature mapping may no longer be accurate, since the consensus sequence may have different gapping.
Tracks

“Tracks” are rows of information that can be displayed or hidden, as desired, in the **Overview** and **Sequences view**. Tracks can pertain to a header, footer, or individual sequence row. The following video provides a brief overview of how tracks are used in MegAlign Pro:

The following tracks can be applied, removed or (in most cases) edited:

- Ruler
- Feature
- Consensus
- Consensus Match
- Sequence Logo
- GC Content
- Gap Fraction
- Numeric
- Pairwise Match Bar
- Translation

The following table shows tasks that affect the display of tracks within the Overview and Sequences views:

<table>
<thead>
<tr>
<th>Task</th>
<th>How to…</th>
</tr>
</thead>
</table>

Copyright DNASTAR, Inc. 2019
<table>
<thead>
<tr>
<th>To create tracks</th>
<th>Track data can be imported automatically with some types of sequence data (e.g., Feature tracks), or can be calculated by the application itself (e.g., Ruler and Numeric tracks).</th>
</tr>
</thead>
<tbody>
<tr>
<td>To display tracks in the views</td>
<td>To display any type of track, you must check the box next to the name of the track in the Tracks panel. This is the only condition needed to view a Ruler track. For any type of track other than a Ruler, you must also expand the track as described below.</td>
</tr>
<tr>
<td>Do any of the following:</td>
<td></td>
</tr>
<tr>
<td>• Click the plus/minus sign to the left of the sequence name ( / ).</td>
<td></td>
</tr>
<tr>
<td>• To expand tracks for selected sequences, choose Sequence &gt; Expand Sequence Rows or Overview &gt; Expand Overview Rows; or right-click on the selection and choose Expand.</td>
<td></td>
</tr>
<tr>
<td>• To collapse tracks for selected sequences, choose Sequence &gt; Collapse Sequence Rows or Overview &gt; Collapse Overview Rows; or right-click on the selection and choose Collapse.</td>
<td></td>
</tr>
<tr>
<td>To expand/</td>
<td>Ensure that no sequences are selected.</td>
</tr>
<tr>
<td>collapse tracks for all</td>
<td></td>
</tr>
<tr>
<td>sequences in a particular view</td>
<td>• To expand tracks for all sequences, choose Sequence &gt; Expand All Rows or Overview &gt; Expand All Rows; or right-click in the view and choose Expand All.</td>
</tr>
<tr>
<td></td>
<td>• To collapse tracks for all sequences, choose Sequence &gt; Collapse All Rows or Overview &gt; Collapse All Rows; or right-click in the view and choose Collapse All.</td>
</tr>
<tr>
<td>To hide tracks</td>
<td>Do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• To hide a specific track from all views, uncheck the box next to the name of the track in the Tracks panel.</td>
</tr>
<tr>
<td></td>
<td>• To hide a specific track in one view only, right-click on the track within that view and choose Hide Track. Alternatively, select a track and use Edit &gt; Delete or press the Delete key.</td>
</tr>
<tr>
<td></td>
<td>• To hide all tracks in one view only, click the minus sign ( ) to the left of the sequence name in that view, or use Analysis &gt; Collapse Sequence Rows or Overview &gt; Collapse Sequence Rows.</td>
</tr>
<tr>
<td></td>
<td>• To hide all tracks in all views, do a combination of the above.</td>
</tr>
<tr>
<td><strong>To access the options for a particular type of track</strong></td>
<td>Do either of the following:</td>
</tr>
<tr>
<td>--------------------------------------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td></td>
<td>• Right-click on a track in either view and choose <strong>Show Track Options</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>View &gt; Tracks &gt; Options</strong> or open the Tracks panel and click the Options bar (Options), then do either of the following to specify the track of interest by clicking on its name in the <strong>Tracks panel</strong>.</td>
</tr>
</tbody>
</table>

| **To change the order of all tracks in a view** | Open a sequence row to view its track. Then drag a track label (e.g. "Features") to the desired position among the other tracks and drop it there. Note that if you turn off some tracks in the Tracks panel and add them again later, they will appear in the order in which their boxes were checked. |

| **To increase/decrease the vertical height of a visible track** | Hover the mouse over the bottom of the track in the Overview or Sequences view, then grab the resize bar and drag it up or down. |

| **To see how the zoom level can affect the appearance of tracks** | See **Zoom in or out on a view**. |
**Ruler tracks**

**To view consensus rulers:**

Blue consensus rulers number and tick any gaps found in the consensus. The visibility of consensus rulers in the [Overview](#), [Sequences view](#) and [Pairwise view](#) is dependent on:

- Which boxes you check in the [Tracks panel](#) (see image below).
  
  - **Ruler** – Overview header & Pairwise view
  
  - **Sequence Ruler** – Overview footer
  
  - **Ruler 1** – Sequences View header
  
  - **Ruler 2** – Sequences View footer

- Whether or not tracks are visible in a given view. To display tracks, click on the plus sign next to a sequence in the view of interest.
To view gap-aware sequence rulers:

Unlike the blue consensus rulers described above, black “gap-aware” sequence rulers use pre-alignment numbering for the sequences. The visibility of sequence rulers in views is dependent on:

- Which boxes you check in the Tracks panel. Boxes for **Sequence Ruler** appear in three parts of the Tracks panel: Overview Details, Sequence Details, and Pairwise Details.

- Whether or not tracks are visible in the views. To display hidden tracks, click on the plus sign next to a sequence in the view of interest.

*Note: In the Overview, a sequence ruler running from left to right (i.e., larger numbers on the right), denotes a sequence that has been reverse complemented with respect to its original orientation. MegAlign Pro does not permit manual reverse-complementing of sequences, but the **Mauve** multiple alignment algorithm reverse-complements automatically, where necessary. In a Mauve multi-block alignment, changing the active block can cause entire sequences to be reverse-complemented.*

To change Ruler options:

Currently, the Ruler tracks do not have editable options. However, you can add white space above and/or below the ruler using sliders in the **Layout section**.
Features tracks

To display sequence features:

The visibility of feature (annotation) tracks in the **Overview**, **Sequences view** and **Pairwise view** is dependent on:

- Whether or not tracks are visible in those views. To display hidden tracks, click on the plus sign next to the sequence of interest in the Overview or Sequences view.

- Which boxes you check in the **Tracks panel** (see image below). Features can be displayed in individual views by clicking the **Features** boxes under: Overview details, Sequence details, and Pairwise details. Hover the mouse over a feature to view a tooltip with details about the feature. Note that after performing a multiple alignment, checking the **Consensus** box will also cause Consensus features imported with **Features > Map Features to Active Consensus** to be displayed.

- **Features** (under Pairwise details*) – Check this box to display any available sequence features as Pairwise
To view a tooltip with details about a feature, hover over it with the mouse. Or select one or more features by clicking on them. You can then view information about them in the Details panel.

The same default color scheme is used for features in both MegAlign Pro and GenVision Pro.

<table>
<thead>
<tr>
<th>Feature Type</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>gene</td>
<td>green</td>
</tr>
<tr>
<td>CDS</td>
<td>blue</td>
</tr>
<tr>
<td>RNA</td>
<td>orange</td>
</tr>
<tr>
<td>repeat</td>
<td>yellow</td>
</tr>
<tr>
<td>transcription</td>
<td>red-purple</td>
</tr>
<tr>
<td>all others</td>
<td>orange-red</td>
</tr>
</tbody>
</table>

To change Features options:

To learn how to access the options section for this track, see Tracks.
Specify the number of feature rows to display by typing a number in the **Rows** box or by using the up/down arrows. If features are overlapping, this indicates a need to increase the number of rows.

The example below shows three rows of features. The semi-opaque scrollbar to the right allows you to scroll up/down to see additional features.

You can also add white space above and/or below features tracks using sliders in the **Layout section**.

Click ![reset button] if you wish to return to the default values.
Consensus track

To display the consensus:

After any type of alignment, a consensus sequence is automatically displayed in the Sequences view header. To display or hide this consensus sequence, check or uncheck the Consensus box in the Tracks panel. This box is only visible after performing an alignment.

Consensus characters in upper case denote that the called character comprises > 50% of the total count for the column. This therefore disqualifies any character that shares the same frequency with another character.

To change Consensus options:

Currently, the Consensus track does not have editable options.
Consensus Match track

To display the Consensus Match:

To display or hide the Consensus Match track in the Sequences view footer, perform an alignment and then check or uncheck the Consensus Match box in the Tracks panel. This box is only visible after performing an alignment.

How Consensus Match is calculated:

The Consensus Match histogram is calculated by dividing the total score for the called consensus character by the number of sequences at the position. As agreement increases, the bar height increases and appears in a lighter shade of green. The histogram is not calculated for positions where there are consensus gaps. Hover over any bar in the histogram to display an information balloon showing the consensus match percentage, as demonstrated in the image below.

The following procedure is used to calculate the consensus sequence and the match percent for a given histogram column:

1. **Score the characters in the column** - Each occurrence of a non-ambiguous character in the column is scored as “1” for that character. If the character is an ambiguity code, a fractional count is added to each of the relevant characters. For example, in a nucleotide sequence, the character R would add “1/2” to the counts for A and G. Likewise, B would add “1/3” to the counts for C, G, and T.

2. **Use the counts to determine the consensus character** - If there is a single un-ambiguous character that is the most frequent, the consensus is called for that character. If there are two or more characters whose scores are tied for the maximum, the consensus is called as “X” or “n,” for proteins or nucleic acids, respectively. If there is a two-way tie, and one of the characters is a gap, the non-gap character will be called.

3. **Determine the case of the consensus character** - If the count for the called character is > 50% of the
total count for the column, upper case is used. Otherwise, lower case is used.

4. Calculate the consensus match for the histogram: The histogram calculation uses the “maximum count” value, which will either be the count of the single predominant character (the unambiguous consensus) or will be the “tied” value that led to the calling of an ambiguity code. The final consensus match is the total score for the called character divided by the number of sequences at the position.

Examples:

<table>
<thead>
<tr>
<th>Characters in the DNA alignment column</th>
<th>Consensus call</th>
<th>Consensus match calculation</th>
<th>Histogram bar size (as % of total available height)</th>
</tr>
</thead>
<tbody>
<tr>
<td>A C G Y</td>
<td>c</td>
<td>1.5/4</td>
<td>38%</td>
</tr>
<tr>
<td>A A C C G T</td>
<td>n</td>
<td>2/6</td>
<td>33%</td>
</tr>
</tbody>
</table>

To change Consensus Match options:

To learn how to access the options section for this track, see Tracks.

- By default, the Consensus Match histogram is shown in tones of green. To choose another color, click on the color box to the right of Color.

Click 🔄 if you wish to return to the default values.
Sequence Logo track

To display the Sequence Logo track:

To display or hide the Sequence Logo track in the Sequences view footer, perform an alignment and then check or uncheck the Sequence Logo box in the Tracks panel. This box is only visible after performing an alignment.

How Sequence Logo is calculated:

The Sequence Logo is a visualization of the nucleotide or amino acid at a given position, based on a formula for the Shannon uncertainty measure given by Schneider and Stephens (1990). The height ranges from 0-2 for nucleotides and 0-4.3 for proteins, and is proportional to the amount of information available for each character. Hover over the logo to reveal a tooltip with the information content of each letter at the position.

To change Sequence Logo options:

To learn how to access the options section for this track, see Tracks.

- The accuracy of this calculation is proportional to the number of sequences in the alignment, and the
track may not be displayed if there are too few sequences. We recommend checking **Small sample correction** when there are relatively few sequences without gaps represented at a given position. This correction has no affect when there are sufficient numbers of sequences to provide a good estimate of information content. Values will be zero if **Small sample correction** is used with fewer than four aligned amino acid sequences.

Click 🔄 if you wish to return to the default values.
GC Content track

To display the GC Content track:

GC Content is a graph track with a scale from 0-100 showing the proportional amount of G or C residues in a sliding window of user-defined width.

The visibility of GC Content tracks in the Sequences view is available only for nucleotide (DNA) sequences, and is dependent on:

- Whether or not tracks are visible in the Sequences view. To display tracks, click on the plus sign next to the sequence of interest.

- Whether or not the GC Content box is checked in the Tracks panel. This box is only visible for nucleotide sequences.

To change GC Content options:

To learn how to access the options section for this track, see Tracks.

- Calculations are performed in a sliding window. Type a number in the Window size box to specify the number of consecutive residues to use in the GC content calculation. The window size may be any integer from 1-5,000, and the default is 25 residues. The window shifts along sequences one position...
at a time, and will therefore overlap for widths greater than 1.

**Note:** the GC value at each residue is computed using a window centered over the residue in the ungapped sequence. An even window width causes the window to be slightly off-center. As the window approaches either end of the sequence, one side will stop moving, and the window will shrink.

- By default, GC Content is shown in tones of blue. To choose another color, click on the color box to the right of **Line color**.

Click 🔄 if you wish to return to the default values.
Gap Fraction track

To display the Gap Fraction track:

Gap Fraction is a graph track with a scale of 0-1 that shows the proportion of gapped positions in a sliding window centered on each position.

The availability of a Gap Fraction track in the Sequences view or Pairwise view is available only for aligned sequences, and is dependent on:

- Whether or not tracks are visible in the views. To display tracks, click on the plus sign next to the sequence of interest.

- Whether or not the Gap Fraction box is checked in the Tracks panel. This box is only visible after alignment has taken place.

To change Gap Fraction options:

To learn how to access the options section for this track, see Tracks.

- Calculations are performed in a sliding window. Type a number in the Window size box to specify the number of consecutive residues to use in the gap fraction calculation. The window size may be any integer from 1-50,000, and the default is 7 residues. The window shifts along sequences one position.
at a time, and will therefore overlap for widths greater than 1.

**Note:** The gap fraction value at each position is computed using a window centered over the position in the gapped sequence. An even window width causes the window to be slightly off-center. As the window approaches either end of the sequence, one side will stop moving, and the window will shrink.

- By default, the Gap Fraction graph is shown in gold. To choose another color, click on the color box to the right of **Line Color**.

Click 🔄 if you wish to return to the default values.
Numeric tracks

A numeric track displays a plot of values along one or more sequences in the project.

To display numeric tracks:

The visibility of numeric tracks in the Sequences view is dependent on:

- The origin of the project. For example, the Model ‘n’ Cα Distances track is only available only for the query sequence in a project sent to MegAlign Pro using NovaFold’s Send template alignment to MegAlign Pro link. It is not available for template sequences in those projects, nor for MegAlign Pro projects that do not originate from NovaFold.

- Whether or not tracks are visible in the Sequences view. To display tracks, click on the plus sign next to the sequence of interest.

- Whether or not corresponding box is checked in the Tracks panel.

When the track is visible, it consists of a graph. For example, the Model ‘n’ Cα Distances track is a graph with a y-axis from 0-16. It shows the predicted pairwise distances between Cα atoms in a predicted model and its theoretical ideal structure. These are calculated by NovaFold using a support vector machine trained to recognize patterns in template coverage, secondary structure, solvent accessibility, and simulated structural diversity. A separate track is available for each model. Models tend to be more accurate in regions with lower distance values.

To change numeric track options:

To learn how to access the options section for this track, see Tracks.
Select from three different Graph types (Line, Skyline, Bar) by clicking on the corresponding icon.

By default, numeric graphs are displayed in green with a pale yellow background. To choose another graph color, click on the box to the right of Color to make a selection from a color chart. To choose another background color, click the color box to the right of the Background checkbox. To turn off the background color, uncheck the checkbox.

Use the first Gridlines dropdown menu to select which gridlines to display: Both (horizontal & vertical), Horizontal (only) or None. Use the second dropdown menu to choose whether gridlines should be visible above (Over graph) or below (Under graph) other parts of the graph.

Check the Smooth box if you wish to average the values over a specified number of residues. Smoothing is computed by averaging values in a sliding window of the specified number of residues. Enter the number of residues in the adjacent text box (maximum=5000). Inputting a high value will smooth the graph curves, while a low value will highlight local differences.

To change the range of values displayed, enter new y-axis endpoints in the Range text boxes. The default range may be too large or too small for some sections, causing the graph to appear empty or peaks to be cut off. You may need to raise or lower the second value, in particular, in order to see the graphical display clearly.

Check the Use logarithmic scale box and select an option from the corresponding drop-down menu if you want to use a logarithmic, rather than a linear scale. Options are log2 or log10.
Note: The log of 0 is not defined. Therefore, log values for the track are calculated as follows: For \( y > 0 \), \( y' = \log(y) \); otherwise, it is displayed as a 0.

Click 😄 if you wish to return to the default values.
Match Bar track

To display the Match Bar track:

The Match Bar track is used to show similarities and differences between the query and target sequences. This track is available in the Pairwise view only after performing a pairwise alignment.

The visibility of this track in the Pairwise view is dependent on:

• Whether or not tracks are visible in the Pairwise view. To display tracks, click on the plus sign next to the sequence of interest.

• Whether or not the Match Bar box is checked in the Tracks panel. This box is only visible after performing a pairwise alignment.

To learn how to access the options section for this track, see Tracks.

• Use the Show identity as drop-down menu to choose how to show the connection between the query and the target. Choosing Residues in target case or Residues in query case cause the connection to appear as a copy of the residue from the target or query sequence. Choosing Vertical bars causes the connection to appear as a symbol, depending on the match status.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Interpretation</th>
<th>Weight table value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical line</td>
<td>Match</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Favorable mismatch</td>
<td>(0,1)</td>
</tr>
<tr>
<td>------</td>
<td>-------------------</td>
<td>-------</td>
</tr>
<tr>
<td>Period</td>
<td>Neutral mismatch</td>
<td>0</td>
</tr>
<tr>
<td>Space</td>
<td>Unfavorable mismatch</td>
<td>&lt; 0</td>
</tr>
</tbody>
</table>

• To add a background color behind each residue, check the **Color background** check box and use the adjacent drop-down menu to choose between **Same as query** and **Same as target**.

**Note:** These options are mirrored in the **Pairwise alignment section** of the **Style panel**. Choices made in either location are instantly reflected in the other location.

Click 🔄 if you wish to return to the default values.
Translation track

To display the Translation track:

Translation tracks in the Sequences view are available only for nucleotide (DNA) sequences, and are dependent on:

• Whether or not tracks are visible in the Sequences view. To display tracks, click on the plus sign next to the sequence of interest.

• Whether or not the Translation box is checked in the Tracks panel. This box is only visible for nucleotide sequences.

Translation track conventions:

• Stop codons are represented by dots.

• For purposes of translation, alignments are assumed to be linear.

• Translations are not displayed for incomplete codons at the right end of the block.

• Translation frames 4-6 are counted from the right end (the 3’ end of the bottom strand).

• In multi-block Mauve alignments, translation is not done across the boundaries of blocks.

To change Translation options:

To learn how to access the options section for this track, see Tracks.
• Use the upper drop-down menu to choose from a variety of NCBI and Lasergene translation codes.

• Put checkmarks next to the reading frames you wish to display, and remove checkmarks from those you do not wish to display. Click All Reading Frames to show or hide all reading frames. Click Top Strand or Bottom Strand to show or hide all the reading frames on that strand.

• Use the left-hand drop-down menu to choose between One-letter or Three-letter amino acid abbreviations.

• Use the right-hand drop-down menu to choose between Uppercase and Lowercase letters.

Click 🔄 if you wish to return to the default values.
Features

MegAlign Pro provides a wizard for copying features from one sequence to another, a procedure known as “feature mapping.” To learn more about how to map features or remove existing features, see:

- Map features
  - Features, Options and Output wizard screens
- Files output after mapping features
- Mapping features in MegAlign Pro vs. SeqNinja
- Remove features
Map features (copy features to another sequence)

MegAlign Pro’s feature mapping lets you map a single annotation or all annotations from a source sequence to a target sequence. The sequences involved must have been previously aligned. During the process, you may optionally filter annotations so as to include/exclude specific gene types. Feature mapping is most commonly used to map desired annotations from a “completely annotated” sequence to a closely-related but “incompletely annotated” one.

The following video provides a short overview on feature mapping:

To map features from one or more source sequences to a target sequence:

1. In Column 1 of the table below, locate the row that describes the target sequence—the sequence that will be “receiving” features from one or more other sequences.

2. As directed in Column 2, select one or more features or one or more sequences that will act as the source(s) for the features.

   • To select an individual feature, open the tracks for the sequence and click on the feature. To select two or more features, select them using Ctrl+click (Win) or Cmd+click (Mac).
• To select one or more sequences from the Overview or Sequences View, use click, **Shift+click**, **Ctrl+click** (Win), or **Cmd+click** (Mac).

3. As directed in Column 3, use the specified **Features** menu command, or the corresponding “right-click” context menu command.

<table>
<thead>
<tr>
<th>Column 1: Target sequence</th>
<th>Column 2: Sequence or feature selection</th>
<th>Column 3: Command name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active consensus</td>
<td>One or more features; or one or more source sequences. Note that feature segments falling entirely within a gap will not be copied.</td>
<td><strong>Features &gt; Map (Selected) Feature(s) to Active Consensus</strong></td>
</tr>
<tr>
<td>Sequence in the top row of the view</td>
<td>A single feature; or one or more source sequences, none of which may be the sequence in the top row of the view.</td>
<td><strong>Features &gt;) Map (Selected) Feature(s) to Top Sequence</strong></td>
</tr>
<tr>
<td>Sequence that is higher on the list than the source sequences</td>
<td>One or more features; or the target sequence and one or more source sequences.</td>
<td><strong>Features &gt; Map (Selected) Feature(s) to Top Selected Sequence</strong></td>
</tr>
<tr>
<td>Sequence that is lower on the list than the source sequences</td>
<td>One or more features; or the target sequence and one or more source sequences.</td>
<td><strong>Features &gt; Map (Selected) Feature(s) to Bottom Selected Sequence</strong></td>
</tr>
<tr>
<td>Sequence in the bottom row of the view</td>
<td>One or more features; or one or more source sequences, none of which may be the sequence in the bottom row of the view.</td>
<td><strong>Features &gt; Map (Selected) Feature(s) to Bottom Sequence</strong></td>
</tr>
</tbody>
</table>

4. If more than two sequences are selected, the following popup will appear. Select **Yes** to launch the Map Features dialog and map all features from the specified source sequences to the target sequence; or **No** to abort feature mapping.

If you initiate feature-mapping for one or more individual features, MegAlign Pro maps the specific feature(s) you requested without further input.
When mapping a single feature, or mapping to the consensus, mapping happens automatically, without launching a wizard. If you initiate feature-mapping in other situations, a wizard may appear. This Map Features wizard has three screens—Features, Options and Output described in a separate topic. To navigate between the three wizard screens, either use the Back or Next buttons or click on the screen name in the left panel of the wizard.

Things to note when mapping features:

- It is possible to map multiple copies of features to any sequence, including the consensus. For example, if you first map a single feature to the consensus, then later map all features from the same source sequence, the first feature that was added will appear twice on the consensus. Be aware of this, in case you wish to avoid adding multiple copies of the same feature.

- When mapping features to the consensus in Mauve multi-block alignments, only features within the active block are mapped. When mapping features to a sequence, features in all the blocks are mapped.

- The project directory will be organized into sub-directories when 1) there are multiple source sequences, or 2) any of the source sequences are multiple end-to-end sequences, or 3) the target includes multiple end-to-end sequences.
Features screen

The Features screen is the first wizard screen of the Map Features dialog, and allows you to choose the features you want to include or exclude in the mapping.

• Use the upper drop-down menu to elect to map All features, Features matching those you will specify in the subsequent row(s) of the dialog, or Features except those specified in the subsequent row(s).

• Use the lower drop-down menu to select the feature type to match (or not match), e.g., gene, CDS, exon, intron, mRNA, tRNA, promoter, misc_binding, etc. To specify more than one feature type, use the plus (+) button to add additional “Features” rows. If you want to further limit the search to features matching (or not matching) particular qualifiers, check the Filter box, then choose a qualifier (gene, /product, /locus_tag, /note or /db_xref) from the drop-down menu to its right. In the rightmost textbox, enter the text that the qualifier must match or not match (e.g., /gene = thrL) in order for the feature to be removed in the output file. You may use wildcards in this box if you wish (e.g., /gene = thr*).
The image below shows an example of how the screen might look after specifying the desired options:

Click **Next** to move to the **Options screen**.
Options screen

The Options screen is the second wizard screen of the Map Features dialog, and lets you specify mapping options.

- Mapping – Use the text boxes or sliders to specify percent cutoffs for:

  - **Minimum feature coverage**, where:

    \[
    \text{feature coverage} = \frac{\text{portion of feature contained within the aligned interval}}{\text{feature length}} \times 100\%
    \]
• **Minimum sequence identity**, where:

\[
\text{sequence identity} = \frac{\text{number of identical aligned residues}}{\text{length of feature in gapped alignment space}} \times 100\%
\]

In this calculation, non-common gaps are counted in both source and target sequences.

Feature coverage is less sensitive to insertions and substitutions than is sequence identity. The default for both Mapping items is 80%.

• Translation – The genetic code specified in this dialog is used for translation, as well as for describing the type of sequence change in the Map Features Report file (see next bullet point). By default, MegAlign Pro translates using the genetic code identified in the source data (e.g., the GenBank /transl_table qualifier), if available; otherwise, it uses the standard genetic code (NCBI:1). To specify a different code, check **Override genetic code** and make a selection from the corresponding drop-down menu. This option does not appear for protein alignments.

• Feature Report – After running the Map Features program, the output is sent to the Map Features Report file. To add a column to that report containing a SeqNinja expression describing the bases in the mapped feature in terms of the source and target sequences, check the box next to **Include specific sequence changes**.

• Unmapped Interval Report – To make a report listing regions that may need further annotation, check the box next to **Generate report of intervals without mapped features**. Then use the text box **Minimum length of interval to report** to specify a minimum length for a stretch of sequence where features were not mapped.

Click **Next** to proceed to the **Output screen**.
Output screen

The Output screen is the third wizard screen of the Map Features dialog, and lets you specify where to store reports and logs related to feature mapping.

- In the Save project in box, specify the directory that will contain the project directory. To use a different directory than the one listed, use the Browse button.

- In the Project name box, type in a name for the project.

The project directory will be created in the specified folder, with the specified name. The project directory cannot be an existing directory. Therefore, if you decide to repeat the mapping using different options, you will need to change the project directory before re-running.

Press OK to start feature mapping, or Cancel to leave the dialog. To learn about files output after feature mapping, click here.
# Output files

After running the Map Features step, the output consists of several files.

<table>
<thead>
<tr>
<th>File Name</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>PROJECT_map_features_console.txt</code></td>
<td>Copy of the text that appeared for this mapping in the Console side panel in the MegAlign Pro user interface.</td>
</tr>
<tr>
<td><code>PROJECT_map_features_report.tsv</code></td>
<td>See the text and table below this one for more information.</td>
</tr>
<tr>
<td><code>PROJECT_map_features_unmapped.tsv</code></td>
<td>Report of intervals in the target sequence to which no features were mapped. Generated only if requested in the Map Features Options screen under Unmapped Interval Report.</td>
</tr>
</tbody>
</table>

The `report.tsv` file is a tab-separated report file that can be opened in [Notepad++] (freeware) or any spreadsheet utility. This report file contains a row for each feature that you directed MegAlign Pro to map. The “Variation” column summarizes the most significant variation of the mapped feature against the source feature:

<table>
<thead>
<tr>
<th>Category</th>
<th>Label in report</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>Not mapped</td>
<td>Not_mapped</td>
<td>Can occur when the feature doesn’t map at all, or when the feature maps, but not well enough to pass the mapping thresholds.</td>
</tr>
<tr>
<td>Indels</td>
<td>Deleted_end_5prime</td>
<td>[Non-protein sequences] First residue and/or last residue cannot be mapped with the current settings, or one/both align with a target gap.</td>
</tr>
<tr>
<td></td>
<td>Deleted_end_3prime</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Deleted_end</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Deleted_ends</td>
<td></td>
</tr>
<tr>
<td>Indel</td>
<td></td>
<td>Both insertions and deletions have occurred.</td>
</tr>
<tr>
<td>Insertion</td>
<td></td>
<td>An insertion has occurred.</td>
</tr>
<tr>
<td>Deletion</td>
<td></td>
<td>A deletion has occurred.</td>
</tr>
<tr>
<td>Substitutions</td>
<td>No_start</td>
<td>[CDS only] The initial codon in the mapped feature is not a start codon.</td>
</tr>
<tr>
<td></td>
<td>Nonsense</td>
<td>[CDS only] A substitution has resulted in an interior stop codon.</td>
</tr>
<tr>
<td></td>
<td>No_stop</td>
<td>[CDS only] The last codon in the mapped feature is not a stop codon.</td>
</tr>
<tr>
<td></td>
<td>Non-synonymous</td>
<td>[CDS only] Non-synonymous substitution occurred.</td>
</tr>
<tr>
<td></td>
<td>Synonymous</td>
<td>[CDS only] Synonymous substitution occurred.</td>
</tr>
<tr>
<td></td>
<td>Substitution</td>
<td>[Non-CDS] A substitution has occurred.</td>
</tr>
<tr>
<td>No change</td>
<td>Identical</td>
<td></td>
</tr>
</tbody>
</table>
Note: If more than one item in the above table applies, the topmost item is reported.
Mapping features in MegAlign Pro vs. SeqNinja

The ability to map features exists in both MegAlign Pro and DNASTAR’s SeqNinja. Here are some reasons you might want to map features in one application versus the other:

<table>
<thead>
<tr>
<th>Task</th>
<th>Use MegAlign Pro</th>
<th>Use SeqNinja</th>
</tr>
</thead>
<tbody>
<tr>
<td>View the alignment and the mapped features</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Configure alignment options</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Map features in an end-to-end alignment. For instance, to perform a Mauve alignment of end-to-end chromosomes with some rearrangement.</td>
<td>x</td>
<td></td>
</tr>
<tr>
<td>Map VCF features from a .vcf file.</td>
<td></td>
<td>x</td>
</tr>
<tr>
<td>Map features into a table, then edit the table before generating the resulting sequence or feature file</td>
<td></td>
<td>x</td>
</tr>
</tbody>
</table>
Remove features

While features can only be mapped when all sequences involved have been aligned, features can be
removed from a sequence before or after aligning. Feature removal is not reversible, so use caution when
removing features, especially those from non-consensus sequences.

To remove individual features from a sequence or from the consensus:

Click the plus sign to the left of consensus or sequence to reveal the associated Features track. Select one
or more features to remove using Ctrl+click (Win) or Cmd+click (Mac), then right-click on the selection and
choose Remove Selected Feature(s) from the context menu, or Features > Remove Selected Feature(s)
or Edit > Delete from the main menu. You will be asked to confirm feature deletion.

To remove all features from one or more selected sequences:

Select one or more sequences using Ctrl+click (Win) or Cmd+click (Mac), then right-click on the selection
and choose Features > Remove Features from Selected Sequence(s) from the context menu.

To remove all features from the consensus:

Select the consensus and choose Features > Remove Features from Active Consensus; or right-click on
the consensus sequence and choose the same command from the context menu.
Try it! – Map features

Both MegAlign Pro and SeqNinja allow you to copy a single annotation, or all annotations from a source sequence to a target sequence. During the process, you may optionally filter features so as to include or exclude specific gene types.

In this tutorial, you will experiment with feature mapping using two closely-related Drosophila simulans sequences: a "source" sequence (.gbk) that contains features and a “target” sequence (.fas) that lacks features.

Begin with Part A: Add, rename and align sequences.
Part A: Add, rename and align sequences

Before mapping features in MegAlign Pro, you first need to add and align the sequences.

1. If you have not yet download and extracted the tutorial data, click here to download it. Then decompress (unzip) the file archive using the method of your choice.

2. If a MegAlign Pro project is already open, choose File > New Alignment Project. Otherwise, launch MegAlign Pro.

3. Choose File > Add Sequences, or click on the Add sequences to project tool ( + ).

4. Navigate to and open the demo data folder Lasergene 'x' Data\Demo MegAlign Pro\Drosophila project, where ‘x’ denotes the Lasergene version. This folder contains two similar sequences for Drosophila simulans chromosome X.

5. Use Ctrl+A (Win) or Cmd+A (Mac) to both sequences and click Open.

6. To rename the first sequence, right-click on the sequence name in the Sequences view or Overview and select Rename. Type in the new Label (see table below) and press OK. Do the same for the second sequence.

<table>
<thead>
<tr>
<th>Type</th>
<th>Original sequence label</th>
<th>New label</th>
</tr>
</thead>
<tbody>
<tr>
<td>Feature source sequence (.gbk)</td>
<td>CM002914</td>
<td>D. simulans PRJNA170244 chrX</td>
</tr>
<tr>
<td>Target sequence (.fas)</td>
<td>gi</td>
<td>62998559</td>
</tr>
</tbody>
</table>

7. If sequences are not already ordered as in the image below, drag one above the other so they are.

8. To align sequences with Mauve using the default parameters, choose Align > Align Using Mauve or click the Align tool arrow ( ▼ ) and choose Align Using Mauve.
9. Use **File > Save** to save the project with the name *Drosophila project.msa*.

Proceed to [Part B: Map a single feature](#).
Part B: Map a single feature

In this part of the tutorial, you will map a single selected feature from the source sequence to the target sequence. In order to choose the appropriate mapping command, you will need to know where the source and target sequences appear in relation to one another in the list on the left of the views. If you followed the steps in Part A, the source sequence should be at the top of the two-member list.

1. To verify this, open the tracks panels by clicking both gray plus signs (⊕) in the Overview or Sequences view. If you followed the steps in Part A, the upper sequence should contain features and the lower sequence should not.

2. In the Overview, double-click on any block to make it the focus block.

   In the Sequences view, note that the letters (or bars, if zoomed out) with highly-colored backgrounds denote the active block selected in the previous step. Letters or bars with dull-colored backgrounds indicate an adjacent, non-focus block. Colored arrows represent features.
3. Keeping within the active block section, right-click on any feature and choose **Map Selected Feature to Bottom Sequence**. Observe that the feature is copied to the corresponding location in the lower sequence. Repeat this with other features, if desired. If you don’t see any features, go back to Step 2 and double-click on a different block to make it active.

4. To prepare for the next part of the tutorial, remove the feature(s) you just added to the target sequence by right-clicking on the lower sequence name and choosing **Features > Remove Features From Selected Sequence**. When prompted, click **Yes**. Observe that the target sequence has returned to its original state.

Proceed to **Part C: Map all features**.
Part C: Map all features

In this part of the tutorial, you will map all features from the source sequence to the target sequence.

1. Right-click on the name of the source (upper) sequence and select Features > Map Features to Bottom Sequence. The Map Features wizard launches.

2. In the Features screen, use the drop-down menu to select All Features, then press Next.

3. In the Options screen, keep the defaults and press Next.

4. In the Output screen, type in the Project name “All features” and use the Browse button to specify where save the project.

5. Click OK to initiate feature mapping. When mapping is finished, click OK and Close. The output sequence will be examined later in this tutorial.

6. To prepare for the next part of the tutorial, remove the features you just added to the target sequence by right-clicking on the lower sequence name and choosing Features > Remove Features From Selected Sequence. When prompted, click Yes.

Proceed to Part D: Map a filtered set of features.
Part D: Map a filtered set of features

In this example, you will map only CDS features which have a note containing the letters RB.

1. Right-click on the name of the source (upper) sequence and select **Features > Map Features to Bottom Sequence**. The Map Features wizard launches.

2. In the **Features screen**, select the features you want to include or exclude in the mapping:
   
   a. From the upper drop-down menu, choose **Features matching**.
   
   b. From the menu just below that, select **CDS**.
   
   c. To restrict mapping to features that have a note containing the letters “RB”, check the **Filter** box and select `/note` from the drop-down menu to its right. In the text box, type in `*RB*`. The asterisk wildcards are used so that any text string containing RB will be included.
   
   d. Click **Next**.

3. In the **Options screen**, the **Mapping** sliders and corresponding text boxes are used to specify the feature coverage and sequence identity thresholds that are required to map a feature. Change both items to **90%** to make mapping extra stringent. Leave other items at their default settings and click **Next**.
4. In the Output screen, type in the Project name "CDS-RB features" and save the project in the same location as the other output file.

5. Click OK to initiate feature mapping.

Proceed to Part E: Compare output files.
Part E: Compare output files

1. When the mapping initiated in Part D is finished, click the hyperlink to the output directory.

2. Open both All features_map_features_1_report.tsv and CDS-RB features_map_features_1_report.tsv in any suitable spreadsheet editor.

3. Observe that the output file All features has many more data rows than the file CDS-RB features. That’s because in the latter case, non-CDS features and features without a note containing the letters “RB” were omitted from feature mapping.

4. Of the remaining rows, look in the Variation column and see that some features were mapped and others weren’t. This assignment was based on the %Coverage and %Identity thresholds.

5. In each spreadsheet, find rows in which the Coverage and %Identity columns are between 80 and 90%. In which mapping project were these features mapped, and in which were they “Not_mapped”?

6. When you are finished, close both spreadsheets and return to the MegAlign Pro window.

7. Once in MegAlign Pro, click OK and then Close to close the Map Features-related dialogs.

Proceed to Part F: Export the annotated target sequence.
Part F: Export the annotated target sequence

1. In MegAlign Pro, hover over any target sequence annotation to read the entry. Verify that the sample entry matches your search criteria by checking the following:

   - Is the feature a CDS?
   - Does its original note contain the letters “RB”?

   Also observe that a new note has been added about the mapping you just performed, including the accession number of the source sequence and Coverage and Identity statistics.

To export the newly-annotated target sequence, select it and choose **File > Export Data > Sequences**. To preserve the annotations, select a format that supports them (e.g., .gbk, .meg).

2. Open the exported file in a text editor and observe that the notes about feature mapping have been preserved.

   This is the end of the Map Features tutorial.
Search Within an Open Project

To go to a specified position:

Choose **Edit > Go To (Pairwise) Position**, use **Ctrl/Cmd+J**.

- If the project contains only aligned or only unaligned sequences, type in a number and click **OK**.

![Go to Sequence Position](image)

- If the project contains a mixture of aligned and unaligned sequences, type in a number and use the drop-down menu to choose whether to go to the position in the aligned or unaligned sequences. Then click **OK**.

![Go to Sequence Position](image)

**To see a specific range in the Sequences view:**

In the **Overview**, double-click on an alignment block to make it active. In the case of a multi-block sequence, double-click on the block again to move the cursor to the selected position. This centers the viewport on the left edge of the block and moves the visible range in the **Sequences view** to the same area. Using the **zoom sliders** in the Sequences view controls the width of the viewport, and thus, the amount of visible sequence.
Make a Selection

Depending on the view, you can select one or more sequences, any portion of a sequence, or a specific portion of sequence corresponding to a feature. The active selection is highlighted in light blue. The selection can then be copied to the clipboard, copied in a specific format, exported to a file, exported to MegAlign, or realigned using different parameters and/or alignment method. This functionality is useful for sending a selected sequence or region of sequence to a new alignment project as an unaligned sequence. In this way, you can create a new document using a subset of the sequences in the current document, thereby avoiding having to find all of the input files. You can also use the selected region of one or more sequences to create a new document.

<table>
<thead>
<tr>
<th>To select...</th>
<th>Do this...</th>
</tr>
</thead>
</table>
| All sequences | Click on the name of any sequence, then use Ctrl/Cmd+A or Edit > Select All.  
- In a Mauve alignment, this command extends the selection across the entire active block.  
- If a portion of sequence or alignment was originally selected, the entire sequence or alignment will be selected.  
- In the Distance view, this command selects the entire distance matrix.  
- If a subsequence was selected in one or all aligned sequences prior to using this command, this action will extend the subsequence selection to the full sequences. |
| Multiple sequences | Use Ctrl/Cmd+click or Shift+click to select multiple sequences. |
| One entire sequence | Either:  
- Click on the sequence name.  
- Drag the mouse across all residues in a sequence track while holding down the left mouse button.  
- Double-click on a feature that spans the entire sequence. |
<p>| A portion of all aligned | Drag the mouse across residues in the consensus sequence while holding |</p>
<table>
<thead>
<tr>
<th>Sequences</th>
<th>Down the left mouse button.</th>
</tr>
</thead>
<tbody>
<tr>
<td>A portion of one sequence</td>
<td>Drag the mouse across residues in a sequence track while holding down the left mouse button.</td>
</tr>
<tr>
<td>The portion of a single sequence associated with a section of track (e.g. a Gap Fraction peak, etc.)</td>
<td>Drag the mouse across the open track while holding down the left mouse button.</td>
</tr>
<tr>
<td>One or more tracks</td>
<td>Click on a track to select it. To add additional tracks to the selection, use Ctrl/Cmd+click or Shift+click.</td>
</tr>
<tr>
<td>One or more features and corresponding sequence</td>
<td>Click on a feature to select it. To add additional features to the selection, use Ctrl/Cmd+click.</td>
</tr>
</tbody>
</table>
| The portion of a single sequence associated with a selected feature | To expand a selection consisting of one or more features to a selection containing just the sequence corresponding to the feature(s), either:  
  - Choose Edit > Select Subsequence or use the context (right-click) option of the same name.  
  - Double-click on the feature under that sequence. |
| The portion of all aligned sequences associated with a feature | To expand a selection consisting of one or more features or subsequence within a single sequence, to the corresponding subsequences across all aligned sequences or subsequences, either:  
  - Choose Edit > Select Subsequences Across Alignment.  
  - Triple-click on the feature under any of the sequences in the alignment. |
| Additional continuous items, when the first endpoint has been selected | Use Ctrl/Cmd+Shift and click on the other endpoint. |
| The current selection, but expanded to encompass additional bases | You can extend the length of an existing selection by Shift+clicking on the new endpoint. The selection will expand to use the chosen base as the new endpoint. If there are multiple selected ranges, the one closed to the chosen base will be expanded. |

To toggle selection of items on or off, hold down the Ctrl/Cmd key while dragging the mouse, or while clicking on the items to toggle on or off.
Choose the Alignment Type

Which is better, multiple or pairwise alignment?

This question is difficult to answer because it very much depends on how the alignment is going to be used.

Mechanistically, the best sequence alignment is the one that produces the fewest number of mismatches. That metric can be misleading, especially if minimizing the score entails extreme amounts of gapping. Consider an example where the goal is to identify some particular conserved domains or a large insertion. Here the placement of gaps outside of the regions of interest may well be of limited concern. Note that with MegAlign Pro, you can select the interesting regions identified by a multiple alignment and copy them as subsequences to a new document for further analysis.

Now consider a situation where a multiple sequence alignment is used to represent the actual relatedness of a group of sequences. Here the alignment is essentially a model, typically of an evolutionary process. In this case the “best” alignment is the one that is most plausible in the light some biological theory or model. One way that this visualized, of course, is to use the alignment to make an evolutionary tree.
When should I use a pairwise alignment?

The answer to this question may seem obvious: use pairwise alignment when you are only interested in two sequences. Also, sometimes pairwise alignment is simply more suitable than multiple alignment. Additionally, there are situations where a multiple sequence alignment (MSA) might help identify pairs for sequences or sub-sequences that are worth a more detailed, pairwise comparison.

Beyond workflow considerations, there are some fundamental differences between the two categories of alignment that might make pairwise alignment a better option for some sequence comparisons. Due to the nature of progressive multiple aligners (including Clustal, MUSCLE and MAFFT), the final sequence alignment can contain inappropriately placed gaps, which adversely affect the interpretation of the results. To understand this, consider how progressive multiple alignments work. The process invariably begins with a single pairwise alignment, adding gaps as necessary in order to minimize the number of mismatches. As the aligner proceeds, additional gaps are added as single sequences and groups of sequences aligned during an earlier stage of the process are included in the growing multiple sequence alignment. During this phase, gaps may be added but are never removed.

This “once a gap, always a gap” approach is a potential drawback that is shared by all progressive multiple alignment algorithms. The heart of the problem is that gap placement (and therefore the alignment) might be affected by the order in which sequences are aligned to each other because sequences added later in the process might be incorrectly aligned. All of the multiple alignment engines used by MegAlign Pro use a “guide tree” based on pairwise similarities of sequences to determine the order in which to align sequences. The first pair chosen consists of the two that are least distant on the guide tree. If the nearest neighbor to this pair is more distant than some other pair are to each other, that pair gets aligned to each other. If not, the neighbor is aligned with the first pair and gaps are added as necessary. In later rounds there may be no singleton sequences left, just clusters of two or more sequences that got aligned. Imagine a case where one of a group of early aligned sequences should have been added later, or where a close relative was added too late. It’s hard to know when this has happened unless you have some a priori information, such as knowledge of the evolutionary relationship of your group of sequences.

The bottom line is that when you examine just a pair from a multiple sequence alignment you may not see the same results as a pairwise alignment of just the two. So the direct approach under these circumstances might give a better picture of the relatedness of the pair.
Perform a Multiple Alignment

Did you arrive here by selecting the DNASTAR Navigator workflow Molecular Biology > Multiple sequence alignment? If so, you’re in the right place!

Protean 3D supports the following multiple alignment methods: Clustal Omega, Clustal W, MAFFT, MUSCLE and Mauve. Click here for descriptions and a comparison of the different methods.

To learn how to perform, modify, and troubleshoot multiple alignments, see the following topics:

- Perform an initial multiple alignment
- Multiple alignment methods and options
- Modify a multiple alignment
- Unalign aligned sequences

Multiple alignment tutorials:

The following tutorials all use free data that can be downloaded from the DNASTAR website.

- Try it! – Perform a Clustal Omega alignment
- Try it! – Perform a MUSCLE alignment with multi-segment sequences
- Try it! – Perform a genomic alignment with Mauve

The following video is a quick introduction to performing multiple alignments in MegAlign Pro:
Perform an initial multiple alignment

To perform the initial multiple sequence alignment:

1. **Select** two or more sequences to align. All sequences must belong to the same category (DNA/RNA or protein). Selected sequences can include any combination of already-aligned sequences and sequences in the “Unaligned Sequences” area. Both types are visible in the Overview (see image) and Sequences view.

2. Hover the mouse over the **Align/Realign** tool ( ) to view a tool tip showing the currently-selected algorithm.

3. Choose the desired **multiple alignment method** and perform the alignment.

   - If the method and options are compatible with the current sequence type, and you want to use it, press the **Align/Realign** tool. In general, we recommend using Mauve for genome scale alignments and the other alignment methods for gene-level alignments. Since Mauve works by initially breaking alignment projects into a series of smaller sub-alignments, we also suggest using Mauve if there is insufficient memory to align sequences with the other methods, or if another type of alignment is taking an excessive amount of time to complete.
• To choose a different method, click on the small black arrow to the right of the Align tool to choose from available methods. Or use the main menu to choose Align > Align Using (Method Name). If the sequences have already been aligned, note that the menu command names change to Align > Realign Using (Method Name).

• To choose a different method and/or change method options before aligning sequences, click on the small black arrow to the right of the Align tool and choose Align with Options; or select Align > Align with Options from the main menu. For a detailed description of the Alignment Options dialog for different methods, see Clustal Omega, Clustal W, MAFFT, MUSCLE or Mauve alignment options.

Except in the case of divergent sequences (see note, below), we recommend using the DNASTAR default settings the first time you perform a multiple sequence alignment. Later, you may wish modify some of the Alignment Options before realigning the sequences. After you customize options in the Alignment Options dialog and perform an alignment using the new settings, they become the new defaults, but only for this project, and only as long as the project remains open. For subsequent alignments in the same project, you can use the Align tool ( ) to perform the alignment using your custom settings.

4. (optional) During the alignment, MegAlign Pro displays a progress window. If you need to interrupt the alignment, click Cancel. To view a console window showing the start time and progress of the alignment, click Show Console.

• If an alignment fails, you will receive a message with recommendations on how to obtain a successful alignment (e.g., by modifying options or choosing a different alignment method). See Troubleshoot multiple alignments.

• If an alignment finishes successfully, a table of pairwise distances and a phylogenetic tree are created and displayed in the Distance view and Tree view, respectively. If the Console is not already open, and you wish to view alignment statistics and other information there, select View > Console. To reset the sequences to the unaligned state (i.e., as if they were just added to MegAlign Pro), use Align > Unalign All.
Notes regarding multiple alignments

When performing a multiple alignment, take the following tips into consideration.

Sequence order matters:

The order in which sequences appear in the Overview and Sequences view may affect the results of the multiple sequence alignment. If you are not satisfied with an alignment, try reordering sequences and running the alignment again.

Divergent sequences

The MUSCLE multiple alignment algorithm assumes that the sequences to be aligned have a certain degree of relatedness. Groups of relatively divergent sequences, especially those with very large data sets, may require considerably more computer resources, particularly RAM. When working with these types of data, we recommend using Align > Align with Options and changing Maximum iterations to 1 or 2. This will both reduce the amount of memory needed, and ensure that the sequences are sufficiently related to allow for the alignment process to be successful.

Additional alignment methods:

Two additional multiple alignment methods are available in DNASTAR’s MegAlign application: Jotun Hein and Clustal V. Please open the classic MegAlign application and select Help > Contents for more information on these methods.

High-throughput sequencing reads:

We caution against attempting a multiple alignment in MegAlign Pro using high-throughput sequencing reads. Analysis of these reads should instead be handled through DNASTAR’s SeqMan NGen and ArrayStar applications.

Known issues with Mauve:
• An issue in Mauve can cause an alignment to stall if sequences are ordered one way, but not another. If this issue occurs, you may see up to three error messages after beginning a Mauve alignment: “progressiveMauve-[OS].exe has stopped working,” “Do you want to send more information about the problem?,” and “Unexpected error while running the alignment.” The last message provides a Details button which reveals the text: “Mauve quit unexpectedly. Reported error: Unrecognized file format.” In addition, a progress bar will open, but the alignment will not finish. To circumvent this issue, Cancel the alignment, drag the sequences into a different order in the Sequences View or Overview, and then try the alignment again.

• Sequences aligned with Mauve may give slightly different results on Windows and Macintosh. These differences originate with the Mauve algorithm and not with the implementation in MegAlign Pro.
Troubleshoot multiple alignments

Error message that sequences are the wrong type or are too long:

After beginning an alignment, an error message will appear if the sequences are not of the appropriate type or are too long for the selected algorithm. If performing a MUSCLE or Clustal Omega alignment, an error message usually indicates that the sequences are too long or that multi-segment sequence groups are ordered incorrectly. To remedy the situation, you can align using Mauve, or correctly re-enter any incorrect multi-segment sequences, or break up the sequences into shorter lengths. This last task can be performed very quickly and easily using DNASTAR SeqNinja.

Message that an unexpected error occurred:

During a multiple sequence alignment, you may receive the following warning:

To reveal more information, click on the Details button.
For additional details, select **View > Console** from the menu. An example **console** is shown below:

![Console screenshot](image.png)

Notice that in this console, the message “Fatal error, exception caught” appears near the bottom. Either that message or an “Out of memory” message are known to occur with particularly long, highly divergent sequences.
Before attempting the alignment again, we recommend using **Align > Align with Options** and checking the box next to **Use Brenner’s Alignment**. Checking the box causes MegAlign Pro to use Brenner’s method for the root alignment. This method uses less memory, and enables the alignment of long and divergent sequences, but with a concurrent loss in accuracy.
Multiple alignment methods and options

MegAlign Pro offers both gene-level and genome-level multiple alignment algorithms.

Gene-level alignment of either protein or nucleotide sequences:

In general, the three gene-level aligners have higher accuracy than the genome-level (Mauve) aligner. They offer editable options for speed, capacity, algorithm, etc., and are the only methods available for "profile" alignments. The disadvantages to gene-level aligners is that sequences must be on same strand, and that large rearrangements (e.g., inversions, translocations) are not allowed.

- **Clustal Omega** – Clustal Omega (Sievers F et al., 2011) was developed at University College Dublin, and is the most advanced version of Clustal. It can align hundreds of thousands of sequences in just a few hours. This method has few editable options, but has high, 64-bit capacity on both Windows and Macintosh.

- **Clustal W** – Clustal W aligns sequences using the method of Thompson et al. (1994). Clustal W was designed to create more accurate alignments than Clustal V when alignments include highly diverged sequences. However, Clustal W does not always handle end-gaps ideally. Also, note that true Clustal W performance is only achieved when you choose the default “Slow-Accurate” option rather than the “Fast-Approximate” option.

- **MAFFT** – MAFFT (Multiple Alignment Fast Fourier Transform; Katoh M & Kumar M, 2002) was developed by the Computational Biology Research Center and generously donated to the public domain. This method has many editable options, and provides a variety of algorithms for different scenarios and a choice of very slow to very fast speeds. It has 32-bit capacity on Windows, and 64-bit on Macintosh. See the CBRC’s MAFFT page for additional references.

- **MUSCLE** – The MUSCLE alignment algorithm was developed by Dr. Robert Edgar (Edgar RC, 2004 & 2004), who very kindly donated it to the public domain. It is one of the faster aligners, and has numerous selectable options. MUSCLE features iterative cycles that guide tree refinement and realignment. Like MAFFT, it has 32-bit capacity on Windows, and 64-bit on Macintosh.

Genome-level alignment of nucleotide sequences:

In comparison to the methods above, the genome-level aligner allows large rearrangements. However, it
only allows nucleotide sequences, and fine-scale gapping may not be as good as in gene-level aligners.

- **Mauve** was developed in the Genome Evolution Laboratory at the University of Wisconsin-Madison (Darling AE, Mau B, and Perna NT, 2010) and is licensed under a GNU General Public License. Mauve has high capacity and uses MUSCLE to create multiple alignments for each block that contains more than a single sequence. The Mauve algorithm is currently the only MegAlign Pro alignment method that is:

  - suitable for aligning very long sequences up to genome-length.
  - capable of producing an alignment when one or more of the sequences are rearranged relative to one another.
  - capable of producing a multi-block alignment (see [Overview](#)).
  - only available for nucleotide sequences.
Clustal Omega alignment options

The Clustal Omega algorithm is for gene level alignment of either protein or nucleotide sequences. To run a Clustal W alignment, select two or more sequences and choose Align > (Re)Align Using Clustal Omega.

If you wish to change method options, instead choose Align > Align with Options. The dialog is the same whether the sequences are protein or nucleotide.

Change settings as desired:

Note: Certain options in this dialog may initially be disabled. For example, some options are only enabled if there are ≥ 100 sequences in the project, while others are enabled only after options higher up in the dialog are checked. See below for further information.
• Use the **Align** drop-down menu to select sequences to align or realign.

• In the **Using** drop-down menu, choose **Clustal Omega**.

• To refine the alignment by specifying a threshold for iteration cycles, check the box next to **Iterate to refine alignment**. When this box is checked, two refinement options become available. You may enter values for neither, either, or both options.
  
  • Enter a value for **Maximum number of cycles of tree refinement** to specify a cutoff for the maximum number of iterations. The default is 1.

  • Enter a value for **Maximum number of cycles of refinement using alignment-based HMMs** to set a cutoff for the number of HMM iterations. MegAlign can often improve the placement of gaps by comparing the alignment to a Hidden Markov Model (HMM) of the alignment. The default is 1. The HMM is very slow, so be aware that entering a large number may cause a commensurate decrease in alignment speed.

In both cases, MegAlign Pro will recompute the pairwise distances, recalculate the guide-tree, and then realign the sequences while staying within the maximum cycle threshold.

• If your project contains \( \geq 100 \) sequences, three clustering options are available. All three options are disabled for projects containing fewer than 100 sequences.

  • To force clustering using a distance matrix based comparison, check **Use distance matrix instead of k-tuple based mbed method for initial alignment**.

  • To use mbed for the first iteration and a distance matrix for other iterations, check **Use mbed for first round and distance matrix for later iterations**.

  • If you check the second box, but not the first, you may optionally set a threshold for the cluster size during mbed iterations by checking **Restrict cluster size in mbed mode**. Once you have checked that box, you may elect to over-ride the default by entering a value for Maximum sequences per subcluster. The default is \(<\text{number of sequences to be aligned}> \times 1,\) up to a maximum value of 100.

The following table shows how the MegAlign Pro settings correspond with settings in **Clustal Omega** online.

<table>
<thead>
<tr>
<th>MegAlign Pro setting</th>
<th>Clustal Omega setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Iterate to refine alignments</td>
<td>Does not correspond with the command-line, but enables the two</td>
</tr>
</tbody>
</table>
Maximum number of cycles of tree refinement | max-guidetree-iterations=(integer) iterations=(integer)  
---|---  
Maximum number of cycles of refinement using alignment-based HMMs | max-hmm-iterations=(integer) iterations=(integer).  
  The value used for “iterations” is the maximum of the values specified for this option and the option in the preceding row.  
Use distance matrix instead of k-tuple (enabled) | full  
Use mbed for first round and distance matrix for later iterations (enabled) | full-iter  
Maximum sequences per subcluster | cluster-size=(integer)  

After making your changes:

- Choose **Align** to use the entered options to perform a multiple sequence alignment.
- Use the **Reset to Default** button if you would like to reset all values to the MegAlign Pro defaults.
- Select **Cancel** to leave the dialog without saving any changes or performing the alignment.
Clustal W alignment options

The Clustal W algorithm is for gene level alignment of either protein or nucleotide sequences. To run a Clustal W alignment, select two or more sequences and choose Align > (Re)Align Using Clustal W.

If you wish to change method options, instead choose Align > Align with Options. The dialog has slightly different options, depending whether the sequences are protein or nucleotide (nucleotide shown below).

Change settings as desired:
• Use the **Align** drop-down menu to select sequences to align or realign.

• In the **Using** drop-down menu, choose **Clustal W**.

• Use the **Scoring matrix** drop-down menu to choose between these options:

<table>
<thead>
<tr>
<th>Matrix</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Nucleotide sequences only</strong></td>
<td></td>
</tr>
<tr>
<td>IUB</td>
<td>The default scoring matrix used by BESTFIT for the comparison of nucleic acid sequences. X's and N's are treated as matches to any IUB ambiguity symbol. All matches score 1.9; all mismatches for IUB symbols score 0.</td>
</tr>
<tr>
<td>Clustal W</td>
<td>The previous system used by Clustal W, in which matches score 1 and mismatches score 0. All matches for IUB symbols also score 0.</td>
</tr>
<tr>
<td><strong>Protein sequences only</strong></td>
<td></td>
</tr>
<tr>
<td>BLOSUM</td>
<td><em>(Henikoff &amp; Henikoff, 1992).</em> BLOSUM is ideal for carrying out similarity searches.</td>
</tr>
<tr>
<td>PAM</td>
<td><em>(Dayhoff et al., 1978).</em> Widely used since the late 1970s.</td>
</tr>
<tr>
<td>GONNET</td>
<td>Derived from PAM matrices <em>(Dayhoff et al., 1978)</em> but more sensitive, and based on a much larger data set.</td>
</tr>
<tr>
<td>ID</td>
<td>Scores two identical amino acids as 1, and anything else as -10,000.</td>
</tr>
</tbody>
</table>

• In the **Iteration method** drop-down menu, choose between **None**, **All alignment steps**, and **Final alignment only**. If you choose an item other than **None**, type the number of **Maximum Iterations** into the text box on the right.

• Enter the desired Multiple alignment parameters:

  ◦ **Gap open penalty**, the numerical penalty for introducing a gap of any length when calculating alignments. This penalty does not take into account the size of the gap. The default is 10.

  ◦ **Gap extend penalty** – This option affects the lengths of gaps, and must be zero or a negative number. Lowering the magnitude of the gap extension penalty may allow for longer gaps. The default is 0.20.

  ◦ **Delay divergent sequences** – This setting aligns more closely related sequences, delaying the alignment of more distantly related ones. Input the percent identity required to delay the addition of a sequence. The default is 30.
- **Transition weight** – This option is only available for nucleotide sequences and gives purine-purine or pyrimidine-pyrimidine substitutions (i.e., A-G or C-T) a weight between 0 and 1. One denotes a match, while zero denotes a mismatch. Assign a high score for closely related sequences and a lower score for distantly related ones. The default is 0.50.

- Enter the desired Pairwise alignment parameters:
  
  - Choose whether MegAlign Pro should use the **Slow, accurate** or **Fast, approximate** version of Clustal W when making the guide tree.
  
  - Type in the **Gap open penalty**, the numerical penalty for introducing a gap of any length when calculating alignments. This penalty does not take into account the size of the gap. The default is 10.
  
  - **Gap extend penalty** – This option affects the lengths of gaps, and must be zero or a negative number. Lowering the magnitude of the gap extension penalty may allow for longer gaps. The default is 0.1.

After making your changes:

- Choose **Align** to use the entered options to perform a multiple sequence alignment.

- Use the **Reset to Default** button if you would like to reset all values to the MegAlign Pro defaults.

- Select **Cancel** to leave the dialog without saving any changes or performing the alignment.
MAFFT alignment options

The MAFFT algorithm is for gene level alignment of either protein or nucleotide sequences. To run a MAFFT alignment, select two or more sequences and choose Align > (Re)Align Using MAFFT.

If you wish to change method options, instead choose Align > Align with Options. Options vary depending whether the sequences are protein or nucleotide (nucleotide version shown below).

Change settings as desired:

- Use the Align drop-down menu to select sequences to align or realign.
- In the Using drop-down menu, choose Clustal W.
- Specify the Gap open penalty, the numerical penalty for introducing a gap of any length when
calculating alignments. This penalty does not take into account the size of the gap. The default is -2.0.

- **Gap extension penalty** – This option affects the lengths of gaps, and must be zero or a negative number. Lowering the magnitude of the gap extension penalty may allow for longer gaps. The default is 0.

- In the Algorithm drop-down menu, either retain the default of Choose algorithm depending upon size [auto], or specify a particular alignment algorithm.

<table>
<thead>
<tr>
<th>Description</th>
<th>Name</th>
<th>No. of Seqs</th>
<th>Strategy</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose algorithm depending upon size [auto]</td>
<td>(default)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Very slow</td>
<td>global homology</td>
<td>&lt; 200</td>
<td>g-ins-i</td>
</tr>
<tr>
<td>Very slow</td>
<td>one conserved domain</td>
<td>&lt; 200</td>
<td>l-ins-i</td>
</tr>
<tr>
<td>Very slow</td>
<td>multiple conserved domains</td>
<td>&lt; 200</td>
<td>e-ins-i</td>
</tr>
<tr>
<td>Slow</td>
<td>iterative refinement, iterations specified by user</td>
<td>N/A</td>
<td>fft-ns-i</td>
</tr>
<tr>
<td>Medium</td>
<td>Iterative refinement, two iterations</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>Fast</td>
<td>Progressive</td>
<td>N/A</td>
<td>fft-ns-2</td>
</tr>
<tr>
<td>Very fast</td>
<td>Progressive</td>
<td>&gt; 2000</td>
<td>fft-ns-1</td>
</tr>
</tbody>
</table>

- in the Scoring matrix drop-down menu, choose the desired matrix:

<table>
<thead>
<tr>
<th>Matrix name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Nucleotide sequences</strong></td>
<td></td>
</tr>
<tr>
<td>1PAM / k=2</td>
<td>For closely related sequences.</td>
</tr>
<tr>
<td>20PAM / k=2</td>
<td>For moderately related sequences.</td>
</tr>
<tr>
<td>200 PAM / k=2</td>
<td>For distantly related sequences.</td>
</tr>
<tr>
<td><strong>Protein sequences</strong></td>
<td></td>
</tr>
<tr>
<td>BLOSUM30, 45, 62, 80</td>
<td><em>(Henikoff &amp; Henikoff, 1992)</em>. The BLOSUM series of matrices contain the same values as in some of MegAlign Pro’s other alignment methods, except that the protein ambiguity codes B, Z, and X are excluded in this case. These matrices are ideal for carrying out similarity searches. Choose a larger number BLOSUM matrix for less</td>
</tr>
</tbody>
</table>
divergent sequences.

| JTT100, 200 | (Thorne JL et al., 1998) These matrices are similar to PAM matrices and were generated using an algorithm similar to the approach of Dayhoff et al. (1978), but based on a larger set of protein sequences. |

After making your changes:

- Choose **Align** to use the entered options to perform a multiple sequence alignment.
- Use the **Reset to Default** button if you would like to reset all values to the MegAlign Pro defaults.
- Select **Cancel** to leave the dialog without saving any changes.
MUSCLE alignment options

The MUSCLE algorithm is for gene level alignment of either protein or nucleotide sequences. To run a MUSCLE alignment, select two or more sequences and choose Align > (Re)Align Using MUSCLE.

If you wish to change method options, instead choose Align > Align with Options. Options vary depending whether the sequences are protein or nucleotide (protein version shown below).

Change settings as desired:

- Use the Align drop-down menu to select sequences to align or realign.
• In the **Using** drop-down menu, choose **MUSCLE**.

• **Substitution matrix** – (protein sequences only) Choose from a list that includes one or more members of the VTML, BLOSUM GONNET and PAM series of matrices.

• **Gap open penalty** – This option affects the chance of gaps being introduced into alignments, and must be zero or a negative number. Decreasing the magnitude of the gap open penalty may lead to an excessive amount of gapping. The default is -400 for DNA; -420 for RNA; -2.9 for protein.

• **Gap extension penalty** – This option affects the lengths of gaps, and must be zero or a negative number. Lowering the magnitude of the gap extension penalty may allow for longer gaps. The default is 0.

• **Center penalty** – This must be zero or a negative number. The default is 0 for DNA; -300 for RNA; and -0.52 for protein.

• **Maximum iterations** – This option, which must be a positive integer, affects the number of rounds of refinement used to produce an alignment. Depending on your data, the alignment might finish before the specified number of rounds have been performed. The default is 8.

• **Use Brenner’s Alignment** – Checking the box causes MegAlign Pro to use Brenner’s method for the root alignment. Brenner’s method uses less memory than the default root alignment, but the alignment will not be as accurate as if the box were left unchecked. For this reason, it is not usually necessary to check the box unless you received certain types of error messages during a previous alignment attempt.

• **Disable anchors optimization** – The default for MUSCLE is for anchor optimization to be enabled (i.e., for this box to be unchecked). One side effect of anchor optimization is that the selected number of **Maximum iterations**, if greater than two, may be over-ruled during sequence processing. If you instead wish to run the exact number of iterations selected in **Maximum iterations** (above), add a checkmark to this box.

• Use the drop-down menus to choose the desired **Cluster method** for **Initial iterations** and **Later iterations**.

<table>
<thead>
<tr>
<th>Cluster method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>UPGMA</td>
<td>Fast O(N2) approximation to the textbook UPGMA algorithm.</td>
</tr>
<tr>
<td>UPGMB</td>
<td>Variant of UPGMA that is used, by default, for both iteration 1 and 2.</td>
</tr>
</tbody>
</table>
**Neighbor Joining**  Better at making phylogenetic trees, but slower, and usually worse for making guide trees for progressive alignment. Not recommended for most alignments.

- Choose the desired **Distance measures**.

<table>
<thead>
<tr>
<th>Distance measure</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Initial iterations</strong></td>
<td></td>
</tr>
<tr>
<td>Kmer 4-6</td>
<td>[default for DNA/RNA; not available for protein]</td>
</tr>
<tr>
<td>Kmer 6-6</td>
<td>[default for protein]</td>
</tr>
<tr>
<td>Kmer 20-3</td>
<td></td>
</tr>
<tr>
<td>Kmer 20-4</td>
<td></td>
</tr>
<tr>
<td>Kmer bit 20-3</td>
<td></td>
</tr>
<tr>
<td><strong>Later iterations</strong></td>
<td></td>
</tr>
<tr>
<td>Kimura % identity</td>
<td>[default]</td>
</tr>
<tr>
<td>Log % identity</td>
<td></td>
</tr>
</tbody>
</table>

- Select the desired **Sequence weights** for **Initial iterations** and **Later iterations**.

<table>
<thead>
<tr>
<th>Sequence weight</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Do not weight sequences.</td>
</tr>
<tr>
<td>ClustalW (default)</td>
<td></td>
</tr>
<tr>
<td>Henikoff</td>
<td></td>
</tr>
<tr>
<td>Henikoff PSI-BLAST</td>
<td></td>
</tr>
<tr>
<td>gsc</td>
<td></td>
</tr>
<tr>
<td>Threeway</td>
<td></td>
</tr>
</tbody>
</table>

The following table shows how the MegAlign Pro settings correspond with settings in [MUSCLE](https://www.drive5.com/muscle/online) online.

<table>
<thead>
<tr>
<th>MegAlign Pro setting</th>
<th>MUSCLE setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Substitution matrix</td>
<td>matrix</td>
</tr>
<tr>
<td>Gap open penalty</td>
<td>gapopen</td>
</tr>
<tr>
<td>Gap extension penalty</td>
<td>gapextend</td>
</tr>
<tr>
<td>Parameter</td>
<td>Value</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Center parameter</td>
<td>center</td>
</tr>
<tr>
<td>Maximum iterations</td>
<td>maxiters</td>
</tr>
<tr>
<td>Use Brenner’s Alignment</td>
<td>brenner</td>
</tr>
<tr>
<td>Disable anchors optimization</td>
<td>anchors</td>
</tr>
<tr>
<td>Cluster method:</td>
<td></td>
</tr>
<tr>
<td>Initial iterations</td>
<td>cluster1</td>
</tr>
<tr>
<td>Later iterations</td>
<td>cluster2</td>
</tr>
<tr>
<td>Distance measure:</td>
<td></td>
</tr>
<tr>
<td>Initial iterations</td>
<td>distance1</td>
</tr>
<tr>
<td>Later iterations</td>
<td>distance2</td>
</tr>
<tr>
<td>Sequence weight:</td>
<td></td>
</tr>
<tr>
<td>Initial iterations</td>
<td>weight1</td>
</tr>
<tr>
<td>Later iterations</td>
<td>weight2</td>
</tr>
</tbody>
</table>

After making your changes:

- Choose **Align** to use the entered options to perform a multiple sequence alignment.

- Use the **Reset to Default** button if you would like to reset all values to the MegAlign Pro defaults.

- Select **Cancel** to leave the dialog without saving any changes.
Mauve alignment options

The Mauve alignment algorithm is for genome level alignment of nucleotide sequences. To run a Mauve alignment, select two or more nucleotide sequences and choose Align > (Re)Align Using Mauve.

If you wish to change method options, instead choose Align > Align with Options.

Change settings as desired:

- Use the Align drop-down menu to select sequences to align or realign.
- In the Using drop-down menu, choose Mauve.
- If the Default seed weight box is checked, as it is by default, the optimal seed weight (number of matches required per k-tuple) is calculated automatically. You may uncheck the box and either use...
the slider or manually enter a number in the **Seed weight** box to specify a particular seed weight between 3 and 21. The default is 15.

- Check the **Use seed families** box to use multiple spaced seed patterns to identify potential homology. When working with divergent genomes, checking this box can significantly improve the sensitivity and accuracy of the alignment.

- Whether or not you have checked either of the boxes in this dialog, you may override the default **Min LCB weight**, if desired, by entering a value in the box. Increasing the **Min LCB weight** may reduce the number of spurious rearrangements, and is advisable in many cases.

The following table shows how the MegAlign Pro settings correspond with settings in [Mauve](https://mauve.mbl.edu/) online.

<table>
<thead>
<tr>
<th>MegAlign Pro setting</th>
<th>Mauve setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default seed weight (disabled)</td>
<td>seed-weight</td>
</tr>
<tr>
<td>Use seed families (enabled)</td>
<td>seed-family</td>
</tr>
<tr>
<td>Min LCB weight (non-default value entered)</td>
<td>weight</td>
</tr>
</tbody>
</table>

After making your changes:

- Choose **Align** to use the entered options to perform a multiple sequence alignment.

- Use the **Reset to Default** button if you would like to reset all values to the MegAlign Pro defaults.

- Select **Cancel** to leave the dialog without saving any changes.

The following videos demonstrate how to perform a multiple alignment using the Mauve alignment algorithm:

The following video shows a multiple alignment using the Mauve algorithm:
Modify a multiple alignment

The following table describes ways to modify an initial multiple alignment:

<table>
<thead>
<tr>
<th>Task</th>
<th>See this topic</th>
</tr>
</thead>
<tbody>
<tr>
<td>To realign a range of aligned sequences using different parameters or a different alignment engine</td>
<td>Subalign sequences</td>
</tr>
<tr>
<td>To merge two existing completed alignments together</td>
<td>Merge two existing alignments (“Profile alignment”)</td>
</tr>
<tr>
<td>To add all/selected sequences from the “Unaligned Sequences” area into the current alignment, while retaining all of the gaps of the original, pre-merge alignment</td>
<td>Merge unaligned sequences into an existing alignment</td>
</tr>
<tr>
<td>To realign existing aligned sequences PLUS selected unaligned sequences</td>
<td>Align selected unaligned sequences with an existing alignment</td>
</tr>
</tbody>
</table>

The following video illustrates some of these modification procedures:
Subalign sequences

While sequences such as full-length calmodulin proteins typically align well throughout the entire length of the polypeptides, full-length alignments of other sequences may not generate such neat blocks of similarity. For example, multiple sequence alignments of full-length beta-tubulins typically show “ragged” carboxyl termini, where the different tubulins terminate at varying positions with respect to the consensus. The “ragged” termini are caused by considerable length variance of the beta tubulins and carboxyl termini that are poorly conserved. Therefore, once you have performed an initial multiple alignment for two or more sequences, you may wish to realign a section using different parameters or a different alignment engine.

To perform a sequence subalignment:

1. Make a single selection across the aligned sequences. One way to do this is to drag the mouse along the consensus sequences. Another is to triple-click on a feature. Either selects a “vertical slice” of all the sequences in the current alignment. If you plan to use Mauve as the alignment algorithm, note that you can only select and subalign sequences within the active block.

2. Choose Align > Realign Subsequences to open a dialog populated for a sequence subalignment.

3. Choose the desired alignment method from the drop-down menu, then set other options as desired.
4. Press Align.

**Notes:**

- Subalignments are not supported when the document contains any end-to-end sequences.

- Occasionally, the new subalignment may no longer be the same as the optimal alignment your alignment method would generate from scratch for this particular set of sequence coordinates. You may want to realign the shorter sequences to evaluate this possibility.

- If you are not sure exactly which segment of an alignment you need for your new alignment, you may select the region liberally, generate the new alignment, and continue to select sub-regions of the alignment until you are satisfied.

- You can create a new alignment from a selection of any length, but you cannot create a new alignment from discontiguous segments of your current alignment.
Merge two existing alignments ("Profile alignment")

To merge two existing alignments:

A “profile alignment” occurs when you merge a MegAlign Pro alignment (.msa) that was saved earlier with the current project. Profile alignments merge two existing multiple alignments without removing any of the existing gaps. However, new gaps may be automatically inserted to reconcile the new alignment. Mauve alignments are not supported in this workflow.

1. Create a project, align the sequences using any alignment method except Mauve, and then save the project in MegAlign Pro (.msa) format.

2. Create a second project and perform an alignment using any method except Mauve. Both projects must use the same sequence type (nucleotide vs. amino acid), but it is not necessary to use the same alignment method that was used in Step 1. If the projects do not contain the same sequence types, you will receive an error message:

![Unable to Merge Alignments]

3. (optional) The next step will over-write the alignment in the second (current) project. Therefore, you may wish to save the alignment before proceeding further.

4. From within the second (current) project, select Align > Merge Alignment into Existing Alignment.

5. In the ensuing Open dialog, navigate to the saved project and click Open. A warning will be displayed if you attempt to merge an unsaved project with the active project.

6. Choose the desired alignment method from the drop-down menu, then set other options as desired. Note that Mauve and MAFFT alignment methods are not supported for this workflow.
7. Press **Align**.

**Note:** Any unaligned sequences from the merged project are automatically transferred to the “Unaligned Sequences” area of the current project.
Merge unaligned sequences into an existing alignment

To merge unaligned sequences into the current project's existing alignment:

In contrast to the "Profile alignment" method, this method retains existing gaps, and adds new gaps, if necessary.

1. Add sequences to the project and align some or all of them. If all sequences were aligned, add more sequences to the project.

2. Before proceeding, check that the "Unaligned Sequences" bars in the Overview and Sequences view display a number ≥ 1 in the parentheses. If you wish, you may show or hide the unaligned sequences by clicking the arrows on the left of each bar.

3. (optional) An upcoming step will overwrite the current alignment. Therefore, you may wish to save the original alignment before proceeding further.

4. Specify which unaligned sequences to add to the current alignment.

5. Select Align > Merge Unaligned into Existing Alignment or press the Align sequences to an existing alignment tool ( ). The menu command and tool are enabled only if the project contains an alignment and at least one unaligned sequence.

6. Choose the desired alignment method from the drop-down menu, then set other options as desired. The Mauve alignment method is not supported in this workflow.

7. Press Align.
Align selected unaligned sequences with an existing alignment

In some cases, you may have already aligned sequences, then decide to completely realign the same sequences plus certain selected unaligned sequences.

To align selected unaligned sequences with an existing alignment:

1. Add sequences to the project and align some or all of them. If all sequences were aligned, add more sequences to the project.

2. Before proceeding, check that the “Unaligned Sequences” bars in the Overview and Sequences view display a number ≥ 1 in the parentheses. If you wish, you may show or hide the unaligned sequences by clicking the arrows on the left of each bar.

3. (optional) An upcoming step will over-write the current alignment. Therefore, you may wish to save the original alignment before proceeding further.

4. Specify which unaligned sequences to include in the new alignment by clicking on them or by using Ctrl/Cmd+click or Shift+click.

5. Select Align > Realign with Selected Unaligned.

6. Choose the desired alignment method from the drop-down menu, then set other options as desired.

7. Press Align.
Unalign aligned sequences

To unalign all sequences in an alignment:

1. Choose Align > Unalign All.

2. When the following message appears, click OK.

Execution of this command causes gaps to be removed from all of the previously aligned sequences. The sequences are then automatically relocated to the “Unaligned Sequences” areas of the Overview and Sequences view. In some cases, a progress bar may be displayed during the unalignment procedure.

To unalign particular aligned sequences:

1. Select one or more of the aligned sequences in the Overview or Sequences view.

2. Choose Align > Unalign Selected.

3. When the following message appears, click OK.
Depending on the size of the alignment, a progress dialog entitled Removing All-Gaps Columns may be displayed during the unalignment process.

Execution of this command causes gaps to be removed from all of the previously aligned sequences. The sequences are then automatically relocated to the “Unaligned Sequences” areas of the Overview and Sequences view. In some cases, a progress bar may be displayed during the unalignment procedure.
Try it! – Perform a Clustal Omega alignment

This tutorial will use the Clustal Omega algorithm to multiply align 143 DNA sequence files consisting of regional variations of the Human Papilloma Virus L1 gene (HPV-L1). HPV has affected humans for hundreds of thousands of years and is known to cause cervical cancer. Some regional variations of the gene are more pathogenic than others. For example, HPV-16 is the most pathogenic variation in Western populations.

The L1 gene is not the cause of variation in pathogenicity. However, variations of the L1 gene are used to tell various strains apart and group them according to relatedness. The results of this tutorial reveal a deeply branched tree revealing an ancient phylogeny for HPV within the human genome.

Begin with Part A: Add and align sequences.
Part A: Add and align sequences

In this part of the tutorial, you will be adding 143 DNA sequences to the MegAlign Pro project and aligning them with the Clustal Omega algorithm using the default settings.

1. If you have not yet download and extracted the tutorial data, [click here to download it](#). Then decompress (unzip) the file archive using the method of your choice.

2. If a MegAlign Pro project is already open, choose **File > New Alignment Project**. Otherwise, launch MegAlign Pro.

3. Choose **File > Add Sequences**, or click on the **Add sequences to project** tool ( 

4. Open the folder **HPV project**. Use **Ctrl+A** (Win) or **Cmd+A** (Mac) to select all 143 DNA sequences and click **Open**.

5. When prompted, select **DNA**.

6. In the **Overview** at the top left of the MegAlign Pro window, note the appearance of a series of gray blocks, one for each sequence. The gray blocks have the lengths of their corresponding sequences. Solid gray blocks and varying block lengths are both indicative of sequences that have not yet been aligned.
7. To align sequences with Clustal Omega using the default parameters, choose **Align > Align Using Clustal Omega** or click the Align tool arrow ( ) and choose **Align Using Clustal Omega**. Sequences now appear mostly in green, with gray representing gaps.

Proceed to **Part B: Navigate using the Overview**.
Part B: Navigate using the Overview

Observe that the sequence blocks in the Overview are now the same lengths. Sequence gaps are represented by gray coloring within the blocks.

The light blue vertical column shown at the left of the green blocks, above, is a "viewport" showing which region is currently being displayed in the Sequences view. The width of the viewport will vary depending on the zoom levels in both this view and the Sequences View. You can use the mouse to drag the viewport to whichever region you wish to see in the Sequences view.

- Using the mouse, slide the viewport to the far right, and then back to the left. At the same time, notice how the Sequence view slides in the same way.

- To navigate to a particular residue in the Sequences view, double-click anywhere on a block in the Overview. The viewport will move so that it is centered on the selection.

- Use the horizontal zoom slider in the Sequences view to zoom in and out. As you do this, notice how the width of the viewport in the Overview changes.

Proceed to Part C: Change sequence names and rendering in the Sequences view.
Part C: Change sequence names and rendering in the Sequences view

In Part B, you looked at the Sequences view while learning the function of the "viewport." You will now explore the Sequences view in more depth. The Sequences view displays entered sequences and aligned sequences. Sequences selected in this view are simultaneously selected in all other MegAlign Pro views.

1. In the Sequences view, observe that the names of each sequence originated from the accession numbers that were embedded in the input files.

To also add the sequence length as part of the name:

a. Use Ctrl+A or Cmd+A to select all of the sequence names.

b. Right-click on the highlighted group and select Rename with Fields, or choose Edit > Rename with Fields from the main menu.

c. Select Sequence length from the left pane and click the right arrow to add it.
d. Click **OK**.

The sequence labels now reflect their lengths in base pairs:

2. Remove the current selection by double-clicking on any white space, e.g., white space in the header or footer area of the Overview or Sequences view.

3. Use **File > Save** to save the project as *HPV project.msa*. 
4. In the Sequence view, click on any plus icon (⊕) to reveal a details track containing a gap-aware ruler. These sequences do not contain annotations, but if they did, the annotations would also be visible.

5. The appearance of the sequences can be changed using settings in the Sequences area located to the right of the views. Experiment with the items in this area to see how they affect the look of the Sequences View. Some items must first be enabled by checking the associated checkbox.

When you have finished trying out different color schemes and fonts, we recommend changing them back to the original settings (shown in the image above) for ease of following the remainder of this tutorial.

6. Imagine that you want to see the Consensus Match track, but it is not included in the default display. To display the track, click the Tracks header tab in the upper right of MegAlign Pro (or select View > Tracks > Tracks) and check the box next to Consensus Match.
7. Locate the **Consensus Match** histogram in the footer of the Sequences view. Hover over a bar to see a pop-up showing the percent of sequences that match the consensus at that residue.

8. Hide the footer by clicking on the small gray arrow near its top right corner ( ). The Sequence Logo, Ruler and Consensus Match will disappear. Click on the arrow again to redisplay the footer. (Note: For future reference, you can close other panes the same way, including the footer and the main parts of the Sequence view and Overviews).

Proceed to [Part D: Change metrics and rendering in the Distance view](#).
Part D: Change metrics and rendering in the Distance view

The Distance view shows a matrix (i.e., table) of numbers representing distances between each pair of sequences. Sequence distances are used as input in creating the Tree view, which you will explore in Part E. Selections within this view are synchronized with other views in MegAlign Pro.

1. To display the Distance view, click on the Distance tab at the bottom of the MegAlign Pro window.

   ![Distance View](image)

   The Distance view matrix is calculated, by default, using Uncorrected Pairwise Distance.

2. Click on the Style tab and experiment with the settings in the Distance parameters section. Observe how these changes affect the look of the Distance view.

   ![Distance Parameters](image)
• Change the distance **Metric** to **Tamura-Nei (1993)**. (Note: Different sub-sets of metrics are available for protein sequences and nucleotide sequences).

• Change the **Font** style and/or size using the middle drop-down menu and text box.

• Change the number of **Decimal places** displayed in the Distance View.

3. Try selecting, copying, and exporting the distance table.

  • *To select* a portion of the table, use the mouse. To select the entire table, use **Edit > Select All** or **Ctrl/Cmd+A**.

  • *To paste the selected information into a spreadsheet application such as Microsoft Excel®,* use **Edit > Copy** or **Ctrl/Cmd+C**.

  • To export the distance matrix in your choice of available formats, use **File > Export Data > Distance Matrix**.

Proceed to [Part E: Change the appearance of the Tree view](#).
Part E: Change the appearance of the Tree view

The Tree view shows evolutionary relationships predicted from the multiple sequence alignment.

1. To display the Tree view, click on the Tree tab at the bottom of the MegAlign Pro window.

The Tree view is calculated using the current Distance metric. In Part D, you chose the Tamura-Nei (1993) distance metric, so this is the metric on which the current Tree view is based.

Note that the MegAlign Pro tree is always unrooted, regardless of the methods used for the multiple
alignment and distance calculations.

2. Experiment with the settings in the Style panel’s Tree section on the right to see how these changes affect the look of the Tree view.

- Change the Layout by clicking any of the four position icons at the top of the Tree section.

- Change the font style and/or size used for the Leaves using the middle drop-down menu and text box.

- Add a background color for the text, if desired, by checking the Background checkbox, then clicking on the white box on the right to make a selection from the color picker.

- Change the color of the branches by clicking on the Branches Color box and making a selection from the color picker.

- Show or hide the branch length by checking and unchecking the corresponding box. While the box is checked, try adjusting the number of Decimal places.

3. In the Distance section on the right, use the distance Metric dropdown menu to return to Uncorrected Pairwise Distance. Observe how the Tree view changes. For greatest accuracy, we recommend using an evolutionarily adjusted metric such as Tamura-Nei (1993) rather than “Uncorrected Pairwise Distance.”
4. If desired, save the project using **File > Save**, or by clicking on the **Save** tool ( 

This is the end of the Clustal Omega alignment tutorial.
Try it! – Perform a MUSCLE alignment with multi-segment sequences

Sequences that consist of more than one chromosome, contig, or fragment are called multi-segment files.

Suppose you want to string together the consensus sequences from all the contigs in an assembly, or chromosomes in a genome, or exons in a gene, etc. If you enter these sequences using File > Enter Sequences or the corresponding button ( ), you will end up aligning the parts to one another. By entering these sequences into MegAlign Pro using the procedure in this tutorial, the entire set of sequences in the multi-segment file (or set of files) will instead be treated as an end-to-end concatenation.

Begin with Part A: Add and align multi-segment files.
Part A: Add and align multi-segment files

1. If you have not yet download and extracted the tutorial data, [click here to download it](#). Then decompress (unzip) the file archive using the method of your choice.

2. If a MegAlign Pro project is already open, choose **File > New Alignment Project**. Otherwise, launch MegAlign Pro.

3. Choose **File > Add Sequences End-to-end**, or click on the **Add sequences end-to-end in project** tool (   )

![Add Sequences End-to-end dialog box](#)

4. Click the **Add** button, then navigate to and open the tutorial data folder *Rp1 exon groups*. The nucleotide files in this folder represent the RP1 exons for several mammal species. Each exon consists of 3-4 segments.

5. If needed, click either once or twice on the file name header to ensure the sequences are in ascending alphabetical order, as in the image below.
6. Use **Shift+click** to select only the four "chimp" segments, and then click **Open**. In the Add Sequences End-to-end dialog, the files will appear in ascending alphabetical order.
7. In the **Group name** text box, replace the default name with **Chimp**, and then click **OK**.

8. Follow steps 3-5 four more times to create separate groups for the **Cow**, **Dog**, **Human**, and **Mouse** sequences. In each case, replace the generic **Group name** with the informal species name.

9. For Group 6, add the rat sequences and replace the default name with **Rat**, but do **not** yet click **OK**.
   For demonstration purposes, you will deliberately be ordering these sequences incorrectly.

10. Select the "exon1" sequence by clicking on it once, and then click three times on the **Down** button until the sequence appears at the bottom of the list. Similarly, select the "exon4" sequence, the click twice on the **Up** button until the sequence appears at the top of the list.
11. Remove the checkmark next to **Add another**, and then click **OK**.

Looking at the Overview, observe that each species is represented by multiple gray blocks of different lengths. Blue dividers show where one segment ends and another begins.

![Alignment Overview](image.png)

12. To make the blocks appear smaller or larger, use the horizontal and/or vertical zoom sliders ( ).

13. Select **Align > Align Using MUSCLE** to align the sequences using the MUSCLE algorithm. The alignment will likely take several minutes to complete.

14. While the alignment is being performed, try using the **View > Console** command. This opens a log showing the progress of the alignment. Before proceeding, close the Console by clicking the ‘x’ in its tab.

15. Use **File > Save** to save the project under the name **RP1 project.msa**.

Proceed to **Part B: Replace a sequence in the Overview and view the phylogenetic tree**.
Part B: Replace a sequence in the Overview and view the phylogenetic tree

In the **Overview**, look for the longest segment and the longest gap region (shown in gray) in each sequence. Note that both of these are located on the left for "Rat," and on the right for all the other groups. These clues indicate that the segments for "Rat" were likely added in the wrong order. (As you recall, these were deliberately added these in the wrong order in **Part A**.)

In this part of the tutorial, you will remove the "Rat" group and add it again--this time in the proper order. You will then re-align the sequences.

1. Single-click on the name "Rat" to select it.

2. Right-click on "Rat" and choose **Remove Sequence**. When asked to confirm, click **OK**.

3. Select the **Add sequences end-to-end in project** tool ( ).

4. Click the **Add** button and add the rat sequences again. This time, leave the sequences in ascending order (exon1, exon2, exon3, exon4).

5. Change the default **Group name** to **Rat**, and uncheck the **Add another** box. Click **OK**.

Observe that the Rat sequence has been added to a new area of the view called “Unaligned Sequences.” Click on the expand arrows to reveal the sequence, shown in the image below.
6. To perform the MUSCLE alignment with the "Rat" group in the correct order, select the name "Rat" on the left of the Overview and choose **Align > Realign with Selected Unaligned**. This command tells MegAlign Pro to perform a novel alignment that includes all the sequences in the existing alignment plus the selected unaligned sequences.

7. Leave the settings at their default values, and choose **Align**. As before, the alignment will likely take several minutes to complete.

   Once the alignment has finished, note that the gap regions in the Overview now appear more randomly distributed, and that all six organisms now have the longest block on the right.

8. Display the **Tree view** by clicking on the **Tree** tab at the bottom of the MegAlign Pro window.

   The phylogenetic tree graphically illustrates plausible evolutionary relationships for the seven species.
9. Using the Distance section on the right, change the Metric from Uncorrected Pairwise Distance to Tamura-Nei (1993). Unlike in Try it! – Perform a Clustal Omega alignment, where changing the method caused a visible change in the tree organization, the tree retains the original structure, and has only slight changes in the branch length.

10. Save the project using File > Save, or by clicking on the Save tool ( ).

This is the end of the MUSCLE alignment tutorial.
Try it! – Perform a genomic alignment with Mauve

In this tutorial, you will be adding six nucleotide sequences to MegAlign Pro using drag & drop, and then aligning them with the Progressive Mauve algorithm. Drag and drop is a feature available in all Lasergene applications, and is useful for entering multiple sequences.

Part A: Add genomic sequences using drag & drop

1. If you have not yet download and extracted the tutorial data, click here to download it. Then decompress (unzip) the file archive using the method of your choice.

2. If a MegAlign Pro project is already open, choose File > New Alignment Project. Otherwise, launch MegAlign Pro.

3. Outside MegAlign Pro, use the Windows Explorer or Macintosh Finder to locate and open the tutorial data folder *H. pylori genomes*. Arrange and size the file explorer and the MegAlign Pro window so that you can see both simultaneously.

4. In the file explorer, use Shift+click to select the four files.

5. Use the mouse to drag & drop the selected files onto any "white space" in the Overview or Sequences view.

   The sequences appear in the Overview as solid gray blocks of unequal length, indicating that the sequences have not yet been aligned.

6. Use your mouse to drag and drop the sequence names (on the left side of the window) so they appear in the same order as in the image below. This will ensure that your block colors and positions match those referenced in later sections of this tutorial.
7. Use **File > Save** to save the project under the name *H. pylori project.msa*.

Proceed to [Part B: Perform a Mauve alignment using modified parameters](#).
Part B: Perform a Mauve alignment using modified parameters

In this part of the tutorial, you will explore how to view and change parameters prior to performing a multiple sequence alignment.

1. Choose Align > Align Using Mauve and align the sequences using the default parameters. Because this is a genomic alignment, the alignment will take longer than those done in the first two tutorials (approximately 5-10 minutes).

After genomic sequence alignment with Mauve, MegAlign Pro displays genomes in the Overview as Locally Co-linear Blocks, usually abbreviated to "blocks" or "LCBs." Blocks represent multiple-aligned sections of at least two of the current set of genomic sequences. Discontinuity in numbering is displayed as a break between blocks. Connecting lines show the correspondence between blocks. Blocks hanging below the black line, signify that the hanging blocks are on the opposite strand compared to the other blocks.

The default settings used in creating this alignment are suitable for most projects, including this one. However, you will make a change to Mauve’s Seed weight parameter in order to see how this affects the alignment results.

In Mauve, Seed weight is the minimum weight of the seed pattern used during the first pass of a multiple alignment. When aligning divergent genomes, lower seed weights may provide better sensitivity. However, if the value is set too low, the result will be reduced sensitivity. In the following steps of this tutorial, you will lower the Seed weight slightly, from the 15 (the default) to 13.
2. Choose **Align > Align with Options**. This dialog allows you to change methods and/or parameters. Note that **Mauve** is already selected in the menu at the top of the dialog, since it is the last method used.

3. By default, the **Default seed weight** box is checked, meaning that the optimal seed weight (number of matches required per k-tuple) is calculated automatically. Uncheck the box and either use the slider to change the **Seed weight** to 13, or type **13** in the **Seed weight** text box.

![Align Sequences dialog](image)

4. Choose **Align** to perform the Mauve alignment again using the selected parameters.

Proceed to **Part C: View a genomic alignment in the Overview**.
Part C: View a genomic alignment in the Overview

Once the alignment has finished, notice how the Overview has changed in response to the parameter change, including changes to the colors of the blocks, and differences in which blocks are hanging below the line (i.e., on the opposite strand).

1. Locate the medium-width block whose right edge is close to the 1,000,000 mark on the ruler. The block will not necessarily be gold, as shown here, but the location should match the location of checkmarks in the image below. Double-click on the block in any row to make it the active block.

Observe that the active blocks are now in a single, highlighted column, with each block having equal width. The viewport is located on the left-most end of the blocks.

Notice how genome NC_012973 flipped in orientation when the new block was made active. To allow this genome’s active block to match the orientation of the active blocks in other rows, MegAlign Pro automatically reverse-complemented all the blocks on the opposite strand.
2. In the Overview, slide the viewport to the right edge of the active blocks. You can use the horizontal green slider above the view to expand this area so you can see it more clearly.

3. Use either set of scroll arrows to center the **Sequences view** on the right edge of the active block, as shown below. (The exact location of the edge may differ from that shown in the image). Observe that residues outside and to the right of the active block are shown in a dimmed/dull version of the color scheme.

4. Select **View > Style > Overview** to open the **Overview section**. Experiment with changing the parameters.
To increase/decrease the amount of white space between rows of blocks, use the **Spacing** slider. Unlike the zoom in/out sliders, this setting affects only the white space between the blocks, and does not affect the sizes of the blocks.

Change the font and font size. If you wish to change the track names font, check the box to enable changing the font and size.

To toggle between displaying or hiding the lines connecting blocks from one row to another, check or uncheck the **Show connecting lines** checkbox.

If you select a different **Reference**, change it back to CP002076 before you are finished.

Proceed to [Part D: View the phylogenetic tree](#).
Part D: View the phylogenetic tree

**Note:** The images in this section show examples of how the trees might appear. Your trees may have different arrangements or different branch lengths from the ones shown.

1. The current names of each sequence originated from the accession numbers that were embedded in the input files. Before viewing the phylogenetic tree, you can change these names to show the organism from which each sequence originated:
   
   a. Use **Ctrl+A** or **Cmd+A** to select all of the sequence names.
   
   b. Right-click on the highlighted group and select **Rename with Fields**, or choose **Edit > Rename with Fields** from the main menu.
   
   c. Select **Default name** from the right pane and click the left arrow (blue) to remove it. Then select **Organism** from the left pane and click the right arrow to add it. Click **OK**.

   The sequence labels now reflect the species names:

   - Helicobacter pylori Cuz20
   - Helicobacter pylori Gambia94/24 (Helicobacter pylori Gam94/24)
   - Helicobacter pylori 26995
   - Helicobacter pylori B38

2. To display the Tree View for the active blocks, click on the Tree tab at the bottom of the MegAlign Pro window.

   ![Tree View Tab]

   The contents of the **Tree view** (and also the **Distance view**) are specific to the currently selected block only.
3. In the Overview, double-click on different blocks in the Overview and see how the branch lengths, or (sometimes) the tree itself, change.

4. To order sequences in the other views so they match the tree, select **Tree > Order sequences like tree**.

5. If desire, save the project using **File > Save**, or by clicking on the **Save** tool ( ).

This is the end of the Mauve alignment tutorial.
Perform a Pairwise Alignment

Did you arrive here by selecting the DNASTAR Navigator workflow Molecular Biology > Pairwise sequence alignment? If so, you’re in the right place!

Protein 3D supports local, global and semi-global pairwise alignment methods. Pairwise alignments can only be performed when two sequences, and only two sequences, have been selected. A common workflow is to first perform a multiple alignment on an entire group of sequences. From the resulting Tree view, two closely related sequences can then be further analyzed by selecting them and performing a pairwise alignment.

Pairwise alignment tutorials:

The following tutorials use free data that can be downloaded from the DNASTAR website:

- Try It! – Follow a multiple alignment with Global pairwise alignments
- Try It! – Align transcripts to genes using Local and Global pairwise alignments
- Try It! – Use a Local pairwise alignment to find a gene within a genome

To perform a pairwise sequence alignment:

1. Decide which two sequences you want to align. The sequences can be any length (DNASTAR has successfully aligned protein sequences up to 35,000 bases in length), but both must belong to the same category: DNA/RNA or protein. If one sequence is significantly longer than the other, use drag & drop in the Sequences view or Overview to organize them such that the longer sequence is above the shorter sequence.

2. Select the two sequences and choose Align > Pairwise or right-click on the selection and choose Align Pairwise. Dialog options vary depending on whether protein or nucleotide sequences were selected. An example is shown below.
3. Use the **Align** drop-down menu to specify which sequences to align.

4. In the **Using** drop-down menu, choose the desired pairwise alignment method:

   - Global alignment, represented in MegAlign Pro by the **Global Needleman-Wunsch** algorithm, includes the full length of both sequences, even if this requires padding one or more of the sequence ends with gaps. MegAlign Pro considers overhangs and underhangs created this way as unaligned context. One example of a situation where a global alignment is preferred over a local alignment is when there are multiple, but disjoint, segments of aligned sequence. Examples when a global alignment is a good choice: 1) aligning a CDS or mRNA sequence to a gene that contains introns; 2) aligning two sequences that differ because of the presence of large insertions, such as might be caused by transposable elements. In both cases, a local alignment is less likely to reflect the full alignment, especially if the lengths of the unalignable inclusions are long relative to the gap extension penalty.

   - Semi-global alignment, represented by the **Semi-global Needleman-Wunsch** algorithm, is similar to global alignment, except the gaps placed at the ends of sequences are not penalized. A semi-global alignment might be more useful than global alignment in situations where long leading/trailing gaps might be suppressed in favor of a result that contains segments of aligned sequences punctuated by gaps.

   - Local alignment, represented by the **Local Smith-Waterman** algorithm, reports the highest scoring contiguous segment of alignment between two sequences, even if the full extent of one
or both of the sequences is not included in the final alignment. Local alignments are ideal for finding a short sequence within a larger sequence. Flanking segments of sequences that are not within the aligned segment can be visualized in MegAlign Pro by checking the Show context box in the Pairwise Alignment section of the Style panel.

See this page from Trinity College-Dublin’s Department of Genetics for a good synopsis of Needleman-Wunsch vs. Smith-Waterman algorithms.

**Note:** When two sequences are nearly identical (check by performing a multiple alignment and consulting the Distance view), all pairwise methods should work equally well.

5. Use the drop-down menu(s) to choose the Substitution matrix and related options, if any

6. Specify the Gap open penalty, the amount deducted from the alignment score for each gap in the alignment. Gaps of different sizes carry the same penalty. Default is 10.

7. Specify the Gap extension penalty, the value which will be deducted from the alignment score after first multiplying it by the length of gaps. Longer gaps have a greater penalty than shorter gaps. Default is 1.

8. If you wish to specify the length of the smallest perfect match of contiguous bases/residues to consider in building an alignment, check the Require minimum word match box and enter a value. The default is unchecked; if checked, the default value is 7.

9. Press OK.

During the alignment, MegAlign Pro displays a progress window. In most cases, this will appear and disappear too suddenly to notice it. In the cases of longer alignments, you can interrupt the alignment, if necessary, by clicking its Cancel button or view a console window showing the start time and progress of the alignment by clicking its Show Console button.

If an alignment finishes successfully, a Pairwise view opens. If an alignment fails, you will receive a message with recommendations on how to obtain a successful alignment (e.g., by modifying options or choosing a different alignment method).

10. (optional) If the Console is not already open, and you wish to view alignment statistics and other information there, select View > Console.
**Note:** Pairwise alignments are not saved when you save or close a MegAlign Pro project.
Comparison of pairwise alignment methods

The three types of alignment—Local, Global and Semi-Global—are actually quite similar, although they can often produce very different results. All use a method called dynamic programming to find the best scoring alignment between two sequences. Alignment scores are computed by adding up per-base match scores and subtracting a penalty for opening a gap (of any length) and another for the number of positions that have gaps. The match scores are based on a scoring matrix such as NUC42 or BLOSUM62. It’s always a good idea to explore the effects of various settings of these three parameters to see if you can get a more desirable outcome.

Depending on your two sequences, the three methods can potentially yield widely different results, so it’s important to understand how they differ.

Local Pairwise Alignment:

MegAlign Pro’s local alignment algorithm, a modernized variant of the one described by Smith-Waterman (1981), is designed specifically to find the highest scoring aligned segments of two sequences, even if the full extent of the two is not included in the final alignment. (Note: in MegAlign Pro, the “Show Context” check-box in the Style Panel lets you display any unaligned parts of the sequences flanking the aligned segments).

Global Pairwise Alignment:

The alternative to locally aligning is to align globally. To do this MegAlign Pro uses two variants of the Needleman and Wunsch (1970) algorithm. Global aligners don’t try to find the best scoring segment, but instead require that the full extent of both sequences be included in their results. There is no requirement or guarantee that the best scoring pair of aligned segments from a local alignment will be aligned in a global alignment.

Semi-Global Pairwise Alignment:

Semi-global alignment is a relatively new approach that is particularly suitable when the two sequences differ greatly in length. When that happens, the longer sequence will have overhangs on either end of the alignment. Since overhangs are represented with gaps, a global aligner will attempt to increase the match score and minimize accumulated gap penalties by aligning parts of the shorter sequence to overhanging sequence region(s). This effect can produce a number of unrealistic, usually small aligned segments spaced by gaps near the ends of the alignment. Semi-global alignment is designed to address this problem by not penalizing gaps in overhangs (aka “end gaps”).
The differences between these three pairwise approaches really can make an impact in the resulting alignment, but the choice of which to use really depends on your task. For basic cases, such as aligning two genes or proteins, Local alignment is a good starting point, but when things get more complicated, Global or Semi-Global may be the way to go. We have included three tutorials to demonstrate some of the differences between these methods.

- Try It! – Follow a multiple alignment with Global pairwise alignments
- Try It! – Align transcripts to genes using Local and Global pairwise alignments
- Try It! – Use a Local pairwise alignment to find a gene within a genome
Substitution matrices

A substitution matrix describes the rate at which a nucleotide or amino acid changes to another nucleotide or amino acid over time. When performing a pairwise alignment, you can specify the desired substitution matrix in the (Pairwise) Alignment Options dialog.

Available matrices for nucleotide sequences:

<table>
<thead>
<tr>
<th>Matrix</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NUC44</td>
<td>DNASTAR’s modified version of NCBI’s NUC.4.4 algorithm, the modification being that U is treated as a synonym of T. In NUC44, exact matches, and T:U matches score as 5, and mismatches between unambiguous bases [G A T C U] score as -4. Matches between bases and ambiguous symbols [S W R Y K M B V H D N] have intermediate scores. A base versus a 2-way ambiguous category [R Y W S K M] to which it belongs scores as +1, and a mismatch to a 2-way group to which it doesn’t belong scores as -4. Example: C is in [S R M] but not in [W Y K]. The 3-way groupings are [B V H D] where C is in all but D (which means not C). Therefore, C vs [B V H] scores as -1 while C vs [D] scores as -4.</td>
</tr>
</tbody>
</table>

Available matrices for protein sequences:

<table>
<thead>
<tr>
<th>Matrix</th>
<th>Description</th>
<th>Secondary option</th>
</tr>
</thead>
<tbody>
<tr>
<td>BLOSUM</td>
<td>(Henikoff &amp; Henikoff, 1992). These matrices are ideal for carrying out similarity searches.</td>
<td>Available matrices range from 30-100, and are provided in increments of 5 and 62. Choose larger numbers for less divergent sequences.</td>
</tr>
<tr>
<td>GONNET</td>
<td>Derived from PAM matrices (Dayhoff et al., 1978) but more sensitive, and based on a much larger data set.</td>
<td>(Unchangeable default of 250)</td>
</tr>
<tr>
<td>IDENTITY</td>
<td>Scores two identical amino acids as 1, and anything else as -10,000.</td>
<td>N/A</td>
</tr>
<tr>
<td>MATCH</td>
<td>Scores two identical amino acids as 1, and anything else as -1.</td>
<td>N/A</td>
</tr>
<tr>
<td>PAM</td>
<td>(Dayhoff et al., 1978). Widely used since the late 1970s.</td>
<td>Available matrices range from 10-500, and are provided in increments of 10. Choose larger numbers for more divergent sequences.</td>
</tr>
<tr>
<td>VTML</td>
<td>Derived from PAM matrices (Dayhoff et al., 1978) by Müller T et al. (2002), .</td>
<td>Available matrices range from 10-500, and are provided in increments of 10.</td>
</tr>
</tbody>
</table>
• BLOSUM, PAM, GONNET, IDENTITY, and MATCH are part of NCBI’s BLAST distribution. For more information, see NCBI’s matrix page.

• The PAM, GONNET and VTML numbers are based on the presumed millions of years of divergence.

• In BLOSUM, the matrix number is proportional to the presumed degree of similarity. Therefore, BLOSUM100 would be the preferred matrix for near-identical sequences.

• VTLM and GONNET are considered to be updated versions of PAM250.

• In BLOSUM, PAM, and GONNET, match/mismatch scores vary with the series number. Also exact matches vary with the particular amino acid. For example, BLOSUM30 scores W:W as 20 and S:S as 4. BLOSUM100 scores these as 17 and 9, respectively.
Try It! – Follow a multiple alignment with Global pairwise alignments

This tutorial demonstrates a situation in which a pairwise alignment can help resolve a confusing placement of gaps within a multiple alignment. In this case, a multiple protein sequence alignment suggests that the protein sequence from a specific organism (*Tupaia chinensis*, the Chinese tree shrew) is severely truncated at its C-terminus and ends with a run of 27 residues that seem to be unrelated to the other members of the alignment, including a relative (*Sorex araneus*, the Eurasian shrew). A pairwise global alignment of the two shrew sequences, however, reveals that a more likely interpretation is that the the *T. chinensis* sequence contains a deletion of 235 residues followed by a terminal stretch of 32 amino acids that is nearly identical to that of the *S. araneus* sequence. Here the pairwise alignment suggests that first-pass multiple sequence alignment is not optimal. Armed with this information, you can try changing the alignment engine and gap penalties to see if a more reasonable result can be achieved. Another technique that might help is to use sub-alignments to refine the overall multiple sequence alignment.

This example also demonstrates the power of using pairwise and multiple alignments together to help interpret specific relationships between sequences that might have become obscured by gaps which were added during the multiple alignment process. With MegAlign Pro, it is simple to generate many pairwise alignments without ever having to disturb the multiple sequence alignment, which has the larger picture. This is far more convenient that starting over with several different documents.

To perform the analysis:

1. If you have not yet download and extracted the tutorial data, [click here to download it](#). Then decompress (unzip) the file archive using the method of your choice.

2. Double-click on the *Angiomotin_vertebrates.clustalo.msa* project file to launch it in MegAlign Pro.

   This project contains a collection of Angiomotin proteins from a diverse set of vertebrate species, already multiply-aligned with Clustal Omega. The figure below shows the alignment with the Sequences view and Overview scrolled to show the two tree shrew sequences. For more detail, you can expand the image below by clicking on it.
3. Notice that the *Tupaia* sequence (the lowermost item on each list) seems to end abruptly with an unaligned run of amino acids. If you can’t see the abrupt end, move the Sequence view’s green horizontal zoom slider to the left until the Sequences view appears as in the image above.

4. To investigate this using pairwise alignment, click on the name of the *Tupaia* sequence to select it, and then **Ctrl-click** (Win) or **Cmd-click** (Mac) on the name of the *Sorex* sequence to add it to the selection. You can select these sequences in either the Sequences view or the Overview.

5. Right-click on either name and select **Align Pairwise**.

6. In the Align Pairwise dialog box, select **Global: Needleman-Wunsch** from the **Using** drop-down menu. Since you are specifically interested in the C-terminal ends of the sequences, the **Global** option is ideal.

7. Keep the default settings for all other dialog options and click **OK**. The alignment will run and a **Pairwise view** will appear.
8. Scroll down the Pairwise view to the end of the alignment and notice that it is now clear that the *Tupaia* sequence contains a large deletion and that the C-terminal ends of the two shrew sequences are nearly identical.

Pairwise alignments can also be used to help interpret multiple alignments with gaps that might obscure the relationships between sequences. While the Pairwise view is still open, try some **Global** alignments between different species pairs. This is easily done by changing the sequence(s) in the drop-down menus at the top of the Pairwise view.

9. Change the sequence in the right drop-down menu to to *Homo sapiens* (human).

10. Scroll through the updated alignment and observe that the two sequences match pretty well, despite some mismatches and gaps. The header shows a similarity calculation (**Similar**) of **91.3**.

11. Change the sequence shown in the left drop-down to *Pan troglodytes* (chimpanzee). The human and chimp sequences are **98.4%** similar, with only an 11-residue gap differentiating them. This similarity can be seen with a much greater degree of clarity than could be seen looking at the Overview of the original multiple alignment. (Click on the image below to expand it.)
Try It! – Align transcripts to genes using Local and Global pairwise alignments

This three-part tutorial illustrates the utility of pairwise alignments when comparing mRNA transcripts to their cognate genes. This example begins with multiple alignments of the alcohol dehydrogenase (ADH) gene from *Drosophila melanogaster* and four mRNA transcript isoforms. Comparing the overview of the alignment to the gene’s annotations reveals a few problems that are easily resolved with pairwise alignments.

As in *Try It! – Follow a multiple alignment with Global pairwise alignments*, a global alignment is the most suitable approach, because long gaps corresponding to introns may make it hard for a local aligner to join segments from exons. With a local alignment the ends of a transcript may not be included among the aligned segments.

Start with *Part A: Compare results from three multiple alignment methods*.
Part A: Compare results from three multiple alignment methods

This part of the tutorial demonstrates that if you don’t have annotations to rely on for validating multiple alignments, a pairwise alignment is a good alternative.

This tutorial uses a default MUSCLE alignment of the *Drosophila melanogaster* ADH gene and the mRNA transcripts for isoforms F,C,E and H. In this example, some of the annotations of the original GenBank entry, NT_033779.5, were removed for the sake of clarity.

To begin the analysis:

1. If you have not yet download and extracted the tutorial data, [click here to download it](#). Then decompress (unzip) the file archive using the method of your choice.

2. Double-click on the *DmADH.muscle.msa* project file to launch it in MegAlign Pro.

   The Overview for this alignment is shown in the image below. (Click on the image to make it larger.)

   ![Overview of alignment](image)

   In this example, the transcripts, represented by the four lower sequences, have already been arranged in the same vertical order as the mRNA-features for the ADH gene, represented by orange arrows in the upper sequence.

3. Hover your mouse over some of the orange mRNA features and verify that they are in the same order as the transcripts represented by the lower four sequences.
As expected, there is a good correspondence of the aligned regions of the transcripts to the exons of the gene. But a closer examination reveals a few problems, one of which is indicated by the red boxes in the image above. Notice that that isoF and isoC are annotated to code for Exon I (box A), which matches the multiple alignment result. However the 5’ end of isoH and isoE are also aligned, somewhat poorly, to this exon. How can you tell? Note that there are only two yellow arrows in box A, but there are green bars in all four transcript rows for box A, the bottom two of which are much sparser than the others This part of the lower two transcripts — which have no corresponding yellow arrows — should really have aligned with the start of Exon II (box B).

As a reminder, the example above used the MUSCLE alignment method. Before testing whether or not pairwise alignment can resolve this problem, check out how some of the other three multiple alignment engines handle these particular sequences.


5. Examine the alignments of transcript sequences to the first two exons of the gene’s sequence. In this case, there are no green bars at all in box A.

6. Realign again, this time using MAFFT (Align > Realign Using MAFFT). For this example data set only MAFFT gives a result that is consistent with the annotations. (Click on the image to make it larger.)

Proceed to Part B: Use a Local pairwise alignment method.
Part B: Use a Local pairwise alignment method

Now that you have finished Part A of the tutorial, this part shows how you can use a local pairwise alignment to resolve the correct mapping of the first intron in isoF and isoC.

1. Click on Pairwise view tab. Look at the left drop-down menu at the top of the view to see that the uppermost sequence (Dmel_ADH) has automatically been selected as the reference.

2. In the right drop-down menu, choose "isoF-NM_001022098.2". The default Local: Smith Waterman method is used to create the alignment.

3. To make sure all features will be displayed:
   a. Open the Tracks side-panel.
   b. Under Pairwise details, click once on the word Features.
   c. Move the Height slider to the right until you can see all the feature rows.

4. In the Pairwise view, click on the plus-sign icon next to the name Dmel_ADH to reveal the Features and Sequence Ruler tracks.

   A correct alignment would show the 5’ end of the isoF sequence aligned with the two orange arrows that begin at the very start of the Dmel_ADH sequence. Instead, however, the beginnings of both the ADH reference sequence and the mRNA are shown as dimly colored context; in other words, as unaligned flanking sequence.
5. Scrolling down through the alignment observe that the 5’ end of the transcript sequence has aligned, albeit poorly, with a region beginning within the first intron. Meanwhile, a solid ungapped alignment doesn’t start until 5’ end of the second exon annotated for either isoF or isoC. (See the boxed area in the image below.)

Clearly, a local pairwise alignment was not an improvement over the first two multiple alignments tried in Part A.

Most likely, introducing a sufficient number of gaps to span the intron would reduce the score so much that the aligner can find a higher scoring segment that contains numerous short gapped regions.

Proceed to Part C: Use a Global pairwise alignment method.
Part C: Use a Global pairwise alignment method

Since the Local pairwise alignment in Part B was not an improvement over the multiple alignments in Part A, you will now try a Global pairwise alignment. This type of alignment forces the ends of both sequences to be aligned.

1. Click the gear icon on the Pairwise view toolbar and select Global: Needleman-Wunsch from the “Using” drop-down menu. Then press Align.

2. After aligning, the display options that you set above remain in effect, but the sequences’ detail tracks will collapse. Expand the DmeI_ADH track again by clicking on its plus sign.

3. To see the “big picture,” zoom all the way out using the green “zoom slider” above the view. The pairwise alignment now appears similar to the Overview. You can see that the global alignment using isoF matches Dmel_ADH’s annotations. (Click on the image to expand it.)

MegAlign Pro allows you to open additional pairwise views so that you can compare alignments with different settings, or even different pairs of sequences. You can use this to compare any of the other three mRNA sequences to Dmel_ADH, while leaving the previous alignment untouched.

4. Clone the current Pairwise view using the ”Clone this view” tool situated at the far right side of the toolbar. The two views will start out the same, but they are completely independent.

5. Select isoE-NM001032099.2 as the query sequence, keeping the reference sequence set to Dmel_ADH. The new Global pairwise alignment now gives the expected results.
This is the end of the tutorial.
Try It! – Use Local pairwise alignment to find a gene within a genome

Consider the case of a researcher who is trying to investigate the role of a gene isolated from a yet-unsequenced *Salmonella* strain. This strain has already been demonstrated to be both copper and multi-drug resistant. As demonstrated in the following tutorial, one way to proceed would be to align the sequence of the uncharacterized gene to the genome of a related reference strain. If a reasonable alignment was found, the annotations of the matching segment could then be examined to infer the function of the cloned gene.

**Note:** To align the large genomic data set used for this tutorial, we recommend using a machine with a minimum of 8 GB — and preferably 16 GB — of RAM.

To perform the analysis:

1. If you have not yet download and extracted the tutorial data, click here to download it. Then decompress (unzip) the file archive using the method of your choice.

1. Double-click on the *Salmonella_CT18_plus_gene.msa* project file to launch it in MegAlign Pro.

   The document contains just two unaligned sequences: the genomic sequence of reference strain *S. enterica serovar Typhi*, strain CT18, and the unknown sequence.
2. Select both sequences, right-click on the selection, and then select **Align Pairwise** from the context menu.

3. In the ensuing dialog box, note that the default pairwise alignment method is **Local: Smith-Waterman**. Since this method is the best choice for finding a small segment of similarity within a larger sequence such as chromosome, keep the default settings and click the **OK** button. (Note: If any long gaps were needed for alignment, you could always realign later using lower gap penalties.)

This is a good time to discuss the concept of "reference" (or "target") sequence versus the "query" sequence. In MegAlign Pro, these two sequences are defined through the two drop-down menus at the top of the view. The left menu should be used for the reference, and the right menu for the query sequence. Most of the time, the sequence selected to be the "reference" is somewhat arbitrary. However, when one sequence is much longer than the other — as in this example — the longer sequence should be used as the reference.

After the alignment has completed, the **Pairwise view** header indicates that the **706 bp** query matches a **702 bp** segment in the CT18 genome with **98.6%** Identity and has **1** gap that is **4 bp** long.
4. Scroll down through the alignment until you locate the gap, which begins at alignment position 452.

Notice that the gap is shown within the reference, indicating that there is a 4 bp insertion in the unknown sequence. Since the insertion length is not a multiple of three, the gap most likely represents a frame-shift in the unknown sequence.

5. In the Tracks side panel on the right, locate the Pairwise Details section and check the box next to Translation.

6. Returning your attention to the Pairwise view on the left, open the tracks for the unknown sequence by clicking the plus sign corresponding to that sequence.

The translation tracks (labeled 1, 2, 3) clearly indicate that the frame-shift has introduced an in-frame stop beginning at base 530 of the query sequence (red box in the image below). In other words, it represents a nonsense mutation. This is good evidence that this is indeed a mutant gene compared
to the non-drug resistant reference strain.

To find more clues to the identity of the unknown gene, you will next investigate the CT18 reference sequence annotations at this position.

7. Collapse the tracks for the unknown sequence by clicking on any of the minus signs corresponding to that sequence.

8. Expand the detail tracks for the reference (CT18) by clicking any of the corresponding plus signs for that sequence.

Observe that the indel's position overlaps a gene and a CDS that are identified as STY0266.

9. Click anywhere on the STY0266 feature to select it.

10. Examine the annotations for STY066 in the Details panel. If the Details panel is not visible, reveal it using View > Details.
As shown in the Details panel, the gene sequenced from the unknown, copper-resistant strain is a defective version of cutF (also called nlpE) which encodes a copper homeostasis protein that has been shown (Nishino, et al. 2010) to be associated with elevated multidrug and copper resistance in E. coli.
Copy, Paste and Delete

In many cases, once you have selected text, data, sequences or subsequences, you can copy the information to the clipboard.

Note: Copy functions are limited by application memory and operating system buffer size. Therefore, for very long sequences or subsequences, we recommend exporting data to a file rather than copying it.

To copy the selected text as it appears in the view:

Choose **Edit > Copy**, press **Ctrl/Cmd+C**, or use the context (right-click) menu to choose **Copy**.

- If a portion of sequence or one or more features are selected, this command copies the selected subsequence(s) as one long string, including the gaps. The subsequence is copied as one long string, without line breaks. If the selection extends across multiple members of the alignment, names are included as prefixes.

- If a selection is made in the **Distance view**, this command copies the selection in a tab-delimited format suitable for use with spreadsheet programs like Microsoft Excel®.

- If a selection is made in the **Pairwise view**, this command also copies the header information.

- In the **Details panel**, contents of each section must be copied separately.

To copy the selected text or data in FASTA format:

Choose **Edit > Copy As FASTA**, press **Ctrl/Cmd+Shift+C**, or use the context (right-click) menu to choose **Copy As**.

To paste text from the clipboard into a text field:

Choose **Edit > Paste** or use **Ctrl/Cmd+V**. This command is disabled in all but a few circumstances.
To delete selected text from a text box:

Press the Delete key or use Edit > Delete.
Export

The following topics discuss how to:

- Export an image of the view
- Export data to a file
- Export data to MegAlign
- Export a tree to a tree viewer

If you renamed sequences manually or automatically, learn how to retain custom names during export.
Export an image of the view

To export an image of a view:

1. Choose File > Export Image > (View Name).

2. Specify the file name and choose the export format: Adobe PDF (.pdf), Microsoft PowerPoint-optimized (.pptx), PNG image (.png) or JPG image (.jpg, .jpeg).

Notes: If you choose Adobe PDF format and a particular font is not supported there, a similar font will be substituted for the original one automatically. If you choose the format that is optimized for use with Microsoft PowerPoint, the MegAlign Pro image is converted into an editable set of objects that can be grouped, ungrouped and moved within the target application. To constrain an object (e.g., a MegAlign Pro track) within Microsoft PowerPoint to move only vertically, rather than laterally, hold down the Shift key.

If exporting the Tree view, the export procedure is now complete.

If exporting the Overview, Sequences view or Pairwise view, the following dialog (or an abbreviated version) will open.

3. Choose export options.

   - Use the Range of alignment boxes to specify the range of residues that should appear in the image. The default is the current viewport range.
• (Sequences and Pairwise only) Type in the number of **Residues per line**. By default, MegAlign Pro places the entire range on a single line.

• (Pairwise only) Check the **include summary** box if you want to include the summary (above the sequences area) in the image.

• (Sequences only) Check the **Include dividing lines** box if you wish to include separators between the header, sequences, and footer.

The **Resulting image size** updates automatically based on the options you choose.

4. Click **OK** to export the image using the specified options or **Cancel** to close the dialog without exporting.

The following video shows how to export an image from MegAlign Pro and edit it in PowerPoint.
Export data to a file

Several commands in the File menu allow you to export alignments, distance matrices and phylogenetic trees, as well as aligned sequences and the consensus sequence. Unless you wish to export all sequences in the project, you must first make a selection.

<table>
<thead>
<tr>
<th>Item to export</th>
<th>Command</th>
<th>Notes / Export format(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>All sequences in the project</td>
<td>File &gt; Export Data &gt; Sequences</td>
<td>Various GenBank and FASTA formats; MegAlign format (.meg); or Nexus formats (.nex, .nxs).</td>
</tr>
<tr>
<td>Selected aligned sequences</td>
<td>File &gt; Export Data &gt; Aligned Sequences</td>
<td>When exporting to most formats, gaps are represented as embedded dashes. When exporting to GenBank, gaps in nucleotide sequences are represented as “n’s” and those in amino acid sequences are represented as “x’s.”</td>
</tr>
<tr>
<td>Selected portion(s) of the aligned sequences</td>
<td>File &gt; Export Data &gt; Aligned Subsequences</td>
<td></td>
</tr>
<tr>
<td>Selected aligned sequences in the active block (requires Mauve alignment)</td>
<td>File &gt; Export Data &gt; Active Block Sequences</td>
<td>Various GenBank and FASTA formats; MegAlign format (.meg); or Nexus formats (.nex, .nxs). Gaps are removed.</td>
</tr>
<tr>
<td>Selected aligned sequences with gaps removed</td>
<td>File &gt; Export Data &gt; Aligned Sequences Without Gaps</td>
<td>Various GenBank and FASTA formats; MegAlign format (.meg); or Nexus formats (.nex, .nxs). Gaps are removed.</td>
</tr>
<tr>
<td>Aligned sequences in the active block with gaps removed (requires Mauve alignment)</td>
<td>File &gt; Export Data &gt; Active Block Sequences without Gaps</td>
<td>Various GenBank and FASTA formats; MegAlign format (.meg); or Nexus formats (.nex, .nxs). Gaps are removed.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If you wish to make a new MegAlign Pro (.msa) file based on the active sequence block, use this command. Later, you can add the exported sequence to a MegAlign Pro project and use it as one of the sequences in a multiple alignment.</td>
</tr>
<tr>
<td>Consensus sequence from the Sequences view</td>
<td>File &gt; Export Data &gt; Aligned Consensus</td>
<td>Various GenBank and FASTA formats; MegAlign format (.meg); or Nexus formats (.nex, .nxs).</td>
</tr>
<tr>
<td>Consensus sequence from the active block of the Overview (requires Mauve alignment)</td>
<td>File &gt; Export Data &gt; Active Block Consensus</td>
<td></td>
</tr>
<tr>
<td>Selected portion(s) of the aligned sequences in the active block</td>
<td>File &gt; Export Data &gt; Aligned Active Block</td>
<td>When exporting to most formats, gaps are represented as embedded dashes. When exporting to GenBank, gaps in nucleotide sequences are represented as “n’s” and those in amino acid sequences are represented as “x’s.”</td>
</tr>
<tr>
<td>Consensus sequence from the <a href="#">Sequences view</a> with gaps removed</td>
<td>Subsequences</td>
<td>File &gt; Export Data &gt; Aligned Consensus Without Gaps</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Consensus sequence from the active block of the Overview with gaps removed (requires Mauve alignment)</td>
<td>File &gt; Export Data &gt; Active Block Consensus without Gaps</td>
<td>File &gt; Export Data &gt; Tree</td>
</tr>
<tr>
<td>Phylogenetic tree information from the <a href="#">Tree view</a></td>
<td>File &gt; Export Data &gt; Distance Matrix</td>
<td>Comma- or tab-separated formats (.csv or .tab), PHYLIP format (.dist) or Nexus formats (.nex, .nxs). After selecting a name and format, click <strong>Save</strong> to launch the Choose Matrix Form dialog:</td>
</tr>
<tr>
<td>Matrix information from the <a href="#">Distance view</a></td>
<td>---</td>
<td>---</td>
</tr>
</tbody>
</table>

Use the drop-down menu to choose whether to save the entire ("square") matrix or only the upper or lower triangle.
### Note
If you choose to save in .dist format, the sample names in the saved file will automatically be truncated to 10 characters.

| Aligned sequences, distance table and phylogenetic tree information | File > Export Data > All Data | Nexus formats (.nex, .nxs) only. |
Export data to MegAlign

You can export sequences and alignments to classic MegAlign, where you may realign using a different method, perform bootstrapping, or view alignment reports.

<table>
<thead>
<tr>
<th>Timing</th>
<th>Command</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Before performing an alignment</td>
<td>File &gt; Send Sequences to MegAlign</td>
<td>Creates and opens a new MegAlign project containing the same sequences and sequence order as in the MegAlign Pro project.</td>
</tr>
<tr>
<td>After performing an alignment</td>
<td>File &gt; Send Aligned Sequences to MegAlign</td>
<td>Sequences retain their MegAlign Pro alignment.</td>
</tr>
<tr>
<td>After performing an alignment and selecting a portion of the consensus</td>
<td>File &gt; Send Aligned Subsequences to MegAlign</td>
<td>Sequences retain their MegAlign Pro alignment.</td>
</tr>
<tr>
<td>After performing a Mauve alignment and selecting an alignment block in the Overview</td>
<td>File &gt; Send Active Block to MegAlign</td>
<td>Exports only the sequences in the active block.</td>
</tr>
</tbody>
</table>
Export a tree to a tree viewer

As described in Export data to a file, Phylogenetic trees can be exported in Newick (.newick) or Nexus (.nex, .nxs) formats using File > Export Data > Tree. The saved files can be opened by many free and commercial evolutionary biology software programs.

The following procedure goes a step further. It lets you automatically launch a third-party tree viewer and view the tree within that application.

To export and open the phylogenetic tree in a third-party tree viewer:

1. Outside MegAlign Pro, download the desired tree viewer and install it on your computer. Compatible viewers include Archaeopteryx (Win only) and FigTree.

   ▲ Note: When installing FigTree on a Macintosh computer, you may receive a message that the application is damaged. You may need to change your Security & Privacy settings to allow applications downloaded from “Anywhere” prior to installation.

2. In MegAlign Pro, set the default application for opening saved trees using the File > Send Tree To menu command.

3. Perform an alignment.

4. Export the tree using File > Send Tree to (Tree Viewer). If you have chosen a compatible tree viewer, this command launches the viewer with the active MegAlign Pro project tree open. If a tree viewer has not yet been specified, you will receive the following message:
Click OK to launch the application preferences dialog, where you can indicate the viewer location.

**Note:** If you export a tree containing duplicate sequence names, you may receive a warning when you try to open it in a third-party application. To fix this issue, return to MegAlign Pro, rename one of the sequences, and then re-export the tree.
Retain custom names during export

After using File > Rename or File > Rename with Fields, the custom names are only exported as part of the sequence data in certain cases. Raw data sequences imported into MegAlign are never modified in any way, and always retain their original names.

The following table lists the cases in which custom sequence names are exported:

<table>
<thead>
<tr>
<th>Export target</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>MegAlign</td>
<td>Send an alignment to MegAlign using File &gt; Send to MegAlign. Or use File &gt; Export Data, save as a MegAlign (.meg) file and then open the file in MegAlign. In either case, MegAlign truncates imported labels to a maximum of 39 characters.</td>
</tr>
<tr>
<td>Tree viewers</td>
<td>Send an alignment directly to a tree viewer with File &gt; Send Tree to (Tree Viewer). Or save a tree file via File &gt; Export Data &gt; Tree, and then open it in a tree viewer. The custom label will be retained.</td>
</tr>
<tr>
<td>Sequences and alignments</td>
<td>Custom labels are exported to Nexus, and MegAlign formats. They are not exported to FASTA or GenBank formats.</td>
</tr>
<tr>
<td>Distance matrices</td>
<td>Custom labels are exported to distance matrices of all formats (e.g., .csv, .tab, .dst, and .nex).</td>
</tr>
</tbody>
</table>
Print Images

To print an image of any MegAlign Pro view, whether it is currently active or not:

Choose File > Print or use Ctrl/Cmd+P. The Print Document dialog opens:
• Use the **Printer** drop-down menu to choose the desired printer from a list of available options.

• Specify the view you wish to print using the **Content to print** menu. Choices may include: **Overview**, **Sequences View**, or **Tree View**. Depending upon the selection, additional options may appear just below this drop-down menu.

  - **Overview** and **Sequences View** - To print only a sub-range of the alignment, type the left and right residues into the **Range of alignment** boxes (if an alignment has taken place) or **Range of sequence** boxes (if alignment has not taken place).

  - **Sequences** - To specify how many residues to include on one line, type in a number from 1-100 next to **Residues per line**. Check the **Include dividing lines** box if you wish to include separators between the header, sequences, and footer.

  - **Tree** - Check **Fit to page** to automatically size the tree to fit on a single page of the size specified in **Page Size** (see below).

• Choose which **Page Size** to print on. (Note: If you wish to change the default print size setting, see **Change the default print size**.)

• Specify the top, bottom, **Margins** by typing a number in the associated box and choosing the units (inches, cm, etc.) from the nearby drop-down menu.

• Choose whether to print in **Portrait** or **Landscape** orientation.

• Under **Page Options**, use the checkboxes to specify what to include in the footer: **footer text**, **date and time** and/or **page numbers**. If you check **Include footer text**, the footer will incorporate the text just below the checkbox. By default, this is the path and MegAlign Pro project name (or only the default project name, for unsaved documents), but you may type in any text that you wish.

• Click the **Print with options** link if you want to launch the default Print dialog for your computer.

Choose **Cancel** to exit from the MegAlign Pro Print Document dialog without printing. Click **Print** to print using the selected parameters, or **Print with Options** to open the Print dialog for your computer’s operating system. The generic dialog can be used to specify additional options, such as the page range and number of copies to print.
Change the default print size

Unless otherwise specified on your computer, the default printing size for all DNASTAR applications is “U.S. Letter” size (8.5 × 11 inches = 21.6 × 28 cm). You can temporarily change to another size, such as A4, from within the application. However, the next time you print, the default size will again be U.S. Letter size.

To correct this issue, you need to change your computer’s default printing size:

On Windows 7 and Windows 8:

1. Open the Control Panel.
2. In the Hardware and Sound category, click on Printers or View devices and printers.
3. Right-click on your printer and choose Properties.
4. In the General tab, click on the Printing Properties button.
5. In the ensuing Printing Shortcuts tab, choose the desired default printing size from the Printing Sizes drop-down menu.
6. Click the Apply button, then the OK button.

On Macintosh:

1. Open System Preferences.
2. Click on Printers and Scanners.
3. Choose the desired size from the Default paper size drop-down menu.

Note: Changes to the default printing size will not be applied until after you restart the DNASTAR application.
Save, Close and Exit

To save, close, or exit:

The following table describes how to save files, close projects and exit from MegAlign Pro:

<table>
<thead>
<tr>
<th>Task</th>
<th>How to…</th>
</tr>
</thead>
<tbody>
<tr>
<td>To save all of the open projects simultaneously</td>
<td>Choose File &gt; Save All or press Ctrl/Cmd+Shift+S.</td>
</tr>
<tr>
<td>To save a new project in multiple sequence alignment (.msa) format, or to overwrite a previously saved version of the project</td>
<td>Choose File &gt; Save, select the Save tool ( ), or use Ctrl/Cmd+S. If you want to preserve the earlier version of a project, or store a copy of the project with a different name or location, use File &gt; Save As instead. By default, MegAlign Pro saves to the desktop unless directed to save elsewhere.</td>
</tr>
<tr>
<td>To close an active project</td>
<td>Choose File &gt; Close or Ctrl/Cmd+W. If multiple projects are open, first select the tab corresponding to the project you wish to close.</td>
</tr>
<tr>
<td>To exit from MegAlign Pro</td>
<td>On Windows, use File &gt; Exit. On Macintosh, use MegAlign Pro &gt; Quit MegAlign Pro. The shortcut Cmd+Q works on both platforms.</td>
</tr>
</tbody>
</table>

Closing or quitting when there are unsaved documents:

If you select File > Close, or if you quit MegAlign Pro when just one unsaved project is open, MegAlign Pro will open the Save Resource dialog. Click Yes to save changes, No to close/quit without saving changes, or Cancel to return to MegAlign Pro without closing/quitting.

If you quit MegAlign Pro while multiple unsaved projects are open, MegAlign Pro will instead display the Save Resources dialog.
• To save all changed projects, choose **Select All**. To close all changed projects without saving the updates, pick **Deselect All**. To save only some of the projects, add/remove checkmarks individually.

• Click **OK** to save only the checked projects and to quit MegAlign Pro. Click **Cancel** to return to MegAlign Pro without saving the checked projects.
Turn off usage logging

By default, usage logging is enabled in Lasergene version 11 and later. To opt out of usage logging, launch the DNASTAR Navigator and go to View > Preferences > Lasergene (Win) or DNASTAR Navigator > Preferences > Lasergene (Mac). Uncheck the box and click Apply and then OK.
Set preferences

You can set preferences in MegAlign Pro for application, Internet, and temporary files.

To open the Set Preferences dialog:

On Macintosh, choose MegAlign Pro > Preferences. On Windows, choose Edit > Preferences.
Set application preferences

The Applications dialog designates an (optional) Newick or Nexus viewer of your choice to use in advanced editing of phylogenetic trees. Note that the download, use, or specification of a tree viewer is optional, and is only necessary if you wish to use MegAlign Pro’s File > Send Tree to [Tree Viewer Name] command.

To access the dialog on Windows, use Edit > Preferences. On Macintosh, use MegAlign Pro > Preferences or Cmd+,. If the Applications section is not already active, click on "Applications" on the left.

- By default, the Location box is empty. If you already have tree viewing/editing software on your machine, use the Browse button to navigate to the application file, and then click OK. Most software that can read a Newick- and/or Nexus-formatted tree file will work here.

- If you would like to download free tree viewing/editing software, click the link provided to visit this page of our website. After downloading appropriate software, the Location box will usually update automatically. If not, use the Browse button as described above.

Click Apply and OK to save your changes or Cancel to ignore any changes. Click Restore Defaults to return to the default (temporary) storage location.
Set Internet preferences

The Internet Preferences dialog lets you choose whether you wish to be notified about Lasergene updates.

To access the dialog, use Edit > Preferences (Win) or MegAlign Pro > Preferences (Mac). If the Internet section is not already active, click on the word "Internet" on the left.

- Check the box if you would like MegAlign Pro to display a notification when a newer version of Lasergene is available. Uncheck the box if you do not wish to receive this notification.

Click Apply and OK to save your changes or Cancel to ignore any changes. Click Restore Defaults to return to the default settings for all four drop-down menus.
Set temporary file preferences

MegAlign Pro creates and uses temporary files while a project is open. The need for temporary file space grows with the number and length of the sequences and amount of track data in open alignment projects. If you expect the temporary files will be too large to fit in the default location, you may specify a different location for these files using the Temporary Files Preferences dialog.

To access the dialog, use Edit > Preferences (Win) or MegAlign Pro > Preferences (Mac). If the Temporary Files section is not already active, click on the phrase "Temporary Files" on the left.

To change the temporary file location, close all MegAlign Pro projects and then return to this dialog. Select the Browse button, navigate to the new location and click OK. As noted in the dialog, the location you choose must remain accessible while MegAlign Pro is running. The new location will be used for all projects that are subsequently created or opened.

Click Apply and OK to save your changes or Cancel to ignore any changes. Click Restore Defaults to return to the default (temporary) storage location.
Change the default application for opening files

Windows 7 and Windows 8:

1. Open the **Control Panel**.

2. Go to **Programs > Default Programs > Associate a file type or protocol with a specific program**.

3. Select extension you wish to change in the **Extensions** list and then click the **Change program** button.

4. Click the **Browse** button in the Open With dialog box.

5. Navigate to and select the application you want the files to open in. (Lasergene applications are located by default in `C:\Program Files\DNASTAR\Lasergene 'x'` or `C:\Program Files (x86)\DNASTAR\Lasergene 'x'`, where ‘x’ represents the version number).

6. Click **Open**.

7. Click **OK** to close the Open With dialog box, and then click **Close**.

Macintosh:

1. Select a file of the type you wish to change in Finder.

2. Go to **File > Get Info**.

3. Click the dropdown arrow in the **Open With** field, and navigate to the application you want the files to open in. (Lasergene applications are located by default in `Applications:DNASTAR:Lasergene ‘x’`, where ‘x’ represents the version number).

4. Click the **Change All** button to make the application you selected the default for all files of this type.
Clean cached files on startup

Prior to the Lasergene 14.0 release, the default MegAlign Pro startup ran a “-clean” option. This option automatically removed some cached files on application restart.

The “-clean” option is no longer executed at each startup. However, if you are a Windows user, you may execute an explicit “-clean” in the unusual event that cached data has become corrupted:

1. Close MegAlign Pro if it is currently open.

2. Launch the Command Line (C:\Windows\system32\cmd.exe).

3. Type the path to the MegAlign Pro application, followed by a space and the -clean command.

   C:\Program Files (x86)\DNASTAR\DNASTAR\Lasergene 14\MegAlign Pro.exe --clean
Troubleshoot the error “A different version is running”

If you receive the error “A different version of Lasergene is running” when you try to launch a Lasergene application, but another version of Lasergene actually isn’t running, there may be a lingering .state file from another version that needs to be deleted.

The solution is to locate and delete files named `STARDM*.state`, where `*` represents the version number.

These files may exist in the following directories:

**Windows 7 and Windows 8:**

- `C:\Users\username\AppData\Local\DNASTAR\DataManager`
- `C:\ProgramData\DNASTAR\DataManager`

**Macintosh:**

- `Hard Drive:Library:Preferences:DNASTAR:DataManager`
- `Hard Drive:Users:username:Library:Preferences:DNASTAR:DataManager`

If you find any of the .state files listed above, delete them. Once the files are deleted, the error should no longer appear.
Supported file types

For a list of file formats supported by this DNASTAR product, please see the File Formats page of our website.
## IUPAC codes

### IUPAC codes for amino acids:

<table>
<thead>
<tr>
<th>1-Letter Code</th>
<th>3-Letter Code</th>
<th>Amino Acid</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Ala</td>
<td>Alanine</td>
</tr>
<tr>
<td>B</td>
<td>Asx</td>
<td>Aspartic Acid or Asparagine</td>
</tr>
<tr>
<td>C</td>
<td>Cys</td>
<td>Cysteine</td>
</tr>
<tr>
<td>D</td>
<td>Asp</td>
<td>Aspartic Acid</td>
</tr>
<tr>
<td>E</td>
<td>Glu</td>
<td>Glutamic Acid</td>
</tr>
<tr>
<td>F</td>
<td>Phe</td>
<td>Phenylalanine</td>
</tr>
<tr>
<td>G</td>
<td>Gly</td>
<td>Glycine</td>
</tr>
<tr>
<td>H</td>
<td>His</td>
<td>Histidine</td>
</tr>
<tr>
<td>I</td>
<td>Ile</td>
<td>Isoleucine</td>
</tr>
<tr>
<td>J</td>
<td>Xle</td>
<td>Leucine or Isoleucine</td>
</tr>
<tr>
<td>K</td>
<td>Lys</td>
<td>Lysine</td>
</tr>
<tr>
<td>L</td>
<td>Leu</td>
<td>Leucine</td>
</tr>
<tr>
<td>M</td>
<td>Met</td>
<td>Methionine</td>
</tr>
<tr>
<td>N</td>
<td>Asn</td>
<td>Asparagine</td>
</tr>
<tr>
<td>O</td>
<td>Pyl</td>
<td>Pyrolysine</td>
</tr>
<tr>
<td>P</td>
<td>Pro</td>
<td>Proline</td>
</tr>
<tr>
<td>Q</td>
<td>Gln</td>
<td>Glutamine</td>
</tr>
<tr>
<td>R</td>
<td>Arg</td>
<td>Arginine</td>
</tr>
<tr>
<td>S</td>
<td>Ser</td>
<td>Serine</td>
</tr>
<tr>
<td>T</td>
<td>Thr</td>
<td>Threonine</td>
</tr>
<tr>
<td>U</td>
<td>Sec</td>
<td>Selenocysteine</td>
</tr>
<tr>
<td>V</td>
<td>Val</td>
<td>Valine</td>
</tr>
<tr>
<td>W</td>
<td>Trp</td>
<td>Tryptophan</td>
</tr>
<tr>
<td>X</td>
<td>Xaa</td>
<td>Unspecified or unknown</td>
</tr>
<tr>
<td>Y</td>
<td>Tyr</td>
<td>Tyrosine</td>
</tr>
</tbody>
</table>
### IUPAC codes for nucleotides:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
<th>Bases Represented</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>adenosine/adenine</td>
<td>A</td>
</tr>
<tr>
<td>C</td>
<td>cytidine/cytosine</td>
<td>C</td>
</tr>
<tr>
<td>G</td>
<td>guanosine/guanine</td>
<td>G</td>
</tr>
<tr>
<td>T</td>
<td>thymidine/thymine</td>
<td>T</td>
</tr>
<tr>
<td>U</td>
<td>uridine/uracil</td>
<td>U</td>
</tr>
<tr>
<td>W</td>
<td>weak</td>
<td>A T</td>
</tr>
<tr>
<td>S</td>
<td>strong</td>
<td>C G</td>
</tr>
<tr>
<td>M</td>
<td>amino</td>
<td>A C</td>
</tr>
<tr>
<td>K</td>
<td>keto</td>
<td>G T</td>
</tr>
<tr>
<td>R</td>
<td>purine</td>
<td>A G</td>
</tr>
<tr>
<td>Y</td>
<td>pyrimidine</td>
<td>C T</td>
</tr>
<tr>
<td>B</td>
<td>not A</td>
<td>C G T</td>
</tr>
<tr>
<td>D</td>
<td>not C</td>
<td>A G T</td>
</tr>
<tr>
<td>H</td>
<td>not G</td>
<td>A C T</td>
</tr>
<tr>
<td>V</td>
<td>not T</td>
<td>A C G</td>
</tr>
<tr>
<td>N or -</td>
<td>any base (not a gap)</td>
<td>A C G T</td>
</tr>
</tbody>
</table>

* The non-standard nucleotide codes “I” (Inosine) or “X” (xanthine) are not supported.
# Installed Lasergene file locations

The following file names use ‘x’ to represent the version number.

<table>
<thead>
<tr>
<th>File Category</th>
<th>Application</th>
<th>Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application</td>
<td>ArrayStar</td>
<td>Windows: C:\Program Files (x86)\DNASTAR\Lasergene x\ArrayStar</td>
</tr>
<tr>
<td></td>
<td>SeqNinja (command line)</td>
<td>Windows: C:\Program Files (x86)\DNASTAR\Lasergene x\SeqNinjaCL</td>
</tr>
<tr>
<td></td>
<td>All others</td>
<td>Windows: C:\Program Files (x86)\DNASTAR\Lasergene x\</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Macintosh: /Applications/DNASTAR/Lasergene x</td>
</tr>
<tr>
<td>Data Manager &lt;sup&gt;2&lt;/sup&gt; (&lt;em&gt;DMx, DMx.exe&lt;/em&gt;)</td>
<td>SeqBuilder Pro, Protean 3D, GeneQuest, MegAlign Pro</td>
<td>Windows: C:\Program Files (x86)\DNASTAR\Lasergene x\</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Macintosh: /Applications/DNASTAR/Lasergene x</td>
</tr>
<tr>
<td>Data Manager State File</td>
<td>SeqBuilder Pro, Protean 3D, GeneQuest, MegAlign Pro</td>
<td>Windows: C:\Program Data\DNASTAR\DataManager</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Macintosh: ~/Library/Application Support/DNASTAR/DataManager,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>~/Library/Preferences/DNASTAR/DataManager,</td>
</tr>
<tr>
<td>License Manager &lt;sup&gt;2&lt;/sup&gt;</td>
<td>All</td>
<td>Windows: C:\Program Files (x86)\DNASTAR\License Manager</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Macintosh: /Applications/DNASTAR/LicenseManager</td>
</tr>
<tr>
<td>Server License File (&lt;em&gt;lservrc&lt;/em&gt;), Server License Manager &lt;sup&gt;2&lt;/sup&gt;, &lt;em&gt;Server Executables (_lserv, lservnt.exe&lt;/em&gt;)</td>
<td>All</td>
<td>Windows: C:\Program Files (x86)\DNASTAR-LicenseServer\Server</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Macintosh: ~/Library/DNASTAR-LicenseServer</td>
</tr>
</tbody>
</table>
| Standalone & Trial Licenses (*.license), License Server Client License (*.lshost), Key Server Client License (*.keyhost) | All | Windows: `C:\Program Data\DNASTAR\Licenses`  
Macintosh: `~/Library/Application Support/DNASTAR/Licenses` |
|---|---|---|
| Preferences | Protean 3D, Navigator, SeqNinja (DNA*), GenVision Pro | Windows: `C:\Users\<user>\DNASTAR`  
Macintosh: `~/Library/DNASTAR` |
|  | ArrayStar | Windows: `C:\Users\<User>\AppData\Roaming\DNASTAR\ArrayStar` |
|  | All others | Windows: `C:\Users\<user>\AppData\Local\DNASTAR\`  
Macintosh: `~/Library/Preferences` |

*AppData is a hidden folder in Windows. To unhide the folder, go to Organize > Folder and Search Options > View > Show Hidden files and folders.*
Research references


NlpE Overproduction on Multidrug Resistance in Escherichia coli.” Antimicrobial agents and chemotherapy. 54. 2239-43. 10.1128/AAC.01677-09. View on PubMed


Waterhouse AM, Procter JB, Martin DMA, Clamp M and Barton GJ (2009). “JalView version 2: a multiple sequence alignment and analysis workbench.” Bioinformatics 25:1189 – 1191. (See on PMC.) [Discusses methodology later used to create the “Taylor” and “Zappo” color schemes]